Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 105402 - rp-pppoe fails on AMD64 2005.1 installcd
Summary: rp-pppoe fails on AMD64 2005.1 installcd
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2005-09-09 09:40 UTC by Gleb Litvjak
Modified: 2006-03-17 09:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Gleb Litvjak 2005-09-09 09:40:17 UTC
I have a pppoe connection. I booted from 2005.1 LiveCD and followed the 
standard procedure to configure rp-pppoe. When I run "adsl-start", it timed 
out. To see more output, I ran "adsl-connect", which told me it recieved 
signal 11. 
My NICs are Realtek 8139too and via_velocity, both work when I boot from 
LiveCD (pinged my laptop). rp-pppoe works fine from any x86 livecd. 

Reproducible: Always
Steps to Reproduce:
1. Boot from the AMD64 liveCD   
2. Setup a pppoe connection using "adsl-setup"  
3. Connect 
Actual Results:  
adsl-start fails ot connect 

Expected Results:  
adsl-start should connect
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2005-09-09 10:39:31 UTC
What error message are you getting exactly?
Comment 2 Gleb Litvjak 2005-09-09 11:24:24 UTC
adsl-connect wrote "Recieved signal 11" iirc. I will now reboot and run it 
again to get the exact message. 
Comment 3 Gleb Litvjak 2005-09-09 11:44:58 UTC
adsl-connect says: 
Using interface ppp0 
Connect: ppp0<-->/dev/pts/0 
Fatal signal 11 
pppoe: read (asyncReadFromPPP):session 846: Input/output error 
Comment 4 Danny van Dyk (RETIRED) gentoo-dev 2005-10-04 13:41:36 UTC
I cannot try to reproduce this without major changes to my equipment here, heh :-)

ATs: Could one of you please try to reproduce this bug? TIA!
Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-21 07:06:17 UTC
Can you please verify that this is still an issue with the 2005.1-r1 CD that was
just released?
Comment 6 Gleb Litvjak 2005-11-25 06:49:18 UTC
Unfortunately, adsl-connect still gets signal 11 even with 2005.1 
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2005-11-26 15:50:14 UTC
Sorry, even with the 2005.1-r1 CD?  There was a media refresh done last week.
Comment 8 Gleb Litvjak 2005-11-26 23:10:56 UTC
Yes, even with the 2005.1-r1 minimal. 
BTW, next week I'm switching to another ISP and thus won't be able to reproduce 
the error. 
Comment 9 Scott Stoddard (RETIRED) gentoo-dev 2006-03-12 18:23:45 UTC
Can anyone verify that this is still a problem with 2006.0?
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2006-03-17 09:04:26 UTC
Unfortunately, since none of us have the ability to test this, I'm going to mark it NEEDINFO.  If someone else comes up with the ability to test this, feel free to comment one way or the other and we can REOPEN it.