Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 104992 - after emerging gcc-3.3.6: internal compiler error: Segmentation fault (not a hardware problem)
Summary: after emerging gcc-3.3.6: internal compiler error: Segmentation fault (not a ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Please assign to toolchain
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-06 03:31 UTC by Jan van Oorschot
Modified: 2005-10-08 16:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
compiler pre-proc output (ccv2jfqe.out,214.07 KB, text/plain)
2005-09-06 03:33 UTC, Jan van Oorschot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan van Oorschot 2005-09-06 03:31:54 UTC
After emerging gcc-3.3.6, other emerges fail with a segmentation fault. This is
my main server machine, been running since 2 years. A memory/hardware problem is
unlikely, since the box is still running stable. The segmentation fault always
occures (i think) during the link step. Rebooting the system did not help.

Reproducible: Always
Steps to Reproduce:
1.emerge glibc
2. wait until linkstep
3. segfault

Actual Results:  
system is running stable (without the new emerge)

Expected Results:  
don't do a segfault

iconv_close.c: In function `iconv_close':
iconv_close.c:37: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into
/var/tmp/portage/glibc-2.3.5-r1/temp/ccv2jfqe.out file, please attach this to
your bugreport.

=== EMERGE INFO ===
Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.6, glibc-2.3.5-r1,
2.6.12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 1.80GHz
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=pentium4 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -pipe -march=pentium4 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 acpi alsa apache2 apm arts avi berkdb bitmap-fonts cdr crypt cups dga
directfb dvd eds emacs emboss encode ethereal foomaticdb fortran gdbm gif gpm
gstreamer imlib ipv6 java jpeg libg++ libwww mad mikmod motif mp3 mpeg ncurses
nls ogg oggvorbis opengl oss pam pdflib perl png postgres python quicktime
readline samba sdl slang snmp spell sse ssl svga tcpd threads tiff truetype
truetype-fonts type1-fonts vorbis xml2 xmms xv zlib userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY

make[2]: ***
[/var/tmp/portage/glibc-2.3.5-r1/work/build-default-i686-pc-linux-gnu-linuxthreads/iconv/iconv_close.o]
Error 1
make[2]: Leaving directory `/var/tmp/portage/glibc-2.3.5-r1/work/glibc-2.3.5/iconv'
make[1]: *** [iconv/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.5-r1/work/glibc-2.3.5'
make: *** [all] Error 2

!!! ERROR: sys-libs/glibc-2.3.5-r1 failed.
!!! Function toolchain-glibc_src_compile, Line 226, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Comment 1 Jan van Oorschot 2005-09-06 03:33:48 UTC
Created attachment 67723 [details]
compiler pre-proc output
Comment 2 Jan van Oorschot 2005-09-06 03:37:22 UTC
ps. i found this out since i was doing a 'emerge -Duv world'. The actual
segfault that woke me up was when the 'emerge world' tried to 'emerge openssh'.
Comment 3 Jan van Oorschot 2005-09-06 04:16:47 UTC
I have retried the 'emerge -Duv world' command several times, and always get the
'segmentation fault' error on the same spot (it's building
net-misc/openssh-3.9_p1-r3):

bindresvport.c: In function `bindresvport_sa':
bindresvport.c:110: internal compiler error: Segmentation fault
Comment 4 Jan van Oorschot 2005-09-06 04:51:55 UTC
ok .. i'am getting desperate. 'emerge gcc' also failes, and non of the standard
env-update/ fix_libtool_files.sh/ldconfig etc seems to help. 
Please advise how to get this system up and running again (maybe reinstall gcc
from a life-cd?).

Thanks,

Jan
Comment 5 Evert 2005-09-06 10:52:20 UTC
If I read your story, I think I'm lucky not being able to emerge gcc-3.3.6...


stage2/xgcc -Bstage2/ -B/usr/i686-pc-linux-gnu/bin/    -O2 -march=athlon-xp
-pipe -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H
-DGENERATOR_FILE  -o gengtype \
 gengtype.o gengtype-lex.o gengtype-yacc.o ../libiberty/libiberty.a
stage2/xgcc -Bstage2/ -B/usr/i686-pc-linux-gnu/bin/ -c    -O2 -march=athlon-xp
-pipe -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H
-DGENERATOR_FILE    -I. -I. -I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/.
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/config
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/../include
/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/read-rtl.c -o read-rtl.o
stage2/xgcc -Bstage2/ -B/usr/i686-pc-linux-gnu/bin/ -c    -O2 -march=athlon-xp
-pipe -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H
-DGENERATOR_FILE    -I. -I. -I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/.
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/config
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/../include
/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/gensupport.c -o gensupport.o
stage2/xgcc -Bstage2/ -B/usr/i686-pc-linux-gnu/bin/ -c    -O2 -march=athlon-xp
-pipe -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes
-Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H
-DGENERATOR_FILE    -I. -I. -I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/.
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/config
-I/compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/../include \
        /compile/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/genconditions.c -o
genconditions.o
rm -f print-rtl1.c
make[1]: *** [stage3_build] Segmentation fault
make[1]: Leaving directory `/compile/portage/gcc-3.3.6/work/build/gcc'
make: *** [bootstrap-lean] Error 2

!!! ERROR: sys-devel/gcc-3.3.6 failed.
!!! Function gcc_do_make, Line 1214, Exitcode 2
!!! emake failed with bootstrap-lean
!!! If you need support, post the topmost build error, NOT this status message.
Comment 6 Jan van Oorschot 2005-09-09 02:24:05 UTC
Well, after a few days, the following observation:

1) i can find no related posts in the gentoo forums
2) my other gentoo boxes have emerged the same compiler and work flawless
3) the mentioned server keeps running like a charm
   except it cant emerge/compile anymore
4) there are no reactions to this bug report
5) i can find no (explicit) instructions on the net how to replace the compiler
   (except a very general link in
http://forums.gentoo.org/viewtopic-t-371781-highlight-binary+gcc.html)

So i can only conclude this problem is caused by a very specific problem in the
configuration of my server. I am in the process of building a new server from
the ground up (new hardware, new gentoo install) and will phase the mentioned
server out. And yes, this new server is running the 3.3.6 compiler like a charm.

This situation has damaged my trust in gentoo somewhat. 'emerge -Duv world' is
required even on a production server (security), and being left without a
compiler is ... well not good. 

I will leave this bug open, please email me for further details. The broken
server will be in the air for at least an other week.


Comment 7 Jan van Oorschot 2005-09-23 00:27:59 UTC
the mentioned server has been decommissioned. Reproduction of the bug or further
investigation will not be possible. I'll change the status to 'WONTFIX'.
Comment 8 Evert 2005-10-08 16:13:05 UTC
For me the problem went away after:

- emerge --depclean
- revdep-rebuild
- emerge unmerge of all the package(-version)s on the system which don't exist
in portage anymore
- revdep-rebuild
- emerge --oneshot for all other installed packages
- revdep-rebuild

Well, quite an operation, but the result, a healthy up2date system :D

Oh and a week after that, I also had to do a fix_libtool_files.sh 3.3.2 for a
compilation which failed...