Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 104394 - after baselayout 1.12.x update mysql daemon tries to start before net.lo so it fails
Summary: after baselayout 1.12.x update mysql daemon tries to start before net.lo so i...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
: 106119 (view as bug list)
Depends on:
Reported: 2005-08-31 09:53 UTC by manolis
Modified: 2005-11-08 09:03 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description manolis 2005-08-31 09:53:01 UTC
after baselayout 1.12.x update mysql daemon tries to start before net.lo so it
I added in /etc/init.d/net.lo the line:

before mysql

And now it starts fine....

Reproducible: Always
Steps to Reproduce:
1.emerge baselayout-1.12.x

Actual Results:  
mysql daemon failed to start at boot time.

Expected Results:  
mysql should start after the net.lo initialization
Comment 1 Roy Marples (RETIRED) gentoo-dev 2005-08-31 10:34:27 UTC
move mysql from the boot runlevel to the default runlevel
Comment 2 manolis 2005-08-31 12:39:04 UTC
mysql IS at the default level
net.lo IS at boot level.
but after the baselayout update net.lo was loading towards the end of the boot
process even if it was at boot level
Comment 3 SpanKY gentoo-dev 2005-08-31 13:45:56 UTC
post the output of `rc-config list`
Comment 4 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2005-08-31 13:57:19 UTC
This happend to me too with some other packages from time to time.
Kernel version or netdrivers as modules seemed to have a effect on it, not 
sure if it does in your case.
Comment 5 manolis 2005-08-31 14:09:56 UTC
Available init scripts
  alsasound                 boot
  bootmisc                  boot
  checkfs                   boot
  checkroot                 boot
  clock                     boot
  coldplug                  default
  consolefont               boot
  courier-pop3d             default
  cupsd                     default
  ddclient                  default
  domainname                default
  fancontrol                default
  hdparm                    default
  hostname                  boot default
  keymaps                   boot
  lm_sensors                default
  local                     default nonetwork
  localmount                boot
  metalog                   default
  modules                   boot
  mysql                     default
  net.eth0                  default
  net.lo                    boot
  netmount                  default
  ntpd                      default
  rmnologin                 boot
  serial                    boot
  smartd                    default
  sshd                      default
  svscan                    default
  urandom                   boot
Comment 6 Marcus D. Hanwell (RETIRED) gentoo-dev 2005-09-04 09:19:22 UTC
I have encountered this issue too, currently using 
sys-apps/baselayout-1.12.0_pre8-r1 with net.lo in the boot runlevel and lo was 
started just before local at the very end. I have mysql in the default run 
level also. This is on an amd64 machine if that makes any difference at all. 
Comment 7 Roy Marples (RETIRED) gentoo-dev 2005-09-06 00:08:39 UTC
Does mysql start before you enter runlevel 3?
Does net.lo end before you enter runlevel 3?
Comment 8 Marcus D. Hanwell (RETIRED) gentoo-dev 2005-09-06 00:42:30 UTC
mysql starts in runlevel 3 as expected. Like I said before it is net.lo which
doesn't start until right at the end of runlevel 3 just before local starts and
you get the login prompt.
Comment 9 Roy Marples (RETIRED) gentoo-dev 2005-09-06 00:59:42 UTC
What's the value of RC_STRICT_NET_CHECKING in /etc/conf.d/rc?
Comment 10 Marcus D. Hanwell (RETIRED) gentoo-dev 2005-09-06 01:07:32 UTC
I have RC_NET_STRICT_CHECKING="no" which I believe was the default as set. This
still means that lo should be brought up first doesn't it?
Comment 11 manolis 2005-09-08 02:39:44 UTC
I have also RC_STRICT_NET_CHECKING set to no.
But this was the default. 
maybe a change to yes, will help?
Comment 12 Roy Marples (RETIRED) gentoo-dev 2005-09-08 03:14:50 UTC
Try setting RC_PARALLEL_STARTUP="yes".

Although it seems 100% unrelated to the issue at hand, it has cured this problem
for one user.
Comment 13 manolis 2005-09-08 03:47:50 UTC
the last time I found about
RC_PARALLEL_STARTUP and set it to "yes"
A lot o things (daemon) didn't like my decision.
It meshed up a lot of things.
Comment 14 Roy Marples (RETIRED) gentoo-dev 2005-09-08 03:59:17 UTC
We recently fixes a lot of parallel startup isses, why not try it again and see
if it helps this issue? If parallel causes issues (but not related to this bug)
then please open a new bug.

Comment 15 manolis 2005-09-08 07:09:37 UTC
Yes,  but it will be a 'workaround' not a fix.
If this can work right in the one-by-one service mode. it is unacceptable.
It maybe run fine in parallel but just from luck.
Comment 16 Shea Sanderson 2005-09-08 22:36:48 UTC
I am having the same problem of net.lo starting right before local as well
except famd is failing because of it. Tried the suggestion of
RC_PARALLEL_STARTUP="yes" and problem is cured for now, but as mentioned this is
just a work around and not a fix as the default behaviour seems to be broken.
Also this is on a x86 system so it seems to go beyond a AMD64 problem.

Comment 17 Roy Marples (RETIRED) gentoo-dev 2005-09-17 02:54:49 UTC
*** Bug 106119 has been marked as a duplicate of this bug. ***
Comment 18 RDWest 2005-09-18 20:35:10 UTC
I've tried everything here and in forums

the only workaround on my box
is setting RC_STRICT_NET_CHECKING to "yes"

and with this set to yes,
my "lo" comes up in console in run lvl 3 
right before mysql

Comment 19 RDWest 2005-09-18 20:36:57 UTC
o - and eth0 is still booting in background
eth0 don't even show up in console

Comment 20 Nir Dremer 2005-09-28 23:54:18 UTC
I'm having the same problem.

nfs & nfsmount starts before net.lo & net.eth0 and fail.

I even tried to bypass it by moving net.* to boot level and it helps only 50% of
the time, part of the boots net services still starts only at the end.

It looks like a dependency problem.

I'm using baselayout 1.12.0_pre8-r2, without parallete startup feature.
Comment 21 Ian Hubbertz 2005-10-13 03:06:20 UTC
Actually, this also affects samba if it is configured to work with cups, as
samba cannot reach the cups server.

net.lo is started AFTER init.d/local.

Another weired thing is that also the dhcpcd started very late (after local and
and even net.lo!), but a IP address is assigned with DHCP very early ?!
Comment 22 Roy Marples (RETIRED) gentoo-dev 2005-11-08 09:03:08 UTC
All righty then - I think I've found the problem.

Either a baselayout ebuild or a stage3 tarball has placed invalid default links
in /etc/runlevels.

baselayout-1.12.0_pre10 ships with an improved rc-status that will display the
word "broken" for broken runlevel links regardless of if it's
started/stopped/whatever. If you see a broken link here's how you fix it :

rc-update del $service
rc-update add $service $runlevel
(where $service is the broken service and $runlevel is the runlevel it was
broken in)

If that fails to fix it, please download this script
Into /etc/init.d, start it and then attach the results here.

Re-open this bug too ....