Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 103869 - cannot build dev-libs/qsa-1.1.1
Summary: cannot build dev-libs/qsa-1.1.1
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-26 19:18 UTC by Marcin Slusarz
Modified: 2007-04-02 18:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Slusarz 2005-08-26 19:18:16 UTC
joi ~ # emerge -pv qsa

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] dev-libs/qsa-1.1.1  +doc -examples -ide +threads 0 kB

Total size of downloads: 0 kB
joi ~ # emerge qsa
Calculating dependencies ...done!
>>> emerge (1 of 1) dev-libs/qsa-1.1.1 to /
>>> md5 files   ;-) qsa-1.0.1.ebuild
>>> md5 files   ;-) qsa-1.1.1.ebuild
>>> md5 files   ;-) files/digest-qsa-1.0.1
>>> md5 files   ;-) files/digest-qsa-1.1.1
>>> md5 files   ;-) files/qsa-1.1.1-example-enums.pro.diff
>>> md5 files   ;-) files/qsa-1.0.1-no-examples.diff
>>> md5 files   ;-) files/qsa-1.0.1-sandbox-fix.diff
>>> md5 files   ;-) files/qsa-1.1.1-without-examples.diff
>>> md5 files   ;-) files/qsa-1.1.1-sandbox-fix.diff
>>> md5 files   ;-) files/qsa-1.1.1-with-examples.diff
>>> md5 files   ;-) files/qsa-1.1.1-without-examples-using-ide.diff
>>> md5 src_uri ;-) qsa-x11-free-1.1.1.tar.gz
>>> Unpacking source...
>>> Unpacking qsa-x11-free-1.1.1.tar.gz to /var/tmp/portage/qsa-1.1.1/work
>>> Source unpacked.
 * Applying qsa-1.1.1-without-examples-using-ide.diff ...                      
                                                    [ ok ]
 * Applying qsa-1.1.1-without-examples.diff ...                                
                                                    [ ok ]
 * Applying qsa-1.1.1-sandbox-fix.diff ...                                     
                                                    [ ok ]
Using Qt library in /usr/qt/3.
Building 2nd stage configure
In file included from main.cpp:29:
configutils.h:4:21: qstring.h: Nie ma takiego pliku ani katalogu (which means:
No such file or directory)
configutils.h:5:25: qstringlist.h: Nie ma takiego pliku ani katalogu
configutils.h:6:18: qdir.h: Nie ma takiego pliku ani katalogu
In file included from main.cpp:29:
configutils.h:8: error: expected init-declarator before '*' token
configutils.h:8: error: expected `,' or `;' before '*' token
configutils.h:15: error: expected `,' or `...' before '&' token
configutils.h:15: error: ISO C++ forbids declaration of `QString' with no type
configutils.h:16: error: `QStringList' does not name a type
configutils.h:18: error: `QString' does not name a type
configutils.h:21: error: expected `,' or `...' before '&' token
configutils.h:21: error: ISO C++ forbids declaration of `QStringList' with no type
configutils.h:24: error: expected `,' or `...' before '&' token
configutils.h:24: error: ISO C++ forbids declaration of `QString' with no type
configutils.h:25: error: expected `,' or `...' before '&' token
configutils.h:25: error: ISO C++ forbids declaration of `QString' with no type
configutils.h:26: error: expected `,' or `...' before '&' token
configutils.h:26: error: ISO C++ forbids declaration of `QString' with no type
configutils.h:29: error: `uint' does not name a type
configutils.h:30: error: expected `,' or `...' before '&' token
configutils.h:30: error: ISO C++ forbids declaration of `QDir' with no type
main.cpp:31:19: qfile.h: Nie ma takiego pliku ani katalogu
main.cpp:32:22: qprocess.h: Nie ma takiego pliku ani katalogu
main.cpp:35:21: qregexp.h: Nie ma takiego pliku ani katalogu
main.cpp:36:26: qapplication.h: Nie ma takiego pliku ani katalogu
main.cpp: In function `void dumpMessages()':
main.cpp:46: error: `messages' undeclared (first use this function)
main.cpp:46: error: (Each undeclared identifier is reported only once for each
function it appears in.)
main.cpp:46: error: `qWarning' undeclared (first use this function)
main.cpp: In function `int main(int, char**)':
main.cpp:53: error: `QApplication' undeclared (first use this function)
main.cpp:53: error: expected `;' before "qapp"
main.cpp:55: error: `QStringList' undeclared (first use this function)
main.cpp:55: error: expected `;' before "configs"
main.cpp:56: error: `QString' undeclared (first use this function)
main.cpp:56: error: expected `;' before "prefix"
main.cpp:57: error: `TRUE' undeclared (first use this function)
main.cpp:58: error: `qapp' undeclared (first use this function)
main.cpp:59: error: expected `;' before "arg"
main.cpp:60: error: `arg' undeclared (first use this function)
main.cpp:65: error: `configs' undeclared (first use this function)
main.cpp:68: error: `prefix' undeclared (first use this function)
main.cpp:70: error: `qWarning' undeclared (first use this function)
main.cpp:74: error: `FALSE' undeclared (first use this function)
main.cpp:96: error: `qtDir' undeclared (first use this function)
main.cpp:96: error: `QString' has not been declared
main.cpp:123: error: invalid conversion from `const char*' to `int'
main.cpp:123: error:   initializing argument 1 of `void message(int)'
main.cpp:128: error: invalid conversion from `const char*' to `int'
main.cpp:128: error:   initializing argument 1 of `void message(int)'
main.cpp:132: error: invalid conversion from `const char*' to `int'
main.cpp:132: error:   initializing argument 1 of `void message(int)'
main.cpp: At global scope:
main.cpp:51: warning: unused parameter 'argc'
make: *** [.obj/release-shared-mt/main.o] Błąd 1

!!! ERROR: dev-libs/qsa-1.1.1 failed.
!!! Function src_compile, Line 38, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.



Reproducible: Always
Steps to Reproduce:




joi ~ # emerge info
Portage 2.0.51.22-r2 (default-linux/amd64/2004.3, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-static x86_64)
=================================================================
System uname: 2.6.12-gentoo-static x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr//lib/mozilla/defaults/pref /usr/kde/2/share/config
/usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl/ http://src.gentoo.pl
http://gentoo.zie.pg.gda.pl/"
LANG="pl_PL"
LC_ALL="pl_PL"
LINGUAS="pl"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X adns alsa arts avi berkdb bitmap-fonts bzip2 cdr crypt cups curl dv
dvd dvdr dvdread eds encode esd fam fbcon flac foomaticdb fortran ftp gif gnutls
gpm gstreamer gtk gtk2 imagemagick imlib ipv6 jabber java javascript jpeg junit
kde kdeenablefinal libwww lzw lzw-tiff mad matroska mikmod mmap mng motif
mozilla mp3 mpeg multilib mysql nas ncurses nls nptl nvidia ogg oggvorbis opengl
oss pam pdflib perl png python qt quicktime readline samba sdl slang sndfile sox
speex spell sqlite ssl svg tcltk tcpd tetex theora threads tiff truetype
truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 vcd vorbis xine xml2
xmms xosd xpm xv xvid zlib linguas_pl userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, MAKEOPTS

joi ~ # emerge -pv qt

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] x11-libs/qt-3.3.4-r3  +cups -debug +doc -examples (-firebird)
+gif -immqt -immqt-bc +ipv6 +mysql +nas -odbc +opengl -postgres +sqlite
-xinerama +zlib 0 kB

Total size of downloads: 0 kB

joi ~ # echo $QTDIR
/usr/qt/3

joi ~ # ls -l /usr/qt/3/include/qstring.h
-rw-r--r--  1 root root 36200 lip 29 10:49 /usr/qt/3/include/qstring.h
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2005-09-19 19:30:05 UTC
do you by chance have qt4 installed?
Comment 2 Marcin Slusarz 2005-09-20 14:36:52 UTC
i don't have qt4

strange, but moving out $QTDIR/.qmake.cache helped...
i don't know why, but .qmake.cache contains strange paths - most of them lead to
/var/tmp/portage/qt-3.3.4-r3/work/qt-x11-free-3.3.4/ (i can attach it here if
necessary)

(actually paths lead to /dane/tmp/portage/ because on my system /var/tmp is a
symbolic link to /dane/tmp, i don't think that matters)


$ epm -ql qt | grep qmake.cache
/usr/qt/3/.qmake.cache

so it looks like there is a bug in qt ebuild
Comment 3 Gregorio Guidi (RETIRED) gentoo-dev 2005-10-18 08:41:28 UTC
Have you tried to see if .qmake.cache is still incorrect after recompiling qt? 
 
Comment 4 Marcin Slusarz 2005-10-18 11:45:36 UTC
joi ~ # cd $QTDIR
joi 3 # pwd
/usr/qt/3
joi 3 # mv .qmake.cache .qmake.cache.old
joi 3 # emerge -pv qt

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] x11-libs/qt-3.3.4-r8  +cups -debug +doc -examples (-firebird)
+gif -immqt -immqt-bc +ipv6 +mysql +nas -odbc +opengl -postgres +sqlite
-xinerama 0 kB

Total size of downloads: 0 kB
joi 3 # emerge qt
(...)
joi 3 # grep portage .qmake.cache
QT_SOURCE_TREE = /dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4
QT_BUILD_TREE = /dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4
QMAKE_MOC=/dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4/bin/moc
QMAKE_UIC=/dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4/bin/uic -L
$$QT_BUILD_TREE/plugins
QMAKE_QMAKE=/dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4/bin/qmake
QMAKE_MOC_SRC=/dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4/src/moc
QMAKE_INCDIR_QT=/dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4/include
QMAKE_LIBDIR_QT=/dane/tmp/portage/qt-3.3.4-r8/work/qt-x11-free-3.3.4/lib
joi 3 #

probably this line in qt ebuild might be the reason:
    sed -e "s:${S}:${QTBASE}:g" \
        ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-04-02 18:57:10 UTC
Please try qsa-1.1.5 and reopen if the problem persists.