Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 103810 - beep-media-player chokes on wav files > 2 gigabyte
Summary: beep-media-player chokes on wav files > 2 gigabyte
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-26 02:36 UTC by Wernfried Haas (RETIRED)
Modified: 2005-10-18 12:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wernfried Haas (RETIRED) gentoo-dev 2005-08-26 02:36:14 UTC
The slightly oversized 2.5 gig wav file
(https://bugs.gentoo.org/attachment.cgi?id=66745) from bug 103578 also doesn't
work in beep-media-player, seems to be another victim of largefile support.

Reproducible: Always
Steps to Reproduce:
emerge bmp, get the attachment, bunzip2 it, play it with bmp.
Actual Results:  
A Window popped up and told me it could not be played.


Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.5-r1, 2.6.12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 AMD Sempron(tm) 2500+
Gentoo Base System version 1.6.13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy distlocks sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gentoo.inode.at/source/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 3dnow X aalib alsa apm atm avi berkdb bitmap-fonts cdr crypt cups curl
dvd emacs emboss encode esd fam flac foomaticdb fortran gd gdbm ggi gif gphoto2
gpm gstreamer gtk gtk2 guile icq imagemagick imlib ipv6 irda java jpeg kde
libg++ libwww live mad mikmod mmx motif mozilla mp3 mpeg ncurses nls nptl
offensive ogg oggvorbis opengl oss pam pdflib perl phyton png python qt
quicktime qz readline real ruby samba sdl slang snmp spell sse ssl tcltk tcpd
tiff truetype truetype-fonts type1-fonts vorbis wmf xine xinetd xml xml2 xmms xv
xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-08-26 02:41:32 UTC

*** This bug has been marked as a duplicate of 103578 ***
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-08-26 03:05:59 UTC
Better having a different bug... 
Comment 3 Tony Vroon gentoo-dev 2005-10-16 05:27:49 UTC
Reassigning bug to me. Why was this not assigned to the primary maintainer?
Comment 4 Tony Vroon gentoo-dev 2005-10-18 12:04:50 UTC
No easy way out; explodes as follows:
append-flags "-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"

if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -pthread
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0   -I/usr/include/libglade-2.0 -I/usr/include/gtk-2.0
-I/usr/include/libxml2 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -O2 -march=pentium3m -pipe -fomit-frame-pointer
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Wall -Wpointer-arith
-finline-functions -ffast-math -fomit-frame-pointer -funroll-all-loops
-DDATA_DIR=\"/usr/share/bmp\" -DPLUGIN_DIR=\"/usr/lib/bmp\"
-DPLUGINSUBS=\"Output\",\"Input\",\"Effect\",\"General\",\"Visualization\"
-DLOCALEDIR=\"/usr/share/locale\" -DI386_ASSEM -I../intl -I.. -DORBIT2=1
-pthread -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include    -O2 -march=pentium3m -pipe -fomit-frame-pointer
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Wall -Wpointer-arith
-finline-functions -ffast-math -fomit-frame-pointer -funroll-all-loops  -MT
beep-util.o -MD -MP -MF ".deps/beep-util.Tpo" -c -o beep-util.o `test -f
'util.c' || echo './'`util.c; \
then mv -f ".deps/beep-util.Tpo" ".deps/beep-util.Po"; else rm -f
".deps/beep-util.Tpo"; exit 1; fi
In file included from util.c:47:
/usr/include/fts.h:41:3: #error "<fts.h> cannot be used with
-D_FILE_OFFSET_BITS==64"
make[4]: *** [beep-util.o] Error 1

Upstream will make one last 0.9.7.1 release, which may or may not include this.
If it doesn't, please attach a working patch and reopen.