Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 102425 - revdep-rebuild take packages out of the world file
Summary: revdep-rebuild take packages out of the world file
Status: VERIFIED INVALID
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-13 13:38 UTC by Romary Sonrier
Modified: 2005-08-13 13:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge sl, then check world file, then emerge --oneshot sl, then check world file again. (typescript,7.36 KB, text/plain)
2005-08-13 13:49 UTC, Alec Warner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Romary Sonrier 2005-08-13 13:38:55 UTC
I suggest that this tool should not emerge broken binaries with the "--oneshot"
option by default.What's more revdep-rebuild does not take into account any
option to disable this behaviour.
I can understand that this behaviour may reduce the chance to get broken thoses
binaries again.
In fact , using  this option "--oneshot" change the world file and some packages
are not updated with a "emerge -u world".

So my question is : did i misunderstood something important ? or the issue this
has been identified but not yet corrected?

thanks in adavance for any help /advices

Romary Sonrier

Reproducible: Always
Steps to Reproduce:
1.revdep-rebuild


Actual Results:  
broken packages are emerged with the --oneshot option

Expected Results:  
broken packages should not be emerged with the --oneshot option by default. An
option should make possible to activite the --oneshot option.
Comment 1 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-08-13 13:46:02 UTC
Revdep-rebuild is used to rebuild currently installed programs when they are 
missing dependent libaries.  --oneshot is used because if it is not used, all 
the dependencies that were broken get added to /var/lib/portage/world.  This is 
bad, because it causes emerge --depclean to not function properly.  All of those 
dependencies would have to be removed by hand, which defeats the whole point of 
portage not adding dependencies to the world file.

Furthermore, if pkgA is installed ( emerge pkgA ) and then it is installed again 
with --oneshot ( emerge --oneshot pkgA ) then that package is not removed from /
var/lib/portage/world, as illustrated by the attachmenet I will attach in a 
moment.  Feel free to duplicate the behavior and if yours differs, to re-open 
the bug.
Comment 2 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-08-13 13:49:34 UTC
Created attachment 65874 [details]
emerge sl, then check world file, then emerge --oneshot sl, then check world file again.
Comment 3 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-08-13 13:50:07 UTC
This should be correct behavior.
Comment 4 Romary Sonrier 2005-08-13 13:59:41 UTC
Your are right, --onshot doesn't change worlde file...