Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 102198 - In xine-lib you disable the asf demultiplexer if win32codecs isnt enabled
Summary: In xine-lib you disable the asf demultiplexer if win32codecs isnt enabled
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 104294 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-12 01:00 UTC by Redeeman
Modified: 2005-08-31 14:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Redeeman 2005-08-12 01:00:57 UTC
in xine-lib 1.1 you are disabling the asf demultiplexer if one does not have 
win32codecs in use. when doing this, wmv/wma files can not be played, since 
wmv/wma is just an alias for the asf container format. dont do this!!!!!!!!! 
 

Reproducible: Always
Steps to Reproduce:
 



simply remove that else, and change it to enable-asf.
Comment 1 Joe Kappus 2005-08-13 21:58:50 UTC
yeah.. that happens here.. but i'm a bit drunk, so someone else should confirm.
Comment 2 Joe Kappus 2005-08-13 22:17:45 UTC
redeeman unsatisfied with comment.. joecool unsatisfied with redeeman bitching,
which is much like having 20 people bitch at once about a problem.  Er,
confirming to get redeeman off back.  Hurry with this devs I can't stand no longer!!
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-08-14 01:33:03 UTC
You need asf demux only if you enable win32codecs, without it the asf demux is 
pointless. 
 
Comment 4 Redeeman 2005-08-14 10:28:24 UTC
no, you are wrong, wrong, wrong! asf demux is used for wma and wmv, (streaming 
wma for example), and ffmpeg includes a windows media audio 2/3 decoder, which 
you can only use with asf demux, and you DONT need win32codecs for that 
Comment 5 Redeeman 2005-08-14 10:28:59 UTC
(and xine-lib has ffmpeg included) 
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-08-30 12:45:10 UTC
*** Bug 104294 has been marked as a duplicate of this bug. ***
Comment 7 Redeeman 2005-08-30 15:16:10 UTC
i dont want to be inpatient, but this is a fairly big showstopper for amd64, 
and very easy to fix, i think you should consider changing it now 
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-08-30 19:05:23 UTC
It crashes on 90% systems while using ffmpeg decoding.
Sorry, as I said already, I will *not* consider this until it works fine upstream. Right now is a no-go, not a 
showstopper.
I'll continue checking for new versions, but until this is sorted up upstream it *will* be disabled where 
win32codecs can't be enabled (so everything but x86).
If you want this enabled, work on xine-lib or ffmpeg sources and let it work fine in every case, right now it 
does not.
Comment 9 Andrei Slavoiu 2005-08-31 02:28:39 UTC
So just because it works only in 10% of the cases you decided to break it for 
them too? I just don't see the logic here. It would be better to put a warning 
when emerging xine-lib that asf playback may not work without win32codecs. 
 
P.S. I'm one of the 10%. 
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-08-31 02:40:07 UTC
Let me picture you what will happen if I leave it selectable: people start 
using it thinking of being able to use it everytime. 
People get crashes. 
They come to me complaining about this. 
 
Instead, leaving it disabled, the ones who REALLY want to mess with code that 
works 1 time on 10, can just use EXTRA_ECONF to enable it while merging 
xine-lib (and lose every hope to get support from gentoo about crashes). 
 
Comment 11 Luca Barbato gentoo-dev 2005-08-31 05:53:05 UTC
Features that aren't stable enough could stay in p.mask packages, surely not ~
ones...
Comment 12 Redeeman 2005-08-31 14:45:37 UTC
xine-lib 1.1 includes ffmpeg, where it works. and you should know, that even 
on x86 that same demultiplexer and decoder for wmv7 and wma2 is used OVER the 
win32codecs, where they also works fine.. 
 
i tried on 6 amd64 boxes, all worked with it 
 
i think you have problems on the computers you test on, cause i dont have 
them. are you sure your own cflags arent abit too agressive? anyway.. while i 
do not particularly care about this, because i am easily able to do the 
modification myself, others might like this. i am only filing this bug to do 
you and other gentoo users a favour..