Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 101906 - keyboard does not work after upgrade to 2.6.12-gentoo-r6
Summary: keyboard does not work after upgrade to 2.6.12-gentoo-r6
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-08-09 14:58 UTC by Erik Quaeghebeur
Modified: 2005-09-17 10:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

.config file used for compilation of 2.6.12-gentoo-r6 kernel (.config,28.70 KB, text/plain)
2005-08-10 04:44 UTC, Erik Quaeghebeur
.config used for 2.6.12-gentoo-r6 kernel compilation after "make oldconfig" (.config,28.87 KB, text/plain)
2005-08-10 06:12 UTC, Erik Quaeghebeur
dmesg when booting with atkbd built in (dmesg-atkbd-built-in.txt,14.00 KB, text/plain)
2005-08-23 12:47 UTC, Erik Quaeghebeur
dmesg when booting with atkbd as module (dmesg-atkbd-as-module.txt,13.75 KB, text/plain)
2005-08-23 12:48 UTC, Erik Quaeghebeur
diff dmesg-atkbd-built-in.txt dmesg-atkbd-as-module (diff-builtin-asmodule.txt,1.84 KB, text/plain)
2005-08-23 12:51 UTC, Erik Quaeghebeur

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Quaeghebeur 2005-08-09 14:58:27 UTC
After uprading from kernel 2.6.11-gentoo-r11 to 2.6.12-gentoo-r6, my keyboard
does not work anymore during boot (after grub).  Similar problems were reported
in the forums (  The solution
proposed there (setting "Legacy USB" to 'off' in bios) does not work for me.

Reproducible: Always
Steps to Reproduce:
1. emerge gentoo-sources
2. copy .config from previous kernel
3. make && make modules_install; install new kernel in /boot; modify grub.conf
4. reboot with new kernel

Actual Results:  
keyboards does not work (also no SHIFT-PGUP during boot)

Expected Results:  
working keyboard
Comment 1 Simon Stelling (RETIRED) gentoo-dev 2005-08-09 15:03:32 UTC
> 2. copy .config from previous kernel
> 3. make && make modules_install; install new kernel in /boot; modify grub.conf

Did you do make oldconfig?
Comment 2 Andy Kissner 2005-08-09 15:58:05 UTC
It sounds like you're using a USB keyboard?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-08-10 02:59:56 UTC
*Attach* your kernel .config, also you need to run 'make .oldconfig' (which is
not really that much recommended anyway between different kernel versions).
Comment 4 Erik Quaeghebeur 2005-08-10 04:44:31 UTC
Created attachment 65590 [details]
.config file used for compilation of 2.6.12-gentoo-r6 kernel
Comment 5 Erik Quaeghebeur 2005-08-10 04:51:49 UTC
A PS/2 keyboard, no USB keyboard.
Usually module 'atkb' is coldplugged; explicitly autoloading it did not help.
Was not aware of "make oldconfig", will try and report back.
Comment 6 Erik Quaeghebeur 2005-08-10 06:12:25 UTC
Created attachment 65597 [details]
.config used for 2.6.12-gentoo-r6 kernel compilation after "make oldconfig"

This .config file was created by running "make oldconfig" on the .config file
for the 2.6.11-gentoo-r11 kernel.  The previous one was a version modified with
"make menuconfig".

The result is still the same: my PS/2 keyboard does not work after grub.
Comment 7 Erik Quaeghebeur 2005-08-10 06:16:03 UTC
Requested info given, reopening bug (please tell me if this is not for me to judge).
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-08-10 06:28:49 UTC
Hmm, don't know what's wrong here. Compiling keyboard support as a module seems
like a bad idea to me in any case. 
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2005-08-10 06:40:08 UTC
Yes, please compile keyboard support as built-in. See if that helps.

Do you have any USB keyboards which you could try? Do you have other machines on
your network that could SSH into your dead-keyboard-PC and obtain some logs?

When you say 'keyboard does not work', I assume you mean you can't type
anything. Do the caps lock / num lock lights operate as normal? Are any of them
on by default?
Comment 10 Erik Quaeghebeur 2005-08-10 08:37:36 UTC
Compiling atkbd in the kernel and not as a module seems to resolve the problem.
 What's the use of modules, if... this is probably a bug for the people at

No other keyboard/computer available to do other tests.

*LOCK keys don't work, leds keep status specified in bios.
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2005-08-12 09:23:25 UTC
Although building something as core as the keyboard driver as a module doesn't
make any sense, this does look like a minor bug.

Please see if you can reproduce it with vanilla-sources-2.6.13_rc6 (atkbd built
as a module, automatically loaded on bootup). If so, we can take the appropriate
steps towards getting it reported upstream.
Comment 12 Erik Quaeghebeur 2005-08-17 12:52:19 UTC
I tried vanilla-sources-2.6.13_rc6: (make oldconfig, all defaults)
* built-in: keyboard works (expected);
* module, coldboot: keyboard does not work (atkbd loaded?);
* module, autoload: keyboard does not work (atkbd loaded according to bootup

When I talk about "keyboard does not work", everything is as described by my
previous comments.

Please advise on further action on my part if necessary. 
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2005-08-18 10:12:01 UTC
If you remove the .config file, and then run "make menuconfig", are you able to
select atkbd as a module? I have tried to do this and it will not let me. I
think this is because atkbd is always on for PC-machines.
Comment 14 Erik Quaeghebeur 2005-08-18 11:19:34 UTC
Yes, I can select atkbd as a module or compiled-in starting with a clean "make
menuconfig" (default is compiled-in).
Comment 15 Daniel Drake (RETIRED) gentoo-dev 2005-08-19 16:46:18 UTC
Ah, thats an AMD64-ism. I got another AMD64 person to test this and it worked
fine as a module.

We now need to compare dmesg logs from the built-in and the modular kernel.
Please build atkbd into the kernel, boot 2.6.13-rc6, and save your dmesg, i.e.:
    # dmesg > dmesg-atkbd-built-in.txt

Attach this file to this bug.

Then, compile atkbd as a module, add it to /etc/modules.autoload.d/kernel-2.6,
copy over the updated bzImage. You now need to reboot into the broken kernel and
run the same command without being able to type! If you are able to SSH in from
a networked machine and save the dmesg to a file in a similar manner as above,
then thats easiest. If not, you can set it to be automatically saved at boot as

Edit /etc/conf.d/local.start and add the following line at the end of the file:

    dmesg > /tmp/dmesg-$(date +%s).txt

Now you can reboot into the broken 2.6.13-rc6 kernel. As soon as you see the
login prompt, reboot into a known working file, and remove that line from

You'll now have two files in /tmp with name dmesg-XXXX.txt (where XXXX is a big
number). Take the _first_ one and attach it here.

Comment 16 Chris Xe 2005-08-22 19:25:17 UTC
(In reply to comment #15) 
> Ah, thats an AMD64-ism. 
I wouldn't be so certain of that... 
I have a Compaq DL 380 server which is running great: 
Linux filestore 2.6.12-gentoo-r4 #1 SMP Wed Jul 27 18:32:55 PDT 2005 i686 
Intel(R) Xeon(TM) CPU 3.20GHz GenuineIntel GNU/Linux 
...except for the fact that the PS/2 keyboard does not do anything once grub 
hands over control. I plugged in a USB keyboard into this machine and that 
works fine (damn inconvenient). I figured it was an issue of exotic hardware. 
But it happened again. I use a USB keyboard but I keep a PS2 (normal) keyboard 
around for guests. I went to use that on a Dell Dimension and I realized that 
the PS2 keyboard was dead there too: 
Linux mindnoise #2 SMP Sat Aug 20 11:21:01 PDT 2005 i686 Intel(R) 
Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux 
This machine was recently changed to the 2005.1 profile. 
So that's 2 non AMD64 machines that have this exact problem. I've tried 
compiling all the keyboard things (that I could find) directly into the 
kernel. Any help would be appreciated. If you would like more information from 
me, let me know specifically what you're looking for. 
Thanks and good luck with this one. 
Comment 17 Daniel Drake (RETIRED) gentoo-dev 2005-08-23 01:03:51 UTC
Chris: No, thats a different problem.

Erik's keyboard works when he compiles keyboard support into his kernel, but
does not work when it is an autoloaded module. Erik is on AMD64.

On x86 you simply cannot compile atkbd as a module. Thats what I meant by "its
an AMD64ism" - the fact that you can even try modular keyboard support... (I was
trying to reproduce the bug on my x86 system, but was unable to do this for this

Feel free to open a new bug for your problem.
Comment 18 Erik Quaeghebeur 2005-08-23 12:47:29 UTC
Created attachment 66680 [details]
dmesg when booting with atkbd built in
Comment 19 Erik Quaeghebeur 2005-08-23 12:48:20 UTC
Created attachment 66681 [details]
dmesg when booting with atkbd as module
Comment 20 Erik Quaeghebeur 2005-08-23 12:51:50 UTC
Created attachment 66682 [details]
diff dmesg-atkbd-built-in.txt dmesg-atkbd-as-module
Comment 21 Daniel Drake (RETIRED) gentoo-dev 2005-08-30 04:41:19 UTC
Ok, please file this bug against 2.6.13-rc6 at and
post the new bug URL here.
Comment 22 Erik Quaeghebeur 2005-08-30 11:37:46 UTC
Submitted bug at <>.
Comment 23 Dmitry Torokhov 2005-08-30 12:05:06 UTC
I don't think that the following config is allowed:

# Hardware I/O ports

Did you edit your .config by hand?
Comment 24 Daniel Drake (RETIRED) gentoo-dev 2005-08-30 16:24:54 UTC
Will track upstream bug, thanks Dmitry