Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 101715 - NX 1.5.0 has been released
Summary: NX 1.5.0 has been released
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
: 103061 (view as bug list)
Depends on:
Blocks: 63757 82330
  Show dependency tree
 
Reported: 2005-08-08 02:30 UTC by Jon Severinsson
Modified: 2006-03-05 06:21 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nx-x11-1.5.0 ebuild (nx-x11-1.5.0.ebuild,2.22 KB, text/plain)
2005-08-08 02:41 UTC, Jon Severinsson
Details
nx-x11-1.5.0.ebuild (nx-x11-1.5.0.ebuild,2.30 KB, text/plain)
2005-08-08 02:43 UTC, Jon Severinsson
Details
nxproxy-1.5.0.ebuild (nxproxy-1.5.0.ebuild,687 bytes, text/plain)
2005-08-08 02:43 UTC, Jon Severinsson
Details
nxssh-1.5.0 ebuild (nxssh-1.5.0.ebuild,1.87 KB, text/plain)
2005-08-08 02:44 UTC, Jon Severinsson
Details
nxesd-1.5.0 ebuild (nxesd-1.5.0.ebuild,829 bytes, text/plain)
2005-08-08 02:44 UTC, Jon Severinsson
Details
nxclient-1.5.0 ebuild (nxclient-1.5.0.ebuild,1.42 KB, text/plain)
2005-08-08 02:45 UTC, Jon Severinsson
Details
nxcomp-1.5.0 ebuild (nxcomp-1.5.0.ebuild,726 bytes, text/plain)
2005-08-08 02:46 UTC, Jon Severinsson
Details
Patch to use the nxcomp ebuild (patch-nxcomp-1.5.diff,2.09 KB, patch)
2005-08-08 02:47 UTC, Jon Severinsson
Details | Diff
freenx-1.5.0.ebuilds compressed overlay (net-misc.tar.bz2,5.86 KB, application/x-bzip)
2005-08-28 11:30 UTC, Rumen Yotov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Severinsson 2005-08-08 02:30:39 UTC
OK, I have taken some time to create propperly working 1.5.0 ebuilds. They
include everyting needed for nxserver-freenx, including nxclient, but they does
not include the commercial nxservers.

First some information about the upstream update:
nxproxy has ben depricated, as nxssh now has the client features of nxproxy
built in, and nxagent now supports rootles mode (nxproxy's serverside feature).
Freenx 0.4.x still requires nxproxy unless the config file is edited, so a
nxproxy ebuild is supplied, the important part is to notice that nxclient
doesn't depend on nxproxy, and nxssh now depends on nxcomp.
Secondly is the sound issue, NX 1.4.0 used uppstream artsd for linux clients,
and a modified esoundd (nxesd) for the windows and mac clients. Beginning with
1.5.0 nxesd has ben updated with the latest esoundd sources from upstream, and
is used in the linux client as well. It is only used in the client, not the
server, so it should still not be installed with nx-x11, but rather in its own
nxesd ebuild.

Now to my ebuilds:
My ebuilds already contains the equivalent to the first two patches in bug
#91409 (remove nxesd form nx-x11, and fixed dependancies), but not the third
patch (use nxcomp ebuild instead of including libXcomp in nx-x11). 
Instead I have created an patch equivalent to the third patch in bug #91409, as
well as a nxcomp 1.5.0 ebuild, which can be applied to portage at a later time.

My sugestion is that you (Stuart) imediately applies the first two patches from
bug #91409, as well as these ebuilds (except nxcomp and the patch), and the
nxserver-freenx-0.4.4 ebuild from bug #98591.
After that you take a good look at my nxcomp solution, and if you are not
sattisfied, tries to come up with a better one.
Comment 1 Jon Severinsson 2005-08-08 02:41:06 UTC
Created attachment 65400 [details]
nx-x11-1.5.0 ebuild
Comment 2 Jon Severinsson 2005-08-08 02:43:10 UTC
Created attachment 65401 [details]
nx-x11-1.5.0.ebuild

Sorry, attached the wrong ebuild
Comment 3 Jon Severinsson 2005-08-08 02:43:41 UTC
Created attachment 65402 [details]
nxproxy-1.5.0.ebuild
Comment 4 Jon Severinsson 2005-08-08 02:44:21 UTC
Created attachment 65403 [details]
nxssh-1.5.0 ebuild
Comment 5 Jon Severinsson 2005-08-08 02:44:56 UTC
Created attachment 65404 [details]
nxesd-1.5.0 ebuild
Comment 6 Jon Severinsson 2005-08-08 02:45:32 UTC
Created attachment 65405 [details]
nxclient-1.5.0 ebuild
Comment 7 Jon Severinsson 2005-08-08 02:46:28 UTC
Created attachment 65406 [details]
nxcomp-1.5.0 ebuild
Comment 8 Jon Severinsson 2005-08-08 02:47:33 UTC
Created attachment 65407 [details, diff]
Patch to use the nxcomp ebuild

Please do not use the nxcomp ebuild unless you apply this patch to the nxproxy,
nxssh and nx-x11 ebuilds.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-08-19 15:40:18 UTC
*** Bug 103061 has been marked as a duplicate of this bug. ***
Comment 10 Martin Gramatke 2005-08-24 14:33:01 UTC
Where do I get all the needed distfiles? 
 
I created a portage overlay with your ebuilds, now "emerge -uD world" gives me 
something like this: 
--------------------------------------------------- 
# emerge -uD world 
Calculating world dependencies ...done! 
>>> emerge (1 of 2) net-misc/nxcomp-1.5.0 to / 
>>> Downloading 
ftp://pandemonium.tiscali.de/pub/gentoo/distfiles/nxcomp-1.5.0-65.tar.gz 
--23:20:51--  
ftp://pandemonium.tiscali.de/pub/gentoo/distfiles/nxcomp-1.5.0-65.tar.gz 
           => `/usr/portage/distfiles/nxcomp-1.5.0-65.tar.gz' 
Resolving pandemonium.tiscali.de... 195.52.219.14 
Connecting to pandemonium.tiscali.de|195.52.219.14|:21... connected. 
Logging in as anonymous ... Logged in! 
==> SYST ... done.    ==> PWD ... done. 
==> TYPE I ... done.  ==> CWD /pub/gentoo/distfiles ... done. 
==> PASV ... done.    ==> RETR nxcomp-1.5.0-65.tar.gz ... 
No such file `nxcomp-1.5.0-65.tar.gz'. 
 
No digest file available and download failed. 
---------------------------------------------------- 
 
I also wonder why "emerge -uDpv" world only proposes 2 updates: 
*************************** 
These are the packages that I would merge, in order: 
 
Calculating world dependencies ...done! 
[ebuild  N    ] net-misc/nxcomp-1.5.0  0 kB [2] 
[ebuild     U ] net-misc/nxproxy-1.5.0 [1.4.0-r2] 0 kB [2] 
 
Total size of downloads: 0 kB 
Portage overlays: 
 [1] /usr/local/gentoo-de 
 [2] /usr/local/portage 
***************************** 
 
I would expect some more packages, especially since "emerge -uDpv nx-x11" tells 
me:  
================= 
[ebuild  N    ] net-misc/nxcomp-1.5.0  0 kB [2] 
[ebuild     U ] net-misc/nx-x11-1.5.0 [1.4.0-r4] 0 kB [2] 
================= 
 
Is my approach to have an overlay correct? 
Should i update or emerge the needed files explicitly? Which packages do I need 
for the server? 
Do i have to uninstall nxserver-freenx 0.4.0 first? 
 
Sorry for these many questions about portage basiscs. 
Comment 11 Rumen Yotov 2005-08-28 11:26:25 UTC
Hi,
Played with this for some hours, all emerged OK will check if it's working ;)
As there were some problems (outdated sources, extra/missing patches etc.) i
edited quite all 1.5.0.ebuilds. Also looked at BUG-98591 & BUG-91409.
A sandbox error still present for 91409, no comments for 98591 (maybe later).
Haven't tried to remove 'nx-x11' dependency for nxssh in favor of 'nxcomp'.
Summary:removed one patch for 1.4.0 from "nx-x11" as it gave an error on
patching; added new patch (window-linux 98591) which came with nx-x11-1.5.0-r1;
edited some source-files versions; made the digests; emerged nx-x11-1.5.0-r1
after 1.5.0.
Finally tar-bz2'd my overlay and will attach it (haven't removed Manifests,
digests though).
PS: to #10: after putting all the ebuilds in overlay unmask them as they are
~x86 masked (look at the ebuilds).Put them in '/etc/portage/package.keywords'.
Also you have to make digests for your overlay files: "ebuild
/usr/local/portage/nx-x11/nx-x11-1.5.0.ebuild digest" (same for all others).
Thanks. Rumen
Comment 12 Rumen Yotov 2005-08-28 11:30:46 UTC
Created attachment 67099 [details]
freenx-1.5.0.ebuilds compressed overlay

Marking this attachment type as "auto-detect", hope this will work.
Comment 13 Martin Gramatke 2005-08-30 15:19:23 UTC
Thanks Rumen, i tried your suggestions. I extracted your overlay, created the 
digests and made an "gensync -a && esync && emerge -vaDu --newuse world" and 
the update of nx-x11 was successful. But the second emerge of nxproxy was not: 
 
>>> Unpacking source... 
>>> Unpacking nxproxy-1.5.0-9.tar.gz to /var/tmp/portage/nxproxy-1.5.0/work 
>>> Source unpacked. 
checking for g++... g++ 
checking for C++ compiler default output... a.out 
checking whether the C++ compiler works... yes 
checking whether we are cross compiling... no 
checking for suffix of executables... 
checking for suffix of object files... o 
checking whether we are using the GNU C++ compiler... yes 
checking whether g++ accepts -g... yes 
checking for gcc... gcc 
checking whether we are using the GNU C compiler... yes 
checking whether gcc accepts -g... yes 
checking for gcc option to accept ANSI C... none needed 
checking for a BSD-compatible install... /bin/install -c 
checking how to run the C++ preprocessor... g++ -E 
checking for X... libraries , headers 
checking for gethostbyname... yes 
checking for connect... yes 
checking for remove... yes 
checking for shmat... yes 
checking for IceConnectionNumber in -lICE... yes 
checking for FreeBSD environment... no 
checking for Cygwin32 environment... no 
checking for Darwin environment... no 
checking for SunOS environment... no 
compiling version 1.5.0 
disabling production of debug symbols 
disabling info output in the log file 
disabling valgrind memory checker workarounds 
configure: creating ./config.status 
config.status: creating Makefile 
if [ -x /usr/X11R6/bin/makedepend ] ; then \ 
                /usr/X11R6/bin/makedepend -I. -I../nxcomp -I. -I../nxcomp \ 
                        -I/usr/include/g++ -I/usr/include/g++-3  -f Makefile 
Main.c   2>/dev/null; \ 
        fi 
gcc -c -O3 -DVERSION=\"1.5.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" 
-DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall 
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations 
-Wnested-externs -I. -I../nxcomp  Main.c 
touch depend.status 
g++ -O3 -DVERSION=\"1.5.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" 
-DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall 
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations 
-Wnested-externs -o nxproxy Main.o  -L../nxcomp -lXcomp 
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../../i686-pc-linux-gnu/bin/ld: 
cannot find -lXcomp 
collect2: ld returned 1 exit status 
make: *** [nxproxy] Error 1 
 
!!! ERROR: net-misc/nxproxy-1.5.0 failed. 
!!! Function src_compile, Line 24, Exitcode 2 
!!! compile problem 
!!! If you need support, post the topmost build error, NOT this status message. 
 
*** Resuming merge... 
>>> emerge (1 of 1) net-misc/nxproxy-1.5.0 to / 
>>> md5 files   ;-) nxproxy-1.5.0.ebuild 
>>> md5 files   ;-) files/digest-nxproxy-1.5.0 
>>> md5 files   ;-) files/patch-nxcomp-1.5.diff 
>>> md5 src_uri ;-) nxproxy-1.5.0-9.tar.gz 
 
 
 
#emerge --info 
 
Portage 2.0.51.22-r2 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r1, 
2.6.12 i686) 
================================================================= 
System uname: 2.6.12 i686 AMD Athlon(tm) XP 2500+ 
Gentoo Base System version 1.12.0_pre6 
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) 
[enabled] 
ccache version 2.4 [enabled] 
dev-lang/python:     2.4.1-r1 
sys-apps/sandbox:    1.2.12 
sys-devel/autoconf:  2.13, 2.59-r7 
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6 
sys-devel/binutils:  2.16.1 
sys-devel/libtool:   1.5.18-r1 
virtual/os-headers:  2.6.11-r2 
ACCEPT_KEYWORDS="x86 ~x86" 
AUTOCLEAN="yes" 
CBUILD="i686-pc-linux-gnu" 
CFLAGS="-march=athlon-xp -O2 -pipe" 
CHOST="i686-pc-linux-gnu" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d" 
CXXFLAGS="-march=athlon-xp -O2 -pipe" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoconfig ccache distcc distlocks sandbox sfperms strict" 
GENTOO_MIRRORS="ftp://pandemonium.tiscali.de/pub/gentoo/ 
ftp://mirror.scarlet-internet.nl/pub/gentoo ftp://mirror.nutsmaas.nl/gentoo/ 
http://gentoo.mirror.icd.hu/ http://pandemonium.tiscali.de/pub/gentoo/ 
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ 
ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ 
http://www.gigaload.org/gentoo.org/ http://gentoo.oregonstate.edu 
http://www.ibiblio.org/pub/Linux/distributions/gentoo" 
LC_ALL="en_US.UTF-8" 
LINGUAS="de" 
MAKEOPTS="-j5" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/gentoo-de" 
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage" 
USE="x86 3dnow 3dnowex 3dnowext X aalib alsa apache2 apm avi berkdb 
bitmap-fonts cdr cjk crypt cscope cups curl divx4linux doc dvb dvd dvdr eds 
emboss encode esd fam flac foomaticdb fortran gd gdbm gif gpm gstreamer gtk 
gtk2 hal imagemagick imlib jack java jpeg junit kde libg++ libwww lirc mad 
maildir mikmod mmx mmxext motif mozilla mp3 mpeg ncurses network nls oav ogg 
oggvorbis opengl oss pam pdflib perl pic png ppds python qt quicktime readline 
real rtc samba scanner sdl slang spell sse ssl subversion svga tcltk tcpd tetex 
tiff truetype truetype-fonts type1-fonts unicode usb userlocales vorbis xine 
xml2 xmms xv zlib linguas_de userland_GNU kernel_linux elibc_glibc" 
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS 
 
 
Comment 14 Martin Gramatke 2005-08-30 15:24:08 UTC
PS: PORTDIR_OVERLAY was "/usr/local/gentoo-de /usr/local/portage" at the moment 
of this emerge of course. I made this --info shot after the clear up. 
Comment 15 Rumen Yotov 2005-08-31 08:42:39 UTC
Hi Martin,
To your comment #13. This is a known error/bug, see comment #0 (initial report)
and specially the two related Bugs-91409,98591.
Somewhere on this bug or the other two there is a word about a bug (sandbox
stops live symlinks to a live FS and you have to copy one library file into your
work dir - libXcomp.so IIRC. It's in /usr/NX/lib/libXcomp.so (copy it as
mentioned below and continue).
Better use the step-by-step procedure to emerge this package, here's how:
1.#ebuild /usr/local/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild unpack
1a.# cd /var/tmp/portage/nxproxy-1.5.0/work && cp /usr/NX/lib/libXcomp.so .
2.#ebuild /usr/local/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild compile
3.#ebuild /usr/local/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild install
4.#ebuild /usr/local/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild qmerge
5.#ebuild /usr/local/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild clean
Thus you can copy the needed lib file and emerge successfully. Check again the
paths/things i may have some errors/typos.
HTH. Rumen
Comment 16 Ed Catmur 2005-09-08 16:30:44 UTC
Isn't this a duplicate of bug 101691?
Comment 17 Edwin 2005-09-28 11:28:21 UTC
I tried to use the compressed overlay, but it fails to build nxproxy.
Error:

>>> emerge (1 of 1) net-misc/nxproxy-1.5.0 to /
>>> md5 files   ;-) nxproxy-1.5.0.ebuild
>>> md5 files   ;-) files/digest-nxproxy-1.5.0
>>> md5 files   ;-) files/patch-nxcomp-1.5.diff
>>> md5 src_uri ;-) nxproxy-1.5.0-9.tar.gz
>>> Unpacking source...
>>> Unpacking nxproxy-1.5.0-9.tar.gz to /var/tmp/portage/nxproxy-1.5.0/work
>>> Source unpacked.
checking for g++... g++
checking for C++ compiler default output... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /bin/install -c
checking how to run the C++ preprocessor... g++ -E
checking for X... libraries , headers 
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for FreeBSD environment... no
checking for Cygwin32 environment... no
checking for Darwin environment... no
checking for SunOS environment... no
compiling version 1.5.0
disabling production of debug symbols
disabling info output in the log file
disabling valgrind memory checker workarounds
configure: creating ./config.status
config.status: creating Makefile
if [ -x /usr/X11R6/bin/makedepend ] ; then \
                /usr/X11R6/bin/makedepend -I. -I../nxcomp -I. -I../nxcomp \
                        -I/usr/include/g++ -I/usr/include/g++-3  -f Makefile 
Main.c   2>/dev/null; \
        fi
touch depend.status
gcc -c -O3 -DVERSION=\"1.5.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -
DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -
Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -
Wnested-externs -I. -I../nxcomp  Main.c
g++ -O3 -DVERSION=\"1.5.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -
DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -
Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -
Wnested-externs -o nxproxy Main.o -Wl,-O1 -L../nxcomp -lXcomp
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../../i686-pc-linux-gnu/bin/ld: 
cannot find -lXcomp
collect2: ld returned 1 exit status
make: *** [nxproxy] Error 1

!!! ERROR: net-misc/nxproxy-1.5.0 failed.
!!! Function src_compile, Line 24, Exitcode 2
!!! compile problem
!!! If you need support, post the topmost build error, NOT this status message.


emerge info:

Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r1, 2.6.
12-gentoo-r9 i686)
=================================================================
System uname: 2.6.12-gentoo-r9 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE=""
ALSA_CARDS="intel8x0"
ANT_HOME="/usr/share/ant-core"
ARCH="x86"
AUTOCLEAN="yes"
BASH_ENV="/etc/spork/is/not/valid/profile.env"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -fomit-frame-pointer -mtune=athlon-xp -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/
X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CVS_RSH="ssh"
CXXFLAGS="-O2 -fomit-frame-pointer -mtune=athlon-xp -march=athlon-xp -pipe"
DCCC_PATH="/usr/lib/distcc/bin"
DISPLAY=":0.0"
DISTCC_LOG=""
DISTCC_VERBOSE="0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig distlocks sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk ftp://mirrors.blueyonder.co.uk/
mirrors/gentoo http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://
ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/"
GLIBC_SSP_CHECKED="1"
GUILE_LOAD_PATH="/usr/share/guile/1.6"
G_BROKEN_FILENAMES="1"
HOME="/root"
HOSTNAME="edder"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.15.92.0.
2/info:/usr/share/gcc-data/i686-pc-linux-gnu/3.4.4/info:/usr/share/info/emacs-
21"
JAVAC="/opt/sun-jdk-1.5.0.04/bin/javac"
JAVA_HOME="/opt/sun-jdk-1.5.0.04"
JDK_HOME="/opt/sun-jdk-1.5.0.04"
KERNEL="linux"
LADSPA_PATH="/usr/lib/ladspa"
LDFLAGS="-Wl,-O1"
LESS="-R"
LESSOPEN="|lesspipe.sh %s"
LOGNAME="root"
LS_COLORS=""
MAIL="/var/mail/root"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-
linux-gnu/2.15.92.0.2/man:/usr/share/gcc-data/i686-pc-linux-gnu/3.4.4/man::/opt/
sun-jdk-1.5.0.04/man:/usr/qt/3/doc/man"
OLDPWD="/usr/local/portage/net-misc/nxssh"
OPENGL_PROFILE="ati"
PAGER="/usr/bin/less"
PATH="/usr/sbin:/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/
bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.4.4:/opt/ati/bin:/opt/sun-jdk-1.5.
0.04/bin:/opt/sun-jdk-1.5.0.04/jre/bin:/usr/qt/3/bin:/usr/NX/bin"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos ppc-od 
s390 sh sparc x86 x86-fbsd x86-od"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_CALLER="emerge"
PORTAGE_GID="250"
PORTAGE_MASTER_PID="29575"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PRELINK_PATH=""
PRELINK_PATH_MASK=""
PS1="[\u@edder \w ]$ "
PWD="/usr/local/portage/net-misc/nxcomp"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
RPMDIR="/usr/portage/rpm"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT="180"
SHELL="/bin/bash"
SHLVL="1"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
TERM="xterm-256color"
USE="x86 3dnow X a52 aac aalib acpi alsa avi bash-completion bidi bitmap-fonts 
browserplugin cdr crypt cups curl dhcp dvd dvdread eds emboss encode faad fam 
fbcon flac foomaticdb fortran gd gdbm ggi gif gpm gstreamer gtk gtk2 guile icq 
imlib jabber java jpeg junit libg++ libwww live lm_sensors mad matroska mikmod 
mmx motif mp3 mpeg mysql ncurses network nls nptl nptlonly ogg oggvorbis openal 
opengl pam pdflib plotutils png ppds python quicktime readline real ruby samba 
sdl slang snmp speex spell sse ssl svga tcltk tcpd tetex tiff truetype truetype-
fonts type1-fonts usb userlocales vorbis wxwindows xine xml xml2 xv zlib 
video_cards_radeon userland_GNU kernel_linux elibc_glibc"
USER="root"
USERLAND="GNU"
USERNAME="edder"
USE_EXPAND="FRITZCAPI_CARDS FCDSL_CARDS VIDEO_CARDS INPUT_DEVICES LINGUAS 
USERLAND KERNEL ELIBC"
VIDEO_CARDS="radeon"
XARGS="xargs -r"
XAUTHORITY="/root/.xauth5hHeFC"
XINITRC="/etc/X11/xinit/xinitrc"
_="/usr/bin/emerge"


I get the same error on another machine with gcc version 3.3.6
Comment 18 Edwin 2005-09-28 11:31:32 UTC
Sorry, I must have been blind, only saw comment #15 now, will be trying that 
solution.
Comment 19 Edwin 2005-09-28 11:44:44 UTC
I tried the manual suggestion in comment #15 and it still does not work. I 
double checked the first two commands and they work without problems. But at the 
compile command I get precisely the same error. If I try to emerge nxssh I also 
get the same: cannot find -lXcomp error
Comment 20 Rumen Yotov 2005-09-28 11:55:13 UTC
Hi,
To comment #17.
Check previous posts, there is an error when using a sandbox and the linker is
trying to link to a "live-fs file" (outside of the sandbox).
It's searching for "libXcomp", see below:
...BEGIN...
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../../i686-pc-linux-gnu/bin/ld: 
cannot find -lXcomp
...END...
The solution (by now) is to copy the library into the sandbox and then link with
this copy.
Find it: "#emerge nxcomp && qlist nxcomp (or equery files nxcomp) will give you:
...BEGIN...
/usr/NX/lib/libXcomp.so.1.5.0
/usr/X11R6/include/NX.h
/usr/NX/lib/libXcomp.so.1
/usr/NX/lib/libXcomp.so
...END...
Use this one:/usr/NX/lib/libXcomp.so. Copy it into workdir etc.
Better use the step-by-step emerge procedure:ebuild ...path_to_ebuild... unpack
Then copy the library, next:
ebuild ...path_to_ebuild... qmerge and last clean (to clean up work directory).
Rumen
Comment 21 Edwin 2005-09-28 12:46:33 UTC
Hi,
To comment #20

Sorry for the confusion, but like I said in comment #19 I already tried that and 
it didn't work. I finally got nxssh on my client machine installed by copying 
libXcomp.so to work/nxssh and work/nxcomp. For nxproxy I needed to make a dir 
nxcomp under nxproxy../work and copy the lib there.
Comment 22 Craig 2005-10-02 22:21:55 UTC
To comment 20: Rumen, I have tried that too and I get an error.

"cannot find -lXcomp"

Here are some relevent cut/pastes

# cd /var/tmp/portage/nxproxy-1.5.0/work
# ebuild /usr/local/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild unpack
# equery files nxcomp
[ Searching for packages matching nxcomp... ]
net-misc/nxcomp-1.5.0
* Contents of net-misc/nxcomp-1.5.0:
/usr
/usr/NX
/usr/NX/lib
/usr/NX/lib/libXcomp.so -> libXcomp.so.1.5.0
/usr/NX/lib/libXcomp.so.1 -> libXcomp.so.1.5.0
/usr/NX/lib/libXcomp.so.1.5.0
/usr/X11R6
/usr/X11R6/include
/usr/X11R6/include/NX.h
# pwd
/var/tmp/portage/nxproxy-1.5.0/work
# cp /usr/NX/lib/libXcomp.so .
# ebuild /usr/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild compile

config.status: creating Makefile
g++ -O3 -DVERSION=\"1.5.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\"
-DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -o nxproxy Main.o  -L../nxcomp -lXcomp
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/../../../../i686-pc-linux-gnu/bin/ld:
cannot find -lXcomp
collect2: ld returned 1 exit status
make: *** [nxproxy] Error 1

!!! ERROR: net-misc/nxproxy-1.5.0 failed.

nxssh also fails with the exact same error. I tried the manual unpack/cp/compile
steps with nxssh as well to no effect.
Comment 23 Craig 2005-10-02 22:28:45 UTC
I just read comment 21 a little more and following those instructions was able
to get things working.

Here is what I did after the previous commands in comment 22:

# pwd
# mkdir nxcomp
# cp /usr/NX/lib/libXcomp.so nxcomp
# ebuild /usr/portage/net-misc/nxproxy/nxproxy-1.5.0.ebuild compile

and then back to the instructions in comment 15.
Comment 24 Rumen Yotov 2005-10-03 09:50:37 UTC
Hi,
As i see that people are having problems with this ebuilds, it can be done but
this some manual work/hacks.
For a better alternative (thanks ecatmur), see BUG-101691, seems it's a
duplicate of this one.
There are newer ebuilds, which don't need any work-arounds.
All the versions are with 1 revision bigger than the ones here, tried them.
Thanks.Rumen
Comment 25 FieldySnuts 2005-12-30 13:36:54 UTC
Can we please get something into portage? It is very frustrating waiting so long.
Comment 26 Michal Januszewski (RETIRED) gentoo-dev 2006-02-14 09:20:13 UTC
I think we'll need to get 1.5 ported to modular X before it can get into Portage.
Comment 27 Stuart Herbert (RETIRED) gentoo-dev 2006-03-05 06:21:25 UTC
Hi,

I've added all the missing components required for FreeNX 0.5.0 w/ NX 1.5.0 into Portage.  They are currently package masked for further testing.

Best regards,
Stu