Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 101707 - samba 3.0.14a-r2 -- os-x client can't connect via network browse
Summary: samba 3.0.14a-r2 -- os-x client can't connect via network browse
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo's SAMBA Team
Depends on:
Reported: 2005-08-08 00:06 UTC by complich8
Modified: 2005-08-25 04:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Debug Level 10 log.smbd from startup to the client hanging (log.smbd,32.28 KB, text/plain)
2005-08-08 00:10 UTC, complich8
log.nmbd at log level 10 from the same time span (log.nmbd,28.23 KB, text/plain)
2005-08-08 00:11 UTC, complich8
samba log for the ibook itself at log level 10 (log.complich8-ibook,85.23 KB, text/plain)
2005-08-08 00:12 UTC, complich8
smb.conf -- in case it helps anyone out. (smb.conf,1.16 KB, text/plain)
2005-08-08 00:15 UTC, complich8
testparm -v -s output (testparm.out,7.24 KB, text/plain)
2005-08-09 08:20 UTC, complich8

Note You need to log in before you can comment on or make changes to this bug.
Description complich8 2005-08-08 00:06:45 UTC
I'm not sure if this is an os-x implementation bug or a samba bug, but it worked
before and os-x didn't change...

I'm running stable on x86 (athlon xp-m 1.66) running samba.  I'm running 2 types
of clients: an os-x (tiger) ibook and a windows xp desktop.  The iBook can
connect to the samba shares via "go"->"Map network drive", but can't browse to
shares via the network browser (finder -> network -> workgroup name -> server
name -> connect).  Shortly after connect, it beachballs (hangs indefinitely,
until finder is relaunched).

per-machine log (at log level 0) shows: 
[2005/08/08 01:17:49, 0] rpc_parse/parse_prs.c:prs_mem_get(537)
  prs_mem_get: reading data of size 2 would overrun buffer.
[2005/08/08 01:17:49, 0] rpc_server/srv_pipe.c:api_pipe_bind_req(919)
  api_pipe_bind_req: unable to unmarshall RPC_HDR_RB struct.

Windows XP clients can connect fine, every way I can think to connect to it. 
os-x client can still connect via "go->connect to server" -- as long as we stay
away from the "browse" interface (in other words, already know the share names).

Reproducible: Always
Steps to Reproduce:
1.emerge samba 3.0.14a-r2
2.start it
3.on os-x machine, hit network->workgroup->servername and click "connect".

Actual Results:  
the os-x client hangs until it's killed and relaunched.
The server shows the errors in the details section.

Expected Results:  
shouldn't have hung at whereever it's hanging.

Portage (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.5-r0, 2.6.11-gentoo-r9 i686)
System uname: 2.6.11-gentoo-r9 i686 Unknown CPU Typ
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -mcpu=athlon-xp -fomit-frame-pointer -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=athlon-xp -fomit-frame-pointer -funroll-loops -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 apache2 apm async avi berkdb bitmap-fonts bzlib cgi chroot crypt curl
eds emboss encode ethereal fam foomaticdb gd gif gnutls gstreamer gtk gtk2 jpeg
junit ldap libg++ libwww mad mikmod mmap mp3 mppe-mppc mysql ncurses nptl ntlm
offensive ogg pam perl php png posix python quicktime readline samba sdl server
slang snmp ssl tcpd truetype-fonts type1-fonts vorbis xmms zlib userland_GNU
kernel_linux elibc_glibc"
Comment 1 complich8 2005-08-08 00:10:32 UTC
Created attachment 65388 [details]
Debug Level 10 log.smbd from startup to the client hanging
Comment 2 complich8 2005-08-08 00:11:17 UTC
Created attachment 65389 [details]
log.nmbd at log level 10 from the same time span
Comment 3 complich8 2005-08-08 00:12:02 UTC
Created attachment 65390 [details]
samba log for the ibook itself at log level 10
Comment 4 complich8 2005-08-08 00:15:03 UTC
Created attachment 65391 [details]
smb.conf -- in case it helps anyone out.
Comment 5 Christian Andreetta (RETIRED) gentoo-dev 2005-08-09 03:35:41 UTC
complich8: instead of the smb.conf, could you please attach the output of
Comment 6 Christian Andreetta (RETIRED) gentoo-dev 2005-08-09 03:41:22 UTC
the previous comment would have liked to be something more complete: retry:

complich8: instead of the smb.conf, could you please attach the output of 
  'testparm -v -s > ${file} 2>&1'? 
Comment 7 complich8 2005-08-09 08:20:42 UTC
Created attachment 65535 [details]
testparm -v -s output

you got it.
Comment 8 complich8 2005-08-09 11:59:50 UTC
I'm seeing the same exact behavior connecting to my work fileservers, which are
xeon-based gentoo boxes.  And I just tested on a solaris box with samba 3.0.14a
and found the same exact behavior.

Other relevant links include: and the linked mailing list
Comment 9 Christian Andreetta (RETIRED) gentoo-dev 2005-08-09 23:12:32 UTC
From what I'm seeing, it should be a combination of (missing)
'client NTLMv2 auth = Yes'
'client plaintext auth = No'
'use sendfile= No' (this one shouldn't be needed, but it's here for nice company)

These settings are to be applied on all failing unixes' smb.conf. Also look at
the man pages of smb.conf for all the recurrencies of 'signing', 'ntlm', 'auth'.
The client seems broken, but these settings could stop the failures to show up.
Comment 10 complich8 2005-08-10 10:35:38 UTC
I tried applying the settings you suggested (the client ntlmv2 auth = yes,
client plaintext auth = no, and client and server signing both set to auto).  I
also set ntlm auth to explicitly enabled.  Restarted smbd on the server,
rebooted the client laptop.

That doesn't seem to be it.  Clientside still hangs, server still shows the same
error logs.
Comment 11 complich8 2005-08-25 02:16:10 UTC
Well, the result I got from samba's bugzilla goes something like this: 

------- Additional Comments From  2005-08-24 06:26 -------
This should be fixed in 3.0.20.  There was one specific 
problem with our rpc_bind server code.

So I guess whenever 3.0.20 rolls down the line, we'll see the problem go away. 
I'm going to consider it resolved at that.
Comment 12 Christian Andreetta (RETIRED) gentoo-dev 2005-08-25 04:30:06 UTC
If you're in a hurry, samba-3.0.20 is being polished on bug #103164