Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 101245 - dijjer-117.ebuild (New Package)
Summary: dijjer-117.ebuild (New Package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://code.google.com/p/dijjer/
Whiteboard:
Keywords:
: 144508 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-03 13:20 UTC by Jay Knight
Modified: 2009-04-22 18:44 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dijjer-117.ebuild (New Package) (dijjer-117.ebuild,760 bytes, text/plain)
2005-08-03 13:21 UTC, Jay Knight
Details
dijjer (for /etc/init.d/) (dijjer,796 bytes, text/plain)
2005-08-03 13:21 UTC, Jay Knight
Details
dijjer (for /etc/init.d) (dijjer,769 bytes, text/plain)
2005-08-05 14:52 UTC, Jay Knight
Details
dijjer-118.ebuild (dijjer-118.ebuild,793 bytes, text/plain)
2005-08-05 14:57 UTC, Jay Knight
Details
dijjer-118.ebuild (dijjer-118.ebuild,807 bytes, text/plain)
2005-08-06 20:25 UTC, Jay Knight
Details
dijjer-118.ebuild (dijjer-118.ebuild,797 bytes, text/plain)
2005-08-09 15:41 UTC, Jay Knight
Details
dijjer-120.ebuild (dijjer-120.ebuild,797 bytes, text/plain)
2006-04-03 14:18 UTC, Jay Knight
Details
/etc/init.d/dijjer (dijjer,804 bytes, text/plain)
2006-04-03 14:20 UTC, Jay Knight
Details
dijjer-120.ebuild (dijjer-120.ebuild,856 bytes, text/plain)
2006-04-08 15:21 UTC, Jay Knight
Details
dijjer-120-r1.ebuild (dijjer-120-r1.ebuild,922 bytes, text/plain)
2006-08-20 04:26 UTC, Chris Carlin
Details
files/dijjer-pkg-2.initd (dijjer-pkg-2.initd,979 bytes, text/plain)
2006-08-20 04:27 UTC, Chris Carlin
Details
files/dijjer-pkg-2.confd (dijjer-pkg-2.confd,439 bytes, text/plain)
2006-08-20 04:28 UTC, Chris Carlin
Details
dijjer-120-r1.ebuild (dijjer-120-r1.ebuild,1.17 KB, text/plain)
2006-08-26 06:02 UTC, Chris Carlin
Details
files/dijjer-config (dijjer-config,332 bytes, text/plain)
2006-08-26 06:04 UTC, Chris Carlin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jay Knight 2005-08-03 13:20:12 UTC
There needs to be a dijjer ebuild.

Reproducible: Always
Steps to Reproduce:
1.  emerge dijjer
2.
3.

Actual Results:  
no ebuild found

Expected Results:  
dijjer gets merged
Comment 1 Jay Knight 2005-08-03 13:21:06 UTC
Created attachment 65016 [details]
dijjer-117.ebuild (New Package)

Ebuild that seems to work for me...file/dijjer next
Comment 2 Jay Knight 2005-08-03 13:21:53 UTC
Created attachment 65017 [details]
dijjer (for /etc/init.d/)
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2005-08-03 14:03:34 UTC
Please always assign text/plain. Also I wonder why any developer would have the
slightest look at this, when you can't even add a description and url.
Comment 4 Jay Knight 2005-08-03 14:14:32 UTC
"Dijjer is free P2P software that dramatically reduces the bandwidth needed to
host large files."  It is something like bittorrent, but requires nothing more
than a modified url to host files with dijjer (no trackers, etc).
Comment 5 Jay Knight 2005-08-05 14:52:45 UTC
Created attachment 65197 [details]
dijjer (for /etc/init.d)

Removed working seednode in command, since a working one is now in the source.
Comment 6 Jay Knight 2005-08-05 14:57:05 UTC
Created attachment 65198 [details]
dijjer-118.ebuild

Using build 118, added ~amd64, now with better ebuild practices :)
Comment 7 Jay Knight 2005-08-06 20:25:49 UTC
Created attachment 65275 [details]
dijjer-118.ebuild

${P} != ${PN}... little bugfix
Comment 8 Jay Knight 2005-08-09 15:41:26 UTC
Created attachment 65562 [details]
dijjer-118.ebuild

Ok, I'll get it right one of these days... fixed yet another dumb bug.
Comment 9 Jay Knight 2005-08-19 13:03:36 UTC
I'm hosting these along with some helpful instructions at http://dijjer.jk3.us/
until this make it to the tree, for anyone who's interested.
Comment 10 Jay Knight 2006-04-03 14:18:57 UTC
Created attachment 83844 [details]
dijjer-120.ebuild

ebuild for build 120
Comment 11 Jay Knight 2006-04-03 14:20:24 UTC
Created attachment 83845 [details]
/etc/init.d/dijjer

new /etc/init.d/dijjer... now using java-config to find java binary.  (Is this the proper way to do it?)
Comment 12 Régis Décamps 2006-04-08 13:07:50 UTC
dijjer-120.ebuild
DESCRIPTION="java distibuted web cache"
What is this?

I find your description in Comment #4 much more self-explainatory:
DESCRIPTION="Peer to peer program similar to bittorrent with easy file publishing". I'm not sure it is useful to indicate that it is programmed in Java.

Comment 13 Jay Knight 2006-04-08 15:21:03 UTC
Created attachment 84232 [details]
dijjer-120.ebuild

good point, updated.
Comment 14 Chris Carlin 2006-08-05 17:03:28 UTC
Judging from http://www.gentoo.org/proj/en/java/java-devel.xml it looks like this ebuild could use some updating. I'd give it a shot if nobody else is up for it.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2006-08-20 03:49:27 UTC
*** Bug 144508 has been marked as a duplicate of this bug. ***
Comment 16 Chris Carlin 2006-08-20 04:26:13 UTC
Created attachment 94683 [details]
dijjer-120-r1.ebuild

What needs to be done to move forward with this package?

I'm uploading dijjer-120-r1.ebuild, files/dijjer-pkg-2.confd, and files/dijjer-pkg-2.initd. 

These use the new java-pkg-2 stuff and move configuration into conf.d/dijjer. They don't replace the existing files since not everyone is using the new Java stuff yet.
Comment 17 Chris Carlin 2006-08-20 04:27:15 UTC
Created attachment 94684 [details]
files/dijjer-pkg-2.initd
Comment 18 Chris Carlin 2006-08-20 04:28:22 UTC
Created attachment 94685 [details]
files/dijjer-pkg-2.confd
Comment 19 Chris Carlin 2006-08-26 05:59:43 UTC
Comment on attachment 94683 [details]
dijjer-120-r1.ebuild

I'm adding a script to prepend the Dijjer node to the list of GENTOO_MIRRORS in /etc/make.conf
Comment 20 Chris Carlin 2006-08-26 06:02:50 UTC
Created attachment 95128 [details]
dijjer-120-r1.ebuild
Comment 21 Chris Carlin 2006-08-26 06:04:01 UTC
Created attachment 95129 [details]
files/dijjer-config
Comment 22 Chris Carlin 2006-08-26 06:14:08 UTC
(In reply to comment #6)
> Created an attachment (id=65198) [edit]
> dijjer-118.ebuild
> 
> Using build 118, added ~amd64, now with better ebuild practices :)

Jay, did you actually test under amd64?
Comment 23 Petteri Räty (RETIRED) gentoo-dev 2006-08-26 06:38:04 UTC
(In reply to comment #20)
> Created an attachment (id=95128) [edit]
> dijjer-120-r1.ebuild
> 

		exeinto /etc/init.d
		newexe ${FILESDIR}/dijjer-pkg-2.initd dijjer

		insinto /etc/conf.d
		newins ${FILESDIR}/dijjer-pkg-2.confd dijjer

You should use newinitd and newconfd here

		exeinto /usr/bin
		newexe ${FILESDIR}/dijjer-config dijjer-config

dobin takes care of this in one line

        if [ ! -d ${DIJJER_DATADIR} ]
        then
                mkdir ${DIJJER_DATADIR}
        fi
        chown -R dijjer:nobody ${DIJJER_DATADIR}
        chmod -R 700 ${DIJJER_DATADIR}

Instead of doing this in the init script, you could consider moving this logic to the ebuild. Of course there is the point of having the control of moving the directory somewhere else.
	start-stop-daemon --start --exec /usr/bin/dijjer --chuid dijjer \
		--background --make-pidfile --pidfile ${DIJJER_PIDFILE} -- ${ARGS}

start-stop-daemon can't be directly used on wrapper scripts. I don't remember the specifics here on how to correct it. Uberlord knows better.

#Uncomment to specify seednodes in address:port format, separated by spaces
DIJJER_SEEDNODES='dijjer.volkmesh.net:9114'

^ Should probably be commented

Please note that these were comments by just looking at the files. I haven't actually tested it in practise.

Comment 24 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-15 17:51:49 UTC
Removing EBUILD from keywords until changes in Comment #23 are implemented. thx
Comment 25 Chris Carlin 2009-01-15 17:56:33 UTC
(In reply to comment #24)
> Removing EBUILD from keywords until changes in Comment #23 are implemented. thx
> 

Wow, this bug is still around?

As far as I know, dijjer is a completely dead project. I'd suggest cosing this bug one way or another. WONT FIX is entirely reasonable as there's unlikely to be anyone willing to do any maintenance even just to get the ebuild shaped up.
Comment 26 Jay Knight 2009-04-22 18:44:33 UTC
Agreed.  dijjer is dead for now.  Marked WONTFIX.