Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 100258 - Using the SKGE driver from 2.6.12-gentoo-r6 makes it impossible for any older driver (sk98lin included) to bring the network card up.
Summary: Using the SKGE driver from 2.6.12-gentoo-r6 makes it impossible for any older...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-07-25 11:09 UTC by Jean-Christophe Choisy
Modified: 2005-11-24 16:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Patch (skge.patch,4.31 KB, patch)
2005-09-11 08:20 UTC, Daniel Drake (RETIRED)
Details | Diff
Please try this patch (skge.patch,1.79 KB, patch)
2005-11-08 02:47 UTC, Daniel Drake (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Christophe Choisy 2005-07-25 11:09:55 UTC
I am a gentoo user, but often feels the need to try different distros to see how others are doing. Lately, 
after my upgrade to 2.6.12-gentoo-r6 (which is marked stable by the way), I noticed that my ubuntu 
livecd was unable to bring my ethernet card up. Tried fedora: same. Tried the gentoo 2005.0 livecd: 
same. Meanwhile, my 2.6.12-gentoo-r6 still worked.

I immediatelly thought that this was the new skge driver messing up with the card. I installed XP on a 
spare partition, the card worked perfectly. Retried Fedora, Ubuntu... All worked.

I reboot in my beloved 2.6.12-gentoo-r6 (of course the network works great), then re-try Ubuntu & 
fedora (sk98lin) and gentoo 2005.0 livecd (older skge) : all three of them fail.

Basicly the card is detected, but cannot be brought up. (ie: the little light on the router stays shut off).

Reproducible: Always
Steps to Reproduce:
1. Use the latest SKGE driver (bundled in gentoo-sources-2.6.12-r6
2. Try using any other linux driver for your card (sk98lin or an older SKGE)
3. Everything is back to normal once the card is used under windows once.

Actual Results:  
The network card can't be brought up.

Expected Results:  
It should not happen at all.

Maybe a corrupted firmware is uploaded to the card or something like that? Actually I don't even know is 
this driver uploads a firmware to the card at all ;p
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2005-07-25 15:26:16 UTC
There is no firmware involved.

What you are seeing is bugs in the older versions of the available drivers.
There's nothing we can do about this, but you can file bugs against the other
distro's who include the older buggy drivers. Or you can power down between
Comment 2 Jean-Christophe Choisy 2005-07-25 20:27:45 UTC
Sorry to re-open this bug, but I'm not so sure about what I'm supposed to do. Using this newer driver 
makes it impossible to use any older one, which means that even the official Gentoo 2005.0 livecd is then 
unable to make use of this card... Isn't that a gentoo-sources problem? Who can fix this if it's not you?

In clear, if a gentoo user today decides to use ANY other distro (since none other use skge yet), they're all 

Maybe you'll just close it again, and if you do so I won't off course re-open, but I feel really strange about 
Comment 3 Stefan Schweizer (RETIRED) gentoo-dev 2005-07-26 02:50:18 UTC
There is also an official sk98lin driver available, I made an ebuild for it:

It supports some newer chipsets, can you please check if it also has this bug?
You can just use it if you are not happy with the in-kernel skge driver.
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2005-07-26 03:10:24 UTC
Are you saying that the older drivers don't work, even after a complete poweroff?
Comment 5 Jean-Christophe Choisy 2005-07-26 10:59:41 UTC
Indeed, that's what I'm saying. To make them work again, you have to use the windows driver once, then 
everything is back to normal. That's why I'm thinking this may be a problem with the current skge driver...
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2005-07-29 17:36:57 UTC
Reported upstream, waiting for response
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2005-08-09 16:46:30 UTC
Please retest with gentoo-sources-2.6.12-r8
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2005-08-23 07:34:01 UTC
Should be fixed, reopen if not
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2005-09-11 08:19:36 UTC
This isn't fixed...
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2005-09-11 08:20:25 UTC
Created attachment 68179 [details, diff]

...but hopefully will be after this patch.

Please let me know if this helps.
Comment 11 Matt Housh 2005-10-06 08:29:50 UTC
The aforementioned patch doesn't seem to solve the problem for me. Also, the
official patch from syskonnect (via install-8_23.tar.bz2) exhibits the same

In contrast to the report in comment #5, the windows driver isn't sufficient to
solve this problem in my case. Rebooting to windows results in a "cable
disconnected" type message every time. Working around it involves either
powering off the machine and removing the power cord before booting up windows
or the older linux driver, or hard-resetting the machine while the drive is active.

Hopefully syskonnect will respond with something that can be backported into
skge or with something I've missed. An email has been sent to their support.
Comment 12 Matt Housh 2005-10-06 12:18:40 UTC
OK, with very quick feedback from SysKonnect support, it turns out that despite
no error messages, the *windows* driver was the one at fault here. Replacing the
version of the driver that shuttle provided ( with from
syskonnect's support site (a generic marvell yukon driver rather than the
shuttle-specific one) seems to have solved the problem.

My apologies for the false alarm. :(
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2005-10-06 12:56:48 UTC
It's still a "bug" if the earlier windows driver broke only after the Linux
driver was upgraded. But I guess the fact that SK aren't addressing this in
their own package means that theres nothing that can be done except for those
users running old+buggy drivers to upgrade. Oh well...
Comment 14 Raphael Marichez (Falco) (RETIRED) gentoo-dev 2005-10-07 18:18:02 UTC
Hi, same thing here, on a very new box. (ASUS P5GD2-X)

As for now, i've tried 2.6.13-gentoo-r3 then 2.6.14-rc3-git (the newest today),
and both failed to bring up the ethernet, even after a cold reboot.

As a workaround, i used the patch proposed by
(the script generates a clear patch, it's easy, and it seems to be GPL)

thanks for all your job
Comment 15 Daniel Drake (RETIRED) gentoo-dev 2005-10-08 02:19:36 UTC
Please elaborate - which driver were you originally trying to use?
Comment 16 Daniel Drake (RETIRED) gentoo-dev 2005-11-08 02:43:42 UTC
Stephen sent me a new patch to try
Comment 17 Daniel Drake (RETIRED) gentoo-dev 2005-11-08 02:47:07 UTC
Created attachment 72437 [details, diff]
Please try this patch
Comment 18 Daniel Drake (RETIRED) gentoo-dev 2005-11-24 16:55:02 UTC
Apparently it doesn't help, closing again...