Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 100071 - sys-apps/baselayout-1.11.13 does not scan for wireless access points
Summary: sys-apps/baselayout-1.11.13 does not scan for wireless access points
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Roy Marples (RETIRED)
Depends on:
Reported: 2005-07-23 16:14 UTC by Keith Gable
Modified: 2005-09-01 16:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gable 2005-07-23 16:14:07 UTC
I updated to baselayout 1.11.13 and on boot, the rcscripts no longer say
"Configuring wireless network on wlan0" or similar. And iwconfig reveals the
network has not been configured. This is fairly serious, as the rcscripts
*should* be configuring my wireless network.

Reproducible: Always
Steps to Reproduce:

Portage (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.5-r0, 2.6.11-gentoo-r8 i686)
System uname: 2.6.11-gentoo-r8 i686 mobile AMD Athlon(tm) XP
Gentoo Base System version 1.6.12
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.10
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon-xp -O3 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -fomit-frame-pointer -pipe"
FEATURES="autoconfig distlocks sandbox sfperms strict"
USE="x86 3dnow 3dnowext X aalib alsa apm arts avi berkdb bitmap-fonts bonobo cdr
crypt cups curl directfb doc dvd dvdr eds emboss encode esd esound fam flac
foomaticdb fortran gd gdbm ggi gif gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml
guile hal imagemagick imlib ipv6 java jpeg kde kerberos krb4 krb5 libg++ libwww
mad mikmod mmx mmxext motif mozilla mp3 mpeg mysql ncurses nls nptl odbc ogg
oggvorbis opengl oss pam pdflib perl png python qt quicktime readline samba sdl
speex spell sse ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts
unicode userlocales vorbis xine xml xml2 xmms xv zlib userland_GNU kernel_linux
Comment 1 SpanKY gentoo-dev 2005-07-23 22:42:58 UTC
we cant guess at what changed, you need to provide helpful info ...

did 1.11.12 work ?  what version of wpa_supplicant do you use ?  what do you
have in your /etc/conf.d/net file ?  what net scripts do you have added to your
default runlevel ?  what does `ls -l /etc/init.d/net.*` show ?
Comment 2 Keith Gable 2005-07-24 09:52:18 UTC
[ebuild   R   ] sys-apps/baselayout-1.11.12-r4  -bootstrap -build -static
+unicode 0 kB

config_eth0=(  " promisc" )
config_wlan0=( " promisc" )
routes_eth0=(  "default via" )
routes_wlan0=( "default via" )

## Fallback to Ad-Hoc if AP not found
adhoc_essid_wlan0=( "Keith" )

root@keith keith # ls -l /etc/init.d/net.*
lrwxrwxrwx  1 root root     6 Jul 23 17:55 /etc/init.d/net.eth0 -> net.lo
-rwxr-xr-x  1 root root 24402 Jul 23 17:55 /etc/init.d/net.lo
lrwxrwxrwx  1 root root     6 May 24 11:34 /etc/init.d/net.wlan0 -> net.lo

Sorry about that, I wrote this bug report when I was sleepy. I thought I
mentioned what version I downgraded to. >_<

(the promisc seems to fix a problem looking for Half Life and BF1942 network games)
Comment 3 Jonas Jonsson 2005-07-24 13:18:49 UTC
I also hade the same problem, everything worked with baselayout-1.11.12-r4 but
not with baselayout-1.11.13... 
The "big" different I have found is that .13 looks for iwconfig at /sbin not
/usr/sbin wich .12-r4 does... 
So I just upgraded wireless-tools from 27 to 27-r1 wich "moves" the iwconfig to

Now everything works as it should again... Dunno, but the baselayout-1.11.13
should depend on wireless-tools => 27-r1 if you use wireless... Well just a
Comment 4 Keith Gable 2005-07-24 14:55:49 UTC
Upgrading wireless-tools makes it work fine now. This dep needs added then.
Comment 5 Roy Marples (RETIRED) gentoo-dev 2005-07-25 02:06:50 UTC
We cannot add that dep as baselayout does not require wireless-tools for it to
work. Also, wireless can be completely configured without wireless-tools when
you use wpa_supplicant.
Comment 6 Tom Wesley 2005-07-26 11:42:39 UTC
This just caught me out also.  Would it be possible to add einfo's?
Comment 7 Michael Schilling 2005-09-01 16:15:29 UTC
This also broke my wifi setup, so I masked version 1.11.13...
But version 1.11.13-r1 did the same thing, and after searching in the forums and
in bugzilla I found this bug, which solved it. Could you please inform the
people that they might update their wireless-tools?

I still think this shouldn't happen on a stable system and 1.11.13-r1 is marked

... just an annoyed comment ... sorry ...

P.S.: I didn't have any problems using the unstable (~x86) version on my
productive system...