Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 100040 - cdrdao-1.2.0 fails on linking gcdmaster (undefined reference to `ao_initialize')
Summary: cdrdao-1.2.0 fails on linking gcdmaster (undefined reference to `ao_initialize')
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
: 100420 100557 103209 107437 114568 159003 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-23 10:14 UTC by Roalt
Modified: 2006-12-24 01:10 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roalt 2005-07-23 10:14:29 UTC
'emerge cdrdao' fails on AMD64 system. It looks like a library is missing or
something because functions like 'ao_initialize' 'ao_default_driver_id',
'ao_open_live', 'ao_play' are undefined:
x86_64-pc-linux-gnu-g++ -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API
-I/usr/include/gtkmm-2.4 -I/usr/lib64/gtkmm-2.4/include
-I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include
-I/usr/include/gdkmm-2.4 -I/usr/lib64/gdkmm-2.4/include
-I/usr/include/pangomm-1.4 -I/usr/include/atkmm-1.6 -I/usr/include/gtk-2.0
-I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include
-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
-I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/include/atk-1.0   -DXTHREADS -D_REENTRANT
-DXUSE_MTSAFE_API -DORBIT2=1 -pthread -I/usr/include/libgnomeuimm-2.6
-I/usr/lib64/libgnomeuimm-2.6/include -I/usr/include/libgnomemm-2.6
-I/usr/lib64/libgnomemm-2.6/include -I/usr/include/libgnomecanvasmm-2.6
-I/usr/lib64/libgnomecanvasmm-2.6/include -I/usr/include/gconfmm-2.6
-I/usr/lib64/gconfmm-2.6/include -I/usr/include/libglademm-2.4
-I/usr/lib64/libglademm-2.4/include -I/usr/include/libgnomeui-2.0
-I/usr/include/gnome-vfsmm-2.6 -I/usr/lib64/gnome-vfsmm-2.6/include
-I/usr/include/gtkmm-2.4 -I/usr/lib64/gtkmm-2.4/include
-I/usr/include/libgnome-2.0 -I/usr/include/glibmm-2.4
-I/usr/lib64/glibmm-2.4/include -I/usr/include/gdkmm-2.4
-I/usr/lib64/gdkmm-2.4/include -I/usr/include/pangomm-1.4
-I/usr/include/atkmm-1.6 -I/usr/include/gtk-2.0 -I/usr/include/sigc++-2.0
-I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -I/usr/lib64/gtk-2.0/include
-I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/include/atk-1.0 -I/usr/include/orbit-2.0
-I/usr/include/libbonobo-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0
-I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0
-I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0
-I/usr/include/libglade-2.0 -I/usr/include/libxml2
-I/usr/include/libbonoboui-2.0   -O2 -pipe -fomit-frame-pointer   -o gcdmaster 
AddFileDialog.o AddSilenceDialog.o AudioCDProject.o AudioCDView.o
BlankCDDialog.o CdDevice.o CdTextDialog.o DeviceConfDialog.o DeviceList.o
DumpCDProject.o DuplicateCDProject.o gcdmaster.o GenericView.o guiUpdate.o
Icons.o MessageBox.o ProcessMonitor.o ProgressDialog.o Project.o
ProjectChooser.o RecordCDSource.o RecordCDTarget.o RecordHDTarget.o
RecordTocDialog.o RecordTocSource.o SampleDisplay.o SampleManager.o Settings.o
TextEdit.o TocEdit.o TocEditView.o TocInfoDialog.o TrackDataScrap.o
TrackInfoDialog.o TrackManager.o xcdrdao.o SoundIF-ao.o -L../dao -ldao
-L../paranoia -lcdda_paranoia -L../trackdb -ltrackdb -L../scsilib/export -lscg
-lschily -Wl,--export-dynamic -pthread -L/usr/lib64 -lgnomeuimm-2.6
-lgnomemm-2.6 -lgnomecanvasmm-2.6 -lgconfmm-2.6 -lglademm-2.4 -lgnomeui-2 -lSM
-lICE -lgnomevfsmm-2.6 -lgtkmm-2.4 -lglade-2.0 -lgdkmm-2.4 -latkmm-1.6
-lpangomm-1.4 -lbonoboui-2 -lxml2 -lpthread -lz -lgnomecanvas-2 -lgnome-2 -lpopt
-lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lglibmm-2.4
-lgnomevfs-2 -lgobject-2.0 -lsigc-2.0 -lbonobo-2 -lgconf-2 -lbonobo-activation
-lORBit-2 -lm -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0   -L/usr/lib64
-lgtkmm-2.4 -lgdkmm-2.4 -latkmm-1.6 -lgtk-x11-2.0 -lpangomm-1.4 -lglibmm-2.4
-lsigc-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0
-lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0      -lnsl
SoundIF-ao.o(.text+0x12): In function `SoundIF::SoundIF()':
: undefined reference to `ao_initialize'
SoundIF-ao.o(.text+0x28): In function `SoundIF::SoundIF()':
: undefined reference to `ao_default_driver_id'
SoundIF-ao.o(.text+0x72): In function `SoundIF::SoundIF()':
: undefined reference to `ao_initialize'
SoundIF-ao.o(.text+0x88): In function `SoundIF::SoundIF()':
: undefined reference to `ao_default_driver_id'
SoundIF-ao.o(.text+0xed): In function `SoundIF::start()':
: undefined reference to `ao_open_live'
SoundIF-ao.o(.text+0x17e): In function `SoundIF::play(Sample*, long)':
: undefined reference to `ao_play'
SoundIF-ao.o(.text+0x1bc): In function `SoundIF::end()':
: undefined reference to `ao_close'
SoundIF-ao.o(.text+0x1ed): In function `SoundIF::~SoundIF()':
: undefined reference to `ao_shutdown'
SoundIF-ao.o(.text+0x207): In function `SoundIF::~SoundIF()':
: undefined reference to `ao_shutdown'
SoundIF-ao.o(.text+0x22d): In function `SoundIF::~SoundIF()':
: undefined reference to `ao_shutdown'
SoundIF-ao.o(.text+0x247): In function `SoundIF::~SoundIF()':
: undefined reference to `ao_shutdown'
collect2: ld returned 1 exit status
make[3]: *** [gcdmaster] Error 1
make[3]: Leaving directory `/var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0/xdao'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0/xdao'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0'
make: *** [all] Error 2

!!! ERROR: app-cdr/cdrdao-1.2.0 failed.


Reproducible: Always
Steps to Reproduce:
1. emerge cdrdao
2.
3.




Just did an 'emerge --sync' (23-juli-2005)

phlox ~ # emerge --info
Portage 2.0.51.22-r2 (default-linux/amd64/2005.0, gcc-3.4.3, glibc-2.3.5-r0,
2.6.11-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.11-gentoo-r1 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.12
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16, 1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf-8"
LC_ALL="en_US.utf-8"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi berkdb bitmap-fonts cdr crypt css cups curl dv dvd dvdr
eds encode esd evo fam foomaticdb fortran gdbm gif gimpprint gnome gphoto2 gpm
gstreamer gtk gtk2 hal ieee1394 imagemagick imlib ipv6 java jpeg kde ldap lzw
lzw-tiff mozilla mp3 mpeg ncurses nls opengl pam pda pdflib perl png ppds python
qt quicktime readline real samba sdl slang spell ssl tcltk tcpd tiff transcode
truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 wifi xemacs xml2
xmms xpm xsl xslt xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, LINGUAS, MAKEOPTS
Comment 1 Attila Stehr 2005-07-23 17:18:21 UTC
no problems on my system:

magic atti # emerge -pvD cdrdao

These are the packages that I would merge, in order:

Calculating dependencies  ...done!
[ebuild   R   ] app-cdr/cdrdao-1.2.0  -debug +encode +gnome -pccts 0 kB

Total size of downloads: 0 kB



Portage 2.0.51.22-r2 (default-linux/amd64/2004.3/lib64, gcc-3.4.3,
glibc-2.3.5-r0, 2.6.12-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /usr/X11R6/bin/startx /etc/env.d"
CXXFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig candy distlocks sandbox severe sfperms strict test"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
ftp://ftp.gentoo.mesh-solutions.com/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LINGUAS="de_DE@euro"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 audiofile avi berkdb bitmap-fonts bzlib cdr crypt
cups curl dga directfb dlloader dmalloc dpms dts dvd dvdr dvdread eds emacs
encode esd exif fam fame fat fbcon ffmpeg flac font-server foomaticdb fortran
gdbm gif gimpprint gnome gpm gstreamer gtk gtk2 hal hardened howl imagemagick
imlib ipv6 ithreads javascript jp2 jpeg jpeg2k kde lcms libsamplerate libwww lzo
lzw lzw-tiff mad matroska memlimit mikmod mjpeg mmap mng mozcalendar mozdevelop
mozsvg mp3 mpeg mpi multilib ncurses nls nptl nptlonly ntfs nvidia ogg oggvorbis
on-the-fly-crypt openal openexr opengl oss pam pda pdflib perl png ppds python
qt quicktime readline real reiserfs sdl slang sndfile spell ssl svg symlink
tcltk tcpd test tetex tga theora threads tidy tiff toolbar truetype
truetype-fonts type1-fonts unicode usb userlocales videos vorbis wmf xine xml2
xmms xpm xprint xrandr xtermtoolbar xv xvid xvmc yv12 zlib linguas_de_DE@euro
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, PORTDIR_OVERLAY
Comment 2 Lars Weiler (RETIRED) gentoo-dev 2005-07-23 17:54:21 UTC
This version of cdrdao needs media-libs/libao as a dependency.  Obviously it's
missing in the ebuild and nobody recognized the problem during the testing-phase.

Thanks for finding this bug!  It should be fixed in portage now.
Comment 3 Roalt 2005-07-24 12:21:09 UTC
Thanks! But something weird is going on here: I just did a 'emerge --sync', and
afterwards tried to do a 'emerge cdrdao'. It still does not try to make libao
first!:

phlox ~ # emerge -pv cdrdao

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] app-cdr/cdrdao-1.2.0  -debug +encode +gnome -pccts 0 kB


To see if my 'emerge --sync' I looked in the /usr/portage/app-cdr/cdrdao and did
see a reference to media-libs/libao:
RDEPEND="encode? ( >=media-sound/lame-3.90 )
        gnome? ( >=dev-cpp/gtkmm-2.4
                >=dev-cpp/libgnomemm-2.6
                >=dev-cpp/libgnomecanvasmm-2.6
                >=dev-cpp/gconfmm-2.6
                >=dev-cpp/libgnomeuimm-2.6
                media-libs/libao )"

(and the changelog even refers to this bug!)

I'm not that familiar with either ebuild files or gentoo in general (so it could
be I miss a step, that's why I didn't reopen it) or is there still something not
fully 100% ?



Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-07-26 16:15:42 UTC
*** Bug 100420 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-07-28 02:02:46 UTC
*** Bug 100557 has been marked as a duplicate of this bug. ***
Comment 6 Roalt 2005-08-20 07:34:21 UTC
As I reported before, the problem is still not fixed.
Comment 7 Luis Medinas (RETIRED) gentoo-dev 2005-08-20 12:51:12 UTC
try USE="gnome" emerge cdrdao.
According to the ebuild libao is only a dependency when you use USE="gnome".
Comment 8 Luis Medinas (RETIRED) gentoo-dev 2005-08-20 12:53:59 UTC
darksystem metalgod # emerge -pv cdrdao

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] media-libs/libao-0.8.5  +alsa +arts +esd -mmap -nas -static 0 kB
[ebuild  N    ] app-cdr/cdrdao-1.2.0  -debug +encode +gnome -pccts 0 kB


I will close the bug. Seems to be everything fine here.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-08-21 04:45:07 UTC
*** Bug 103209 has been marked as a duplicate of this bug. ***
Comment 10 Mark D. 2005-08-23 23:13:06 UTC
This bug is not fixed (or maybe this is a new bug). cdrdao does not compile when
I enable the gnome use flag, and I do have libao compiled.

Here's my output:

f-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0
-lgmodule-2.0 -ldl -lglib-2.0   -L/usr/lib -lmad -lm   -L//usr/lib -lvorbisfile
-lvorbis -lm -logg   -L/usr/lib -lao    -lnsl
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld:
cannot find -lgnomevfsmm-2.6
collect2: ld returned 1 exit status
make[3]: *** [gcdmaster] Error 1
make[3]: Leaving directory `/var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0/xdao'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0/xdao'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0'
make: *** [all] Error 2

!!! ERROR: app-cdr/cdrdao-1.2.0 failed.
!!! Function src_compile, Line 55, Exitcode 2


It does work if I remove the gnome dependency.
Comment 11 Roalt Dot Com 2005-08-24 12:22:14 UTC
Luis Medinas: Did you check if the fix worked on a x86_64 platform? I think that
may be the problem...
Comment 12 Milton Pividori 2005-08-24 13:20:18 UTC
It works on AMD64. I have cdrdao installed with the gnome USE flag activated. I
had problems with cdrdao before (discovered when I was trying to install k3b),
but then I could compile it. I am really sorry, but I don't remember what I did
to fix it.

Here you have some useful info (I hope that it is useful):

# emerge -pv libao
[ebuild   R   ] media-libs/libao-0.8.5  +alsa -arts +esd -mmap -nas -static 0 kB

# emerge -pv cdrdao
[ebuild   R   ] app-cdr/cdrdao-1.2.0  -debug +encode +gnome -pccts 0 kB

#emerge --info
Portage 2.0.51.22-r2 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1, 2.6
.12-gentoo-r9 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share
/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib6
4/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://www.las.ic.unicamp.br/pub/gentoo/ ftp://ftp.las.ic.unicam
p.br/pub/gentoo/"
LANG="es_AR"
LC_ALL="es_AR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi bash-completion berkdb bitmap-fonts cdr crypt cups curl dv
d dvdr eds encode esd fam flac foomaticdb fortran gif gnome gpm gstreamer gtk gt
k2 ieee1394 imagemagick imlib ipv6 java jpeg junit lm_sensors lzw lzw-tiff mad m
ozilla mp3 mpeg ncurses nls nvidia ogg oggvorbis opengl pam pdflib perl png pyth
on quicktime readline samba sdl spell ssl tcpd tiff truetype-fonts type1-fonts u
sb userlocales vorbis xml2 xmms xpm xv xvid zlib userland_GNU kernel_linux elibc
_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 13 Roalt 2005-08-27 04:08:33 UTC
There is absolutely WEIRD! I just did a emerge --sync and emerge -u world 'just
to be sure'... and I STILL GET THIS ERROR!

I re-did an 'emerge libao' but it does not help. I think I use the same USE
combinations.

Does it help to do something like 'emerge --deep --newuse -u world' ?

I went to the /var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0/xdao directory and
I found out the '-lao' was missing, when I added it, the message that failed
worked again! Question: Why was it not added?



phlox kernel # emerge -pv libao

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-libs/libao-0.8.5  +alsa -arts +esd -mmap -nas -static 0 kB

Total size of downloads: 0 kB
phlox kernel # emerge -pv cdrdao

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] app-cdr/cdrdao-1.2.0  -debug +encode +gnome -pccts 0 kB

Total size of downloads: 0 kB
phlox kernel # emerge --info
Portage 2.0.51.22-r2 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16, 1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo/
http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf-8"
LC_ALL="en_US.utf-8"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi berkdb bitmap-fonts browserplugin cdr crypt css cups curl
doc dv dvd dvdr eds encode esd evo fam foomaticdb fortran gdbm gif gimpprint
gnome gphoto2 gpm gstreamer gtk gtk2 hal ieee1394 imagemagick imlib ipv6 java
jpeg kde ldap lzw lzw-tiff mozilla mp3 mpeg mysql ncurses nls opengl pam pda
pdflib perl png ppds python qt quicktime readline real samba sdl slang spell ssl
tcltk tcpd tiff transcode truetype-fonts type1-fonts unicode usb userlocales v4l
v4l2 wifi xemacs xml2 xmms xpm xsl xslt xv zlib userland_GNU kernel_linux
elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, LINGUAS, MAKEOPTS

Comment 14 Milton Pividori 2005-08-27 17:06:02 UTC
Yes... try "emerge --sync" and then "emerge --update --deep --newuse world". If
it doesn't work, I can give you the binaries...
Comment 15 Luis Medinas (RETIRED) gentoo-dev 2005-08-27 21:50:28 UTC
I'm investigating this... i need to do a few tests and probably pull off some
CFLAGS on x86.
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2005-09-27 12:44:50 UTC
*** Bug 107437 has been marked as a duplicate of this bug. ***
Comment 17 Ilya Schurov 2005-09-30 06:57:49 UTC
Problem persists (AMD64) after re-emerging libao and after 'emerge --update
--deep --newuse world'.
Comment 18 Roalt 2005-10-05 03:40:23 UTC
First I thought I was the only one with this problem, but now I see that there
are more with this same problem, I think this is still an open bug. 

Maybe people where this problems appears or does not appear can list their
emerge --info ? 

There must be something more complicated wrong. Could it be an error in
'autoconf', C Compiler flags, a mixed-up portage cache? 

I would really like to do something like 'emerge
--rebuild-my-complete-system-and-i-do-not-care-if-it-takes-2-weeks' but the
emerge --deep --newuse world just not helps...

I repeat my remark I did before as I think the core of the problem is there:

<quote>
I went to the /var/tmp/portage/cdrdao-1.2.0/work/cdrdao-1.2.0/xdao directory and
I found out the '-lao' was missing, when I added it, the message that failed
worked again! Question: Why was it not added?
</quote>
Comment 19 Milton Pividori 2005-10-05 07:47:11 UTC
This is my emerge --info output:

Portage 2.0.51.22-r2 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.12-gentoo-r10 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r10 x86_64 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System version 1.6.13
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks fixpackages sandbox sfperms strict"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/
http://www.las.ic.unicamp.br/pub/gentoo/"
LANG="en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="amd64 X alsa apache2 avi berkdb bitmap-fonts cdr crypt cups curl dvd dvdr
eds emboss encode esd fam foomaticdb fortran gif gimpprint gnome gpm gstreamer
gtk gtk2 hal howl imagemagick imlib ipv6 java jpeg libwww lzw lzw-tiff mad
mozilla mp3 mpeg mysql ncurses nls nvidia ogg oggvorbis opengl pam pdflib perl
png postgres python quicktime readline sdl spell ssl tcpd tiff truetype
truetype-fonts type1-fonts usb userlocales vorbis xine xml xml2 xpm xv xvid zlib
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTDIR_OVERLAY
Comment 20 Ilya Schurov 2005-10-05 10:51:32 UTC
user@heartofgold ~ $ emerge --info
Portage 2.0.52-r1 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.13-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.0_pre8
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/
http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.gentoo.no/"
LANG="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="X alsa amd64 avi bash-completion berkdb bitmap-fonts cdr crypt cups dvd eds
emboss encode fam foomaticdb fortran gif gnome gpm gstreamer gtk gtk2 guile
imagemagick imlib ipv6 jpeg libwww lzw lzw-tiff mp3 mpeg ncurses nls nvidia ogg
opengl pam pdflib perl png python qt quicktime readline sdl spell ssl tcltk tcpd
tetex tiff truetype-fonts type1-fonts unicode usb userlocales vorbis xine xml2
xpm xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 21 Lorentz Morrow 2005-10-26 07:48:08 UTC
I've got two that fail...

lorentz1 lorentz # emerge --info
Portage 2.0.53_rc6 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2,
2.6.13-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.13-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.0_pre9
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distfiles.gentoo.org
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi berkdb bitmap-fonts cdr crypt cups eds emboss encode esd
fam foomaticdb fortran gif gnome gpm gstreamer gtk gtk2 imagemagick imlib ipv6
jpeg kde lzw lzw-tiff mp3 mpeg ncurses nls opengl pam pdflib perl png python qt
quicktime readline sdl spell ssl tcpd tiff truetype-fonts type1-fonts udev usb
userlocales xine xml2 xpm xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

acmoss1 lorentz # emerge --info
Portage 2.0.53_rc6 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2,
2.6.13-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.13-gentoo-r4 x86_64 AMD Opteron(tm) Processor 250
Gentoo Base System version 1.12.0_pre9
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distfiles.gentoo.org
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="amd64 X apache avi berkdb bitmap-fonts cdr crypt cups dvd eds emboss encode
fam foomaticdb fortran gif gnome gpm gstreamer gtk gtk2 imlib ipv6 jpeg kde
libwww lzw lzw-tiff mp3 mpeg mysql ncurses nls opengl pam pdflib perl png python
qt quicktime readline sdl spell ssl tcpd tiff truetype-fonts type1-fonts udev
usb userlocales xml2 xpm xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 22 Collin Grégory 2005-10-27 10:22:17 UTC
Just a tips that worked for me : 

I'm using the gnome desktop environment and so i set the gnome flag in my
make.conf...
But when i have been in front of the same as yours i tried to unset temporarly
the gnome flag just for the cdrdao package and it allowed me to compile k3b
cleanly !

Maybe is it a clues for a future correction of the ebuild ?

Cheers ;)

Greg
Comment 23 Roalt 2005-10-28 05:03:16 UTC
Hi Greg,

That tip works like a charm! I removed the 'gnome' use flag and then cdrdao
compiled and after I enabled 'gnome' I could emerge k3b without any problems. So
we probably have to add a line :

app-cdr/cdrdao -gnome

to our /etc/portage/package.use file (I have not tried that but I assume that
the way to proceed until this bug is actually fixed).

So most other people with this bug run gnome and only use k3b for it's
functionality...

Comment 24 Luis Medinas (RETIRED) gentoo-dev 2005-11-26 14:28:27 UTC
1.2.1 is in CVS. Please test and see if this bug is there (because i don't have
this issue). Reopen if you still have the same problem.
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2005-12-10 05:43:11 UTC
*** Bug 114568 has been marked as a duplicate of this bug. ***
Comment 26 Roalt 2005-12-10 07:36:48 UTC
I just did a emerge sync and then commented out any '-gnome' use flags from the
/etc/portage/package.use file. I then did a "ACCEPT_KEYWORDS="~x86" emerge
cdrdao" and the package (1.2.1) compiles!

Good work, another bug solved!
Comment 27 Luis Medinas (RETIRED) gentoo-dev 2005-12-10 07:45:43 UTC
great i'll mark it stable asap.
Comment 28 Jakub Moc (RETIRED) gentoo-dev 2006-12-24 01:10:12 UTC
*** Bug 159003 has been marked as a duplicate of this bug. ***