Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 100039 (app-cdr/bashburn-1.6) - app-cdr/bashburn-1.6 and app-cdr/cdrtools-2.01.01_alpha01-r2 - can't record cd due to illegal write mode error
Summary: app-cdr/bashburn-1.6 and app-cdr/cdrtools-2.01.01_alpha01-r2 - can't record c...
Status: RESOLVED NEEDINFO
Alias: app-cdr/bashburn-1.6
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-23 09:59 UTC by Łukasz Damentko (RETIRED)
Modified: 2006-12-21 12:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
.config (.config,28.45 KB, text/plain)
2005-08-21 06:14 UTC, Łukasz Damentko (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz Damentko (RETIRED) gentoo-dev 2005-07-23 09:59:30 UTC
After configuring bashburn-1.6 and trying to burn cd I get below error with
every try to compile. Doesn't matter what mode I select it refuses to burn.




Reproducible: Always
Steps to Reproduce:
1. emerge and configure bashburn and cdrtools
2. try to burn cd with bashburn

Actual Results:  
ISO found

Not enabling overburn...
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J
Comment 1 Łukasz Damentko (RETIRED) gentoo-dev 2005-07-23 09:59:30 UTC
After configuring bashburn-1.6 and trying to burn cd I get below error with
every try to compile. Doesn't matter what mode I select it refuses to burn.




Reproducible: Always
Steps to Reproduce:
1. emerge and configure bashburn and cdrtools
2. try to burn cd with bashburn

Actual Results:  
ISO found

Not enabling overburn...
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
cdrecord: Warning: Running on Linux-2.6.12-ck2
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
TOC Type: 1 = CD-ROM
cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: 'ATAPI:0,0,0'
devname: 'ATAPI'
scsibus: 0 target: 0 lun: 0
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'HL-DT-ST'
Identifikation : 'CD-RW GCE-8481B '
Revision       : '1.00'
Device seems to be: Generic mmc CD-RW.
Current: 0x0009
Profile: 0x000A
Profile: 0x0009 (current)
Profile: 0x0008
Profile: 0x0002 (current)
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO BURNFREE
Supported modes:
Drive buf size : 1467136 = 1432 KB
FIFO size      : 4194304 = 4096 KB
cdrecord: Drive does not support SAO recording.
cdrecord: Illegal write mode for this drive.
Burning failed. Check docs for info.
Press [ENTER] to return to main menu.

Expected Results:  
Burn cd cleanly!

|-(Setup)                       (CURRENT VALUE)
|  1) CD-Writer                 (ATAPI:0,0,0)
|  2) CD-Reader Device File     (/dev/cdrom)
|  3) CD-Reader Mount Point     (/mnt/cdrom)
|  4) Speed                     (32)
|  5) Blanking Type             (fast)
|  6) Number of Devices         (1)
|  7) Root Directory            (/opt/BashBurn)
|  8) Burn Directory            (/tmp/burn)
|  9) CD Label                  (BashBurn CD)
| 10) Copyright                 (GNU GENERAL PUBLIC LICENSE)
| 11) Author                    (<Change me>)
| 12) Publisher                 (<Change me>)
| 13) Description               (Burned with BashBurn)
| 14) Name of the package       (<Change me>)
| 15) Normalize                 (yes)
| 16) Driver options            ()
| 17) FIFO directory            (/tmp)
| 18) Delete temp after burn    (no)
| 19) Allow overburn            (no)
| 20) Copy protection           (no)
| 21) Set the Bitrate           (128)
| 22) Language                  (English)
| 23) DAO/TAO                   (-dao)

Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r0,
2.6.12-ck2 i686)
=================================================================
System uname: 2.6.12-ck2 i686 AMD Athlon(tm) XP 2000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env
/usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="pl_PL"
LC_ALL="pl_PL"
LINGUAS="pl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X aalib alsa apache apache2 apm audiofile avi berkdb bitmap-fonts
cdr crypt cups curl dba dts eds emboss encode esd esound extras fam fastcgi flac
font-server foomaticdb fortran gd gdbm gif gnome gpm gstreamer gtk gtk2
imagemagick imlib innodb jabber java jpeg ldap libg++ libwww mad maildir mbox
mikmod mmx mmx2 motif mp3 mpeg mysql ncurses nls nptl nptlonly ogg oggvorbis
opengl pam pdflib perl png ppds python qt quicktime readline real ruby sdl slang
spell sse ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts unicode
usb vorbis win32codecs xine xml xml2 xmms xv xvid zlib linguas_pl userland_GNU
kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS
Comment 2 Łukasz Damentko (RETIRED) gentoo-dev 2005-07-26 05:29:26 UTC
log from burning from root account:


ISO found

Not enabling overburn...
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J
Comment 3 Łukasz Damentko (RETIRED) gentoo-dev 2005-07-26 05:29:26 UTC
log from burning from root account:


ISO found

Not enabling overburn...
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
cdrecord: Warning: Running on Linux-2.6.12-gentoo-r6
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
TOC Type: 1 = CD-ROM
scsidev: 'ATAPI:0,0,0'
devname: 'ATAPI'
scsibus: 0 target: 0 lun: 0
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'HL-DT-ST'
Identifikation : 'CD-RW GCE-8481B '
Revision       : '1.00'
Device seems to be: Generic mmc CD-RW.
Current: 0x0009
Profile: 0x000A
Profile: 0x0009 (current)
Profile: 0x0008
Profile: 0x0002 (current)
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1467136 = 1432 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data    83 MB
Total size:       96 MB (09:31.20) = 42840 sectors
Lout start:       96 MB (09:33/15) = 42840 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -11834 (97:24/16)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 24
Manufacturer: SONY Corporation
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 317009
Starting to write CD/DVD at speed 32 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:   83 of   83 MB written (fifo 100%) [buf 100%]  26.6x.^[[5~
Track 01: Total bytes read/written: 87736320/87736320 (42840 sectors).
Writing  time:   40.126s
Average write speed  16.2x.
Min drive buffer fill was 99%
Fixating...
Fixating time:    6.620s
cdrecord: fifo had 1382 puts and 1382 gets.
cdrecord: fifo was 0 times empty and 1060 times full, min fill was 87%.

Burning finished
Temporary files in /tmp/burn not deleted...
Press [ENTER] to return to main menu.
Comment 4 Łukasz Damentko (RETIRED) gentoo-dev 2005-07-26 05:33:54 UTC
cd burned from root works fine, mounts ok, so on, it's just that specific user
problem.
Comment 5 Łukasz Damentko (RETIRED) gentoo-dev 2005-07-26 05:37:16 UTC
user permission info:

uid=1001(rane) gid=100(users)
grupy=10(wheel),16(cron),18(audio),19(cdrom),27(video),35(games),80(cdrw),100(users),250(portage)

lrwxrwxrwx  1 root root  3 lip 26 13:28 /dev/cdrom -> hdc
lrwxrwxrwx  1 root root  3 lip 26 13:28 /dev/cdrw -> hdc
brw-rw----  1 root cdrom 22, 0 lip 26 13:28 /dev/hdc
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2005-08-02 16:49:43 UTC
Is cdrecord set uid root?  There were problems with it set in the past.
Comment 7 Łukasz Damentko (RETIRED) gentoo-dev 2005-08-02 16:55:55 UTC
It isn't:

-rwxr-xr-x  1 root root 332836 lip 23 21:30 /usr/bin/cdrecord
Comment 8 Lars Weiler (RETIRED) gentoo-dev 2005-08-02 17:07:10 UTC
Sounds like bug #98393, but I can't see any similarities (like the same hardware
or the same kernel-version).
Comment 9 Łukasz Damentko (RETIRED) gentoo-dev 2005-08-02 17:39:21 UTC
Kernel version or cdrtools version isn't big issue here - i've tried all the
cdrtools in Portage and about 6 kernels before filing it here. And it changed
nothing. It can go to DUP, this side or another, i think here's more info than
in previous bugs, and i believe i excluded all the simple solutions for such
problems like udev right to files... 

Anyway, this bug was filed later, that's my mistake, sorry for that, should have
found previous one and posted all that stuff out there... 

Getting back to the matter, do you have any ideas what can cause this strange
situation? :]
Comment 10 Łukasz Damentko (RETIRED) gentoo-dev 2005-08-21 06:11:42 UTC
Situation changed dramatically, new version of cdrtools
(cdrtools-2.01.01_alpha03-r1) caused that:

[burn]$ cdrecord -v speed=2 dev=ATAPI:0,0,0 livecd-x86-2005.1.iso              
                                      cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent default
                                     s.
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 J&#258;&#347;rg Schi
                                     lling
TOC Type: 1 = CD-ROM
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: 'ATAPI:0,0,0'
devname: 'ATAPI'
scsibus: 0 target: 0 lun: 0
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
cdrecord: Cannot do inquiry for CD/DVD-Recorder.
cdrecord: Invalid argument. test unit ready: scsi sendcmd: no error
CDB:  00 00 00 00 00 00
status: 0x0 (GOOD STATUS)
cmd finished after 0.000s timeout 40s
cdrecord: The unit seems to be hung and needs power cycling.

I'm not sure, but it may be problem with my kernel config, so i'm posting it
here. Of course turning computer off and on didn't fix that.
Comment 11 Łukasz Damentko (RETIRED) gentoo-dev 2005-08-21 06:14:47 UTC
Created attachment 66473 [details]
.config

My kernel .config file.
Comment 12 Lars Weiler (RETIRED) gentoo-dev 2006-12-02 22:58:57 UTC
Quite old bug...  Is this still valid?
Comment 13 Steve Dibb (RETIRED) gentoo-dev 2006-12-21 12:33:09 UTC
resolving needinfo