Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 93753

Summary: xmms only plays vorbis when compiled vanilla
Product: Gentoo Linux Reporter: Benjamin Paul Kay <kc8tbe>
Component: Current packagesAssignee: Luis Medinas (RETIRED) <metalgod>
Severity: normal CC: sound
Priority: High Keywords: PMASKED
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on: 152472    
Bug Blocks:    

Description Benjamin Paul Kay 2005-05-23 19:23:24 UTC
ogg/vorbis files may be added to the xmms playlist, but when one of these files 
is played one of two things happens: nothing at all happens -or- there are a 
series of rapid clicks as the progess bar moves through the song in a few 
This cannot be a problem with xmms-vorbis itself, since mplayer uses   
xmms-vorbis to play ogg/vorbis files and mplayer is NOT having any trouble   
playing ogg/vorbis files.   
If I compile xmms from the vanilla sources, ogg/vorbis files play fine. However   
if I put the ebuild in Additional Information in my portage overlay and emerge   
it, the resulting xmms suffers from the same problems as the xmms from the   
normal portage tree.   
also, see forum thread:  

Reproducible: Always
Steps to Reproduce:
I'm not sure how to reproduce the bug on somebody else's system, but it occurs  
every time on my system. 
emerge info 
shell-init: could not get current directory: getcwd: cannot access parent 
directories: No such file or directory 
Portage (default-linux/x86/2005.0, gcc-3.3.5-20050130, 
glibc-, 2.6.11-gentoo-r8 i686) 
System uname: 2.6.11-gentoo-r8 i686 AMD Athlon(tm) XP 2500+ 
Gentoo Base System version 1.4.16 
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May  8 2005, 09:47:20)] 
dev-lang/python:     2.3.5 
sys-apps/sandbox:    [Not Present] 
sys-devel/autoconf:  2.59-r6, 2.13 
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5 
sys-devel/libtool:   1.5.16 
CFLAGS="-march=athlon-xp -O3 -pipe -funroll-loops -fomit-frame-pointer" 
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=athlon-xp -O3 -pipe -funroll-loops -fomit-frame-pointer" 
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict" 
USE="x86 3dfx 3dnow X Xaw3d aalib acl acpi aim alsa apache2 apm arts avi berkdb 
bidi bitmap-fonts bonobo bzlib caps cdb cdr cjk crypt cups curl curlwrappers 
dga dio directfb divx4linux dvd dvdr emboss encode esd fam fastcgi fbcon fdftk 
firebird flac foomaticdb fortran ftp gd gdbm ggi gif gnome gpm gtk gtk2 gtkhtml 
icq imagemagick imap imlib inifile ipv6 jabber java joystick jpeg kde libg++ 
libwww mad mikmod mmx motif mozilla mp3 mpeg mpi msn ncurses nls nocardbusoav 
odbc offensive ogg oggvorbis opengl oscar oss pam pcre pdflib perl png pnp 
posix ppds python qt quicktime readline ruby samba sasl scanner sdl simplexml 
slang slp sockets speex spell sse ssl svga sysvipc szip tcltk tcpd tetex theora 
tiff truetype truetype-fonts type1-fonts unicode usb vhosts videos vorbis wmf 
wxwindows xine xml xml2 xmms xosd xv xvid yahoo zlib userland_GNU kernel_linux 

# Copyright 1999-2005 Gentoo Foundation 
# Distributed under the terms of the GNU General Public License v2 
# For help with this ebuild, contact Benjamin Kay 
# $Header: $ 
DESCRIPTION="X MultiMedia System" 
src_unpack() { 
  unpack ${A} 
src_compile() { 
  cd work/xmms-1.2.10 
  econf || die "Error: econf failed" 
  emake || die "Error: emake failed!" 
src_install() { 
  cd xmms-vanilla-1.2.10/work/xmms-1.2.10 
  make DESTDIR="${D}" install || die 
Comment 1 Eric Shattow 2005-05-24 08:15:13 UTC
change this
CFLAGS="-march=athlon-xp -O3 -pipe -funroll-loops -fomit-frame-pointer" 
to this
CFLAGS="-march=athlon-xp -O2 -pipe" 
Comment 2 Benjamin Paul Kay 2005-05-24 17:08:39 UTC
Tried re-emerging "xmms-*" and "flac" using suggested CFLAGS. Also tried 
re-emerging with empty CFLAGS. Finally, tried unmerging "xmms-*" and then 
emerging "xmms-vanilla" with empty CFLAGS. In all cases, the bug persisted; the 
problem is probably not related to CFLAGS. 
Comment 3 Lukas Erni 2005-05-28 12:34:23 UTC
same problem over here.

3  media-plugins/xmms-vorbis
      Latest version available: 1.2.10-r1
      Latest version installed: 1.2.10-r1
      Size of downloaded files: 2,916 kB
      Description: Xmms Plugin: xmms-vorbis
      License:     GPL-2

*  media-libs/libvorbis
      Latest version available: 1.1.0
      Latest version installed: 1.1.0
      Size of downloaded files: 1,372 kB
      Description: the Ogg Vorbis sound file format library
      License:     BSD

*  media-sound/xmms
      Latest version available: 1.2.10-r14
      Latest version installed: 1.2.10-r14
      Size of downloaded files: 2,979 kB
      Description: X MultiMedia System
      License:     GPL-2

some make.conf stuff:
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"

I used the "oggvorbis" useflag for ogg. I also gave it a shot to unmerged and
try it a 2nd time with "ogg" beside "oggvorbis" since "oggvorbis" is deprecated
as my "/usr/portage/profiles/use.desc" is telling me. but no luck still the same
crapy noiz.

emerge -pv xmms


[ebuild   R   ] media-sound/xmms-1.2.10-r14  -3dnow +alsa +arts -debug -directfb
+esd +flac +jack -lirc +mad +mikmod -mmx +mp3 +nls +oggvorbis +oss +sndfile* 0 kB
[ebuild  N    ] media-plugins/xmms-sndfile-1.2  221 kB

as it seems the ebuild of xmms does read the +oggvorbis flag.

emerge info

Portage (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-, 2.6.11-ck8-r1 i686)
System uname: 2.6.11-ck8-r1 i686 AMD Athlon(tm) XP 2800+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May  8 2005, 12:54:03)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.9.5, 1.8.5-r3, 1.7.9-r1, 1.6.3, 1.4_p6
sys-devel/libtool:   1.5.16
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
USE="x86 X acpi alsa arts avi berkdb bitmap-fonts caps cdr crypt cups curl
divx4linux doc dvd dvdr eds emboss encode esd fam flac foomaticdb fortran gdbm
gif gimpprint gnome gpm gstreamer gtk gtk2 guile imagemagick imlib ipv6 jack
jack-tmpfs java jpeg libg++ libwww linguas_de mad mikmod motif mozilla moznomail
mp3 mpeg msn ncurses nls ogg oggvorbis opengl oscar oss other_var1 other_var2
pam pdflib pearl perl png ppds python quicktime readline real rtc samba scanner
sdl slang sndfile softmmu speex spell sqlite ssl svga tcltk tcpd tetex tiff
truetype truetype-fonts type1-fonts unicode usb vorbis xml xml2 xmms xv zlib
video_cards_rage128 userland_GNU kernel_linux elibc_glibc"
Comment 4 Lukas Erni 2005-05-29 11:55:11 UTC
today i played a ogg file with xmms fine. also the time in the playlist was
shown fine. but wait, this ogg-file was made with cdex under windowz! i have not
tryed to play with grips encoding setings but as it seams to work with some
files, xmms is probable just playing some oggs but it depens on... that what i
have not worked out right now. i have no time to do now and probable i'm not
online next week.

my enc-settings in grep:
-o %m -a %a -l %d -t %n -b %b %w -N %t -G %g -d %y
(dont now what it means now :-)

Comment 5 Andreas Thalhammer 2005-06-02 11:36:17 UTC
I have experienced the same annoying problem. Most ogg files don't play at all. 
As I ripped some CDs 8 weeks ago or so there are some news: 
- 90 % of these songs play well 
- 10 % don't play at all 
- all songs that play are shown correctly in length and mp3-tag data 
- the songs that don't play show only their filename and 0:00 or a weird song 
length (e.g. -1476/-8230) 
I monitored these effects on -q 2 (constant quality = 2) encoded ogg files. 
I recently also encoded an other pack of CDs with -q 3 and 100 % of those files 
do not play at all. 
So I gave -b 128 a try (constant bitrate), result: doesn't play! 
Problem is not depending on -q or -b settings 
Was there an oggenc update recently? Maybe xmms-vorbis (decode) is no longer 
compatible with a recent version of oggenc... 
More information: 
- media-sound/xmms-1.2.10-r14 
- ogg123 works (from media-sound/vorbis-tools-1.0.1) 
- USE="hardened pic" among other useflags. Maybe this has something to do with 
- I checked media-plugins/xmms-vorbis-1.2.10-r1 with gcc-3.3.4-vanilla (using 
gcc-config for switching) - no success 
Hell, what's wrong?!? 
Comment 6 Lukas Erni 2005-06-03 12:53:31 UTC

cool to see your results Andreas - geting closer. all descriptions you made, are
the same over here. I still do not konw anything more about it but with knoppix
the same version of xmms plays my "gentoo-xmms-broken-oggs" fine.

Comment 7 Lukas Erni 2005-06-23 07:32:22 UTC
beep-media-player (bmp) is playing the xmms-brocken-files fine! bmp is a gtk2
port of xmms. gtk1 is not utf-8 aware. is anyone with this problem on a uft-8
system? also one other thing i've noticed gnome 2.10 is telling me when i try to
play one of this suspicious files by clicking on it:

Cannot open xy.ogg
The filename "xy.ogg" indicates that this file is of type "Ogg Vorbis-Audio".
The contents of the file indicate that the file is of type "MP3-Audio". If you
open this file, the file might present a security risk to your system.
Do not open the file unless you created the file yourself, or received the file
from a trusted source. To open the file, rename the file to the correct
extension for "MP3-Audio", then open the file normally. Alternatively, use the
Open With menu to choose a specific application for the file.

how can I edit or display mime-types proper? or could this be related to utf-8
encoded id3 tags? I do not have a clou but i'm trying with some guesings :-/

Comment 8 Benjamin Paul Kay 2005-06-24 19:17:28 UTC

You can test the xmms-vorbis plugin independently of xmms to see whether or not
it can decode ogg files. Simply invoke mplayer to play an ogg file; you will
notice that it uses the xmms-vorbis shared library to decode the file. If
mplayer is able to play the file, then the error lies somewhere in xmms itself
and not in the process of decoding the ogg/vorbis file.


The error regarding mime-types is a gnome thing, at least as far as I know. I
noticed the error on ogg, flac, and wav files in one version of gnome, but
manual inspection revealed that all the files were formatted properly. Perhaps
gnome is seeing an id3 tag attached to your ogg file and assuming that is should
be an mp3 file? At any rate, I don't think this has anything to do with this bug.
Comment 9 Lukas Erni 2005-07-03 11:34:40 UTC
now found something:
it depends on wether if the file has id3v2 tags in or not. If I delete (not
balanking) the v2-tags on any of this files (I did it with media-sound/id3v2)
they just play fine with xmms.

in replay to the first one:
it is possible to play this files in mplayer! (also describted it the forumthread)

and the second:
ogg files encoded with cdex on windows do play well because they do not have
id3v2 tags. also open per click in gnome does work on files without id3v2. on my
system the gnome-warning just pops up if the file has id3v2 tags inside.

Comment 10 fkosa 2005-07-10 07:21:20 UTC
I have the same problem, but in most cases, opening an .ogg file my xmms crashes 
with segfault.

Removing id3v2 tag did not help.
Comment 11 Lukas Erni 2005-07-11 13:01:42 UTC
news again:

in short:
turn off the "MAD MPEG Decoder plugin" under Audio-I/O-Plugins and it plays fine!

can anybody confirm that?

Comment 12 Luis Medinas (RETIRED) gentoo-dev 2006-01-11 16:51:47 UTC
any news on this ?
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2006-10-23 00:37:31 UTC
xmms and all plugins are now package.masked and will be removed from the tree in one month.