Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 926967

Summary: media-video/vlc-9999 is seems like missing a BDEPEND dev-qt/qtquickcontrols2
Product: Gentoo Linux Reporter: nurali <nurali258>
Component: Current packagesAssignee: Gentoo Media-video project <media-video>
Status: UNCONFIRMED ---    
Severity: normal CC: ironmikkl
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description nurali 2024-03-14 04:57:54 UTC
I got following error when trying to emerge media-video/vlc-9999:
checking for x86_64-pc-linux-gnu-protoc... no
checking for protoc... protoc
checking protobuf-lite matches protoc version 23.3... yes
checking for Qt5Core >= 5.12.0 Qt5Widgets Qt5Gui Qt5Quick Qt5QuickWidgets Qt5QuickControls2 Qt5Svg... no
configure: error: Package 'Qt5Quick', required by 'virtual:world', not found
Package 'Qt5QuickWidgets', required by 'virtual:world', not found
Package 'Qt5QuickControls2', required by 'virtual:world', not found. If you want to build VLC without GUI, pass --disable-qt.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-video/vlc-9999/work/vlc-9999/config.log
 * ERROR: media-video/vlc-9999::gentoo failed (configure phase):
 *   econf failed
 *
And I installed dev-qt/qtquickcontrols2 manually(with/without USE="widgets"),then I can emerge vlc
Please check
Comment 1 Andreas Sturmlechner gentoo-dev 2024-03-14 20:09:43 UTC
Some build failure in 9999 can never be major.
Comment 2 Mikkl 2024-05-15 20:12:01 UTC
Same here