Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 918665 (CVE-2023-5528)

Summary: sys-cluster/kubelet: privilege escalation in windows nodes
Product: Gentoo Security Reporter: Christopher Fore <csfore>
Component: VulnerabilitiesAssignee: Gentoo Security <security>
Status: CONFIRMED ---    
Severity: major    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: C1 [ebuild]
Package list:
Runtime testing required: ---

Description Christopher Fore 2023-11-27 17:22:12 UTC
CVE-2023-5528 (https://groups.google.com/g/kubernetes-security-announce/c/SL_d4NR8pzA)

A security issue was discovered in Kubernetes where a user that can create pods and persistent volumes on Windows nodes may be able to escalate to admin privileges on those nodes. Kubernetes clusters are only affected if they are using an in-tree storage plugin for Windows nodes.
Comment 1 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2023-11-27 18:34:36 UTC
Note that we don't version the summary until there's a fixed version in tree. Thanks for reporting!

William, please bump.