Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 918639

Summary: =dev-ml/dune-2.9.3-r3 fails tests
Product: Gentoo Linux Reporter: matoro <matoro_gentoo>
Component: Current packagesAssignee: Gentoo Team for the ML programming language family <ml>
Status: CONFIRMED ---    
Severity: normal CC: matoro_gentoo, tupone
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 896102    
Attachments: build.log

Description matoro archtester 2023-11-27 01:49:02 UTC
>>> Test phase: dev-ml/dune-2.9.3-r3
make -j10   check
./dune.exe build @check
File "/usr/lib64/ocaml/core_bench/dune-package", line 1, characters 11-14:
1 | (lang dune 3.7)
               ^^^
Error: Version 3.7 of the dune language is not supported.
Supported versions of this extension in version 3.7 of the dune language:
- 1.0 to 1.12
- 2.0 to 2.9
File "/usr/lib64/ocaml/ppx_bench/dune-package", line 1, characters 11-14:
1 | (lang dune 3.7)
               ^^^
Error: Version 3.7 of the dune language is not supported.
Supported versions of this extension in version 3.7 of the dune language:
- 1.0 to 1.12
- 2.0 to 2.9
File "/usr/lib64/ocaml/ppx_expect/dune-package", line 1, characters 11-14:
1 | (lang dune 3.7)
               ^^^
Error: Version 3.7 of the dune language is not supported.
Supported versions of this extension in version 3.7 of the dune language:
- 1.0 to 1.12
- 2.0 to 2.9
File "/usr/lib64/ocaml/result/dune-package", line 1, characters 11-14:
1 | (lang dune 3.7)
               ^^^
Error: Version 3.7 of the dune language is not supported.
Supported versions of this extension in version 3.7 of the dune language:
- 1.0 to 1.12
- 2.0 to 2.9
-> required by library "dune-configurator" in
   _build/default/otherlibs/configurator/src
make: *** [Makefile:87: check] Error 1
 * ERROR: dev-ml/dune-2.9.3-r3::gentoo failed (test phase):

Reproducible: Always




Portage 3.0.51 (python 3.11.6-final-0, default/linux/arm64/17.0, gcc-13, glibc-2.37-r7, 6.1.60-gentoo-dist aarch64)
=================================================================
System uname: Linux-6.1.60-gentoo-dist-aarch64-with-glibc2.37
KiB Mem:    65137172 total,  12668160 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 27 Nov 2023 00:32:01 +0000
sh bash 5.1_p16-r6
ld GNU ld (Gentoo 2.40 p5) 2.40.0
app-misc/pax-utils:        1.3.7::gentoo
app-shells/bash:           5.1_p16-r6::gentoo
dev-lang/perl:             5.38.0-r1::gentoo
dev-lang/python:           3.11.6::gentoo, 3.12.0_p1::gentoo
dev-util/cmake:            3.27.7::gentoo
dev-util/meson:            1.2.3::gentoo
sys-apps/baselayout:       2.14::gentoo
sys-apps/openrc:           0.48::gentoo
sys-apps/sandbox:          2.38::gentoo
sys-devel/autoconf:        2.71-r6::gentoo
sys-devel/automake:        1.16.5-r1::gentoo
sys-devel/binutils:        2.40-r5::gentoo
sys-devel/binutils-config: 5.5::gentoo
sys-devel/gcc:             13.2.1_p20230826::gentoo
sys-devel/gcc-config:      2.11::gentoo
sys-devel/libtool:         2.4.7-r1::gentoo
sys-devel/make:            4.4.1-r1::gentoo
sys-kernel/linux-headers:  6.1::gentoo (virtual/os-headers)
sys-libs/glibc:            2.37-r7::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    volatile: False
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24

Binary Repositories:

gentoobinhost
    priority: 1
    sync-uri: https://gentoo.osuosl.org/releases/arm64/binpackages/17.0/arm64

ACCEPT_KEYWORDS="arm64"
ACCEPT_LICENSE="@FREE"
CBUILD="aarch64-unknown-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="aarch64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=y --autounmask-continue=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GDK_PIXBUF_MODULE_FILE GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR XDG_STATE_HOME"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg-live config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LEX="flex"
MAKEOPTS="-j10"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/sbin/nologin"
USE="acl arm64 bzip2 cli crypt dri fortran gdbm iconv ipv6 libtirpc ncurses nls nptl openmp pam pcre readline seccomp split-usr ssl test-rust unicode xattr zlib" ADA_TARGET="gnat_2021" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_ARM="edsp v8 vfp vfp-d32 vfpv3 vfpv4" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php8-1" POSTGRES_TARGETS="postgres15" PYTHON_SINGLE_TARGET="python3_11" PYTHON_TARGETS="python3_11" RUBY_TARGETS="ruby31" VIDEO_CARDS="fbdev dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, INSTALL_MASK, LC_ALL, LD, LFLAGS, LIBTOOL, LINGUAS, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS
Comment 1 matoro archtester 2023-11-27 01:49:18 UTC
Created attachment 875758 [details]
build.log
Comment 2 Tupone Alfredo gentoo-dev 2024-06-02 08:06:01 UTC
it seems that dune put in the installed files a requirement that dune should be at least the version that is used at time of install.

to be short, test will work only if ppx_bench, core_bench, ppx_expect & result are built with the version that is in testing.

So please test again with previously dropping those packages
Comment 3 matoro archtester 2024-06-02 19:12:21 UTC
(In reply to Tupone Alfredo from comment #2)
> it seems that dune put in the installed files a requirement that dune should
> be at least the version that is used at time of install.
> 
> to be short, test will work only if ppx_bench, core_bench, ppx_expect &
> result are built with the version that is in testing.
> 
> So please test again with previously dropping those packages

Is there any way to enforce this in the ebuild?
Comment 4 Tupone Alfredo gentoo-dev 2024-06-03 04:58:08 UTC
(In reply to matoro from comment #3)
> (In reply to Tupone Alfredo from comment #2)
> > it seems that dune put in the installed files a requirement that dune should
> > be at least the version that is used at time of install.
> > 
> > to be short, test will work only if ppx_bench, core_bench, ppx_expect &
> > result are built with the version that is in testing.
> > 
> > So please test again with previously dropping those packages
> 
> Is there any way to enforce this in the ebuild?

I don't think so.
Comment 5 matoro archtester 2024-06-03 19:16:02 UTC
(In reply to Tupone Alfredo from comment #4)
> (In reply to matoro from comment #3)
> > (In reply to Tupone Alfredo from comment #2)
> > > it seems that dune put in the installed files a requirement that dune should
> > > be at least the version that is used at time of install.
> > > 
> > > to be short, test will work only if ppx_bench, core_bench, ppx_expect &
> > > result are built with the version that is in testing.
> > > 
> > > So please test again with previously dropping those packages
> > 
> > Is there any way to enforce this in the ebuild?
> 
> I don't think so.

What about a check in pkg_setup that looks at the versions?  Would that be acceptable?  I can look into implementing it if necessary.
Comment 6 Tupone Alfredo gentoo-dev 2024-06-04 06:06:39 UTC
Probably the best things to do is checking if dune was previously installed and that the version installed is greater than current.

In that case tell user that all dune dependent packages must be removed (something like glibc, you cannot downgrade easily)
Comment 7 matoro archtester 2024-06-04 14:21:02 UTC
(In reply to Tupone Alfredo from comment #6)
> Probably the best things to do is checking if dune was previously installed
> and that the version installed is greater than current.
> 
> In that case tell user that all dune dependent packages must be removed
> (something like glibc, you cannot downgrade easily)

What about subslot binds (:=) that would force them to be rebuilt on any dune version change?
Comment 8 Tupone Alfredo gentoo-dev 2024-06-04 15:00:51 UTC
(In reply to matoro from comment #7)
> (In reply to Tupone Alfredo from comment #6)
> > Probably the best things to do is checking if dune was previously installed
> > and that the version installed is greater than current.
> > 
> > In that case tell user that all dune dependent packages must be removed
> > (something like glibc, you cannot downgrade easily)
> 
> What about subslot binds (:=) that would force them to be rebuilt on any
> dune version change?

That is already done. But for making the test working you need to compile install merge rebuild the packages that are needed for test and only then test dune