Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 91763

Summary: K3B Does not detect proper media speed
Product: Gentoo Linux Reporter: Brian Harris <verlane24>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Brian Harris 2005-05-06 21:05:25 UTC
K3B 0.11.18 and 0.11.23 do not detect proper media speed. After starting burn process, K3B reports that burner(40x) and/or media(24x) do not support 24X, and K3B drops to 4X. 

This is on a pioneer dvr-109, kernel 2.6.11-r6 and 2.6.8-r6 both have same problem. DMA is active, and I get descent results with hdparm. Previous TDK burner wrote at full speed 16X. 

I believe this is a gentoo issue; the only other reference i found to a similar problem after exhaustive searching was also a gentoo user.

Reproducible: Always
Steps to Reproduce:
1.Set speed at 24X.
2.Start burn process
3.K3B reports that it cannot burn at 24X, reverts to 4X and burns CD.

Actual Results:  
takes 30 minutes to burn audio CD

Expected Results:  
Burn at top speed rated for media 24X

Output from K3B after burning is finished:

System
-----------------------
K3b Version:0.11.18
KDE Version: 3.3.2
QT Version: 3.3.4

cdrecord
-----------------------
/usr/bin/cdrecord: Warning: Running on Linux-2.6.11-gentoo-r6
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
SCSI buffer size: 64512
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J
Comment 1 Brian Harris 2005-05-06 21:05:25 UTC
K3B 0.11.18 and 0.11.23 do not detect proper media speed. After starting burn process, K3B reports that burner(40x) and/or media(24x) do not support 24X, and K3B drops to 4X. 

This is on a pioneer dvr-109, kernel 2.6.11-r6 and 2.6.8-r6 both have same problem. DMA is active, and I get descent results with hdparm. Previous TDK burner wrote at full speed 16X. 

I believe this is a gentoo issue; the only other reference i found to a similar problem after exhaustive searching was also a gentoo user.

Reproducible: Always
Steps to Reproduce:
1.Set speed at 24X.
2.Start burn process
3.K3B reports that it cannot burn at 24X, reverts to 4X and burns CD.

Actual Results:  
takes 30 minutes to burn audio CD

Expected Results:  
Burn at top speed rated for media 24X

Output from K3B after burning is finished:

System
-----------------------
K3b Version:0.11.18
KDE Version: 3.3.2
QT Version: 3.3.4

cdrecord
-----------------------
/usr/bin/cdrecord: Warning: Running on Linux-2.6.11-gentoo-r6
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
SCSI buffer size: 64512
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
on-the-fly encryption (version 1.0-rc1) built-in, (C) 2004,2005 Maximilian Decker
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <burbon04 at gmx.de>.
      For more information please see
http://burbon04.gmxhome.de/linux/CDREncryption.html.
      The original author should not be bothered with problems of this version.
TOC Type: 0 = CD-DA
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'PIONEER '
Identifikation : 'DVD-RW  DVR-109 '
Revision       : '1.17'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x0009
Profile: 0x002B
Profile: 0x001B
Profile: 0x001A
Profile: 0x0016
Profile: 0x0015
Profile: 0x0014
Profile: 0x0013
/usr/bin/cdrecord: This version of cdrecord does not include DVD-R/DVD-RW
support code.
/usr/bin/cdrecord: If you need DVD-R/DVD-RW support, ask the Author for
cdrecord-ProDVD.
/usr/bin/cdrecord: Free test versions and free keys for personal use are at
ftp://ftp.berlios.de/pub/cdrecord/ProDVD/
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009 (current)
Profile: 0x0008
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1267712 = 1238 KB
FIFO size      : 4194304 = 4096 KB
Encoding speed : 445x (33327 sectors/s) for libedc from Heiko Eißfeldt
pregap1: -1
Track 01: audio   30 MB (03:03.42) no preemp     
Track 02: audio   24 MB (02:27.10) no preemp      pregapsize:   0
Track 03: audio   23 MB (02:19.16) no preemp      pregapsize:   0
Track 04: audio   27 MB (02:44.77) no preemp      pregapsize:   0
Track 05: audio   41 MB (04:04.96) no preemp      pregapsize:   0
Track 06: audio   30 MB (03:03.00) no preemp      pregapsize:   0
Track 07: audio   30 MB (03:01.50) no preemp      pregapsize:   0
Track 08: audio    8 MB (00:51.60) no preemp      pregapsize:   0
Track 09: audio  304 MB (30:07.46) no preemp      pregapsize:   0
Total size:      522 MB (51:43.00) = 232725 sectors
Lout start:      522 MB (51:45/00) = 232725 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -11834 (97:24/16)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
Manuf. index: 24
Manufacturer: SONY Corporation
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 127124
Starting to write CD/DVD at speed 4 in real RAW/RAW96R mode for single session.
Last chance to quit, starting real write in 2 seconds.
   1 seconds.
   0 seconds.
 Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Turning BURN-Free on
Performing OPC...
/usr/bin/cdrecord: WARNING: Drive returns wrong startsec (-150) using -11834
from ATIP
Writing lead-in at sector -11834
Lead-in write time:   59.939s
Writing pregap for track 1 at -150
Encryption feature disabled.
Starting new track at sector: 0
Track 01:    0 of   32 MB written.
Track 01:    1 of   32 MB written (fifo 100%) [buf  98%]   6.2x.
......etc etc etc


Writing  time:  847.753s
Average write speed   3.9x.
Min drive buffer fill was 4%
Total of 1 possible drive buffer underruns predicted.
Writing Leadout...
Fixating...
Fixating time:   34.399s
/usr/bin/cdrecord: fifo had 8955 puts and 8955 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 6976 times full, min fill was 70%.

cdrecord comand:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=40 -raw96r
driveropts=burnfree -eject -text -useinfo -audio -shorttrack
/tmp/kde-brian/k3bCdCopy0/Track01.wav /tmp/kde-brian/k3bCdCopy0/Track02.wav
/tmp/kde-brian/k3bCdCopy0/Track03.wav /tmp/kde-brian/k3bCdCopy0/Track04.wav
/tmp/kde-brian/k3bCdCopy0/Track05.wav /tmp/kde-brian/k3bCdCopy0/Track06.wav
/tmp/kde-brian/k3bCdCopy0/Track07.wav /tmp/kde-brian/k3bCdCopy0/Track08.wav
/tmp/kde-brian/k3bCdCopy0/Track09.wav

emerge info:

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.200
                                                                               
   41102-r1, 2.6.11-gentoo-r6 i686)
=================================================================
System uname: 2.6.11-gentoo-r6 i686 Intel(R) Pentium(R) 4 CPU 1500MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Apr 30 2005, 11:41:52)]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -Wall -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share
                                                                               
   /config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb
/usr/shar                                                                      
             e/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -Wall -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/
                                                                               
   distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acpi alsa avi berkdb bitmap-fonts cdparanoia cdr crypt cups curl divx
                                                                               
   4linux dv dvd dvdr dvdread emboss encode fam flac foomaticdb fortran gdbm gif
gi                                                                             
      mp gpm gtk gtk2 imagemagick imlib ipv6 jpeg libg++ libwww mad mikmod mmx
mmx2 mo                                                                        
           tif mozilla mp3 mpeg ncurses nls nptl ogg oggvorbis opengl oss pam
pdflib perl p                                                                  
                 ic png python qt quicktime readline scanner sdl spell sqlite
sse sse2 ssl svga t                                                            
                       cpd tiff truetype truetype-fonts type1-fonts usb vorbis
win32codecs xine xml2 xm                                                       
                            ms xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LINGUAS, PORTDIR_OVERLAY
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2005-05-07 02:00:52 UTC

*** This bug has been marked as a duplicate of 90947 ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-05-07 02:26:24 UTC
Also, latest firmware is 1.40 (you have 1.17), so you could give it a try.

http://www.pioneerelectronics.com/pna/article/0,,2076_4249_201803982,00.html
Comment 4 Brian Harris 2005-05-07 13:01:31 UTC
Well, for anyone else who has this issue it is not resolved by firmware upgrade.

Will post bug with KDE.

Thanks