Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 91341

Summary: openmotif cannot be upgraded due to motif-config block
Product: Gentoo Linux Reporter: Jason Rhinelander <gentoo>
Component: New packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---

Description Jason Rhinelander 2005-05-03 12:31:08 UTC
When doing an upgrade of my system I ran into an inability to upgrade packages due to a new openmotif being available (openmotif-2.2.3-r6 -> openmotif-2.2.3-r7), however the new openmotif depends on motif-config-0.9.  The problem is that 0.9 blocks versions of openmotif prior to 2.2.3-r7, and this block prevents a smooth upgrade.

I realize that I can get around this by unmerging one or both and remerging them, but that is the problem: this is a far from optimal solution, and should not be necessary.  openmotif and motif-config should upgrade smoothly and cleanly; manually unmerging the old packages should not be required.
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-05-03 14:30:49 UTC

*** This bug has been marked as a duplicate of 79606 ***