Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 909816

Summary: net-im/neochat-23.04.3 fails tests
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: lg3dx6fd
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: fixed in 24.02.2
Package list:
Runtime testing required: ---
Attachments: build.log
1-LastTest.log

Description Agostino Sarubbo gentoo-dev 2023-07-07 06:52:04 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-im/neochat-23.04.3 fails tests.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2023-07-07 06:52:07 UTC
Created attachment 865217 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-07-07 06:52:08 UTC
Created attachment 865218 [details]
1-LastTest.log

1-LastTest.log
Comment 3 Agostino Sarubbo gentoo-dev 2023-07-07 06:52:08 UTC
Error(s) that match a know pattern:


	  1 - neochatroomtest (Subprocess aborted)
	  2 - texthandlertest (Subprocess aborted)
  Could not find a package configuration file provided by "Sqlite3" with any
-- Could NOT find ReuseTool (missing: REUSETOOL_EXECUTABLE) 
  Reuse tool not found, skipping test generation
Comment 4 Andreas Sturmlechner gentoo-dev 2023-07-25 12:29:04 UTC
Interestingly, this works for me:

>>> Test phase: net-im/neochat-23.04.3
 * Source directory (CMAKE_USE_DIR): "/var/tmp/portage/net-im/neochat-23.04.3/work/neochat-23.04.3"
 * Build directory  (BUILD_DIR):     "/var/tmp/portage/net-im/neochat-23.04.3/work/neochat-23.04.3_build"
ctest -j 24 --test-load 999
Test project /var/tmp/portage/net-im/neochat-23.04.3/work/neochat-23.04.3_build
    Start 1: appstreamtest
    Start 2: neochatroomtest
    Start 3: texthandlertest
1/3 Test #1: appstreamtest ....................   Passed    0.01 sec
2/3 Test #2: neochatroomtest ..................   Passed    0.04 sec
3/3 Test #3: texthandlertest ..................   Passed    0.04 sec

100% tests passed, 0 tests failed out of 3
Comment 5 Andreas Sturmlechner gentoo-dev 2024-06-24 18:53:15 UTC
Tested fine for me, please re-open when it happens with >=24.05.1.
Comment 6 Andreas Sturmlechner gentoo-dev 2024-07-05 16:30:04 UTC
*** Bug 935506 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Sturmlechner gentoo-dev 2024-07-05 16:38:37 UTC
likely fixed in MR https://invent.kde.org/network/neochat/-/merge_requests/1113
Comment 8 Larry the Git Cow gentoo-dev 2024-07-05 16:50:54 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=38692a47dbf7121a85ff1300a017656354857b3c

commit 38692a47dbf7121a85ff1300a017656354857b3c
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2024-07-05 16:49:26 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2024-07-05 16:50:46 +0000

    net-im/neochat: Disable broken texthandlertest
    
    Fixed in ~arch already, more info in the bug.
    
    Bug: https://bugs.gentoo.org/909816
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 net-im/neochat/neochat-23.08.5.ebuild | 5 +++++
 1 file changed, 5 insertions(+)