Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 903543

Summary: mail-client/evolution does not start, gives "Failed to connect to socket /root/.cache/at-spi/bus_0: Permission denied"
Product: Gentoo Linux Reporter: Mark-Joe <mjpflaum>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: UNCONFIRMED ---    
Severity: normal CC: floppym
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Mark-Joe 2023-03-29 14:46:12 UTC
When attempting to start evolution (version mail-client/evolution-3.46.3-r1),
the mail client attempts to start and then quits with the message:

evolution:3204): dbind-WARNING **: 13:38:20.811: Couldn't connect to accessibility bus: Failed to connect to socket /root/.cache/at-spi/bus_0: Permission denied
(evolution-alarm-notify:3211): dbind-WARNING **: 13:38:21.024: Couldn't connect to accessibility bus: Failed to connect to socket /root/.cache/at-spi/bus_0: Permission denied
bwrap: Can't find source path /root/.cache/at-spi: Permission denied

When setting /root and /root/.cache/at-spi to a=xwr (which I obviously don't want to for long), then evolution starts.  

The behavior appears in kernel 4.19.277-gentoo and 6.1.19-gentoo
Comment 1 Mike Gilbert gentoo-dev 2023-03-29 20:29:35 UTC
Are you attempting to run evolution as root?
Comment 2 Mark-Joe 2023-03-29 20:54:23 UTC
No, I run evolution as a standard user, not as root. I tried it also with another user account, same thing. I have no idea why evolution wants to store data under /root/.cache/at-spi
Comment 3 Mike Gilbert gentoo-dev 2023-03-29 21:00:44 UTC
Is XDG_CACHE_HOME set in the environment?
Comment 4 Mark-Joe 2023-03-29 21:10:17 UTC
 XDG_CACHE_HOME has not been set. It also isn't in my older gentoo machines where evolution is running. 
 I tried to set XDG_CACHE_HOME to /home/username/.cache but it did not help