Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 89929

Summary: mplayer-1.0_pre6-r4 emerge fails
Product: Gentoo Linux Reporter: Joel Parker <jjk3>
Component: Current packagesAssignee: media-video herd <media-video>
Status: VERIFIED FIXED    
Severity: normal CC: zunbid
Priority: High    
Version: 2005.0   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Joel Parker 2005-04-21 07:31:12 UTC
I'm getting the following errors when I try to emerge media-video/mplayer-1.0_pre6-r4:

# emerge -v mplayer
Calculating dependencies ...done!
>>> emerge (1 of 1) media-video/mplayer-1.0_pre6-r4 to /
>>> md5 files   ;-) ChangeLog
>>> md5 files   ;-) metadata.xml
>>> md5 files   ;-) mplayer-1.0_pre7.ebuild
>>> md5 files   ;-) mplayer-1.0_pre5-r5.ebuild
>>> md5 files   ;-) mplayer-1.0_pre6-r4.ebuild
>>> md5 files   ;-) mplayer-1.0_pre6-r5.ebuild
>>> md5 files   ;-) mplayer-1.0_pre6-r6.ebuild
>>> md5 files   ;-) files/mplayer-avi_crash.patch
>>> md5 files   ;-) files/mplayer-nl.patch
>>> md5 files   ;-) files/mplayer-0.90-coreutils-fixup.patch
>>> md5 files   ;-) files/digest-mplayer-1.0_pre7
>>> md5 files   ;-) files/mplayer-1.0_pre5-configure.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-mips64.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-bio2jack.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-r4-ppc64.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-yuv2rgb_fix.patch
>>> md5 files   ;-) files/mplayer-1.0-gtk2.patch
>>> md5 files   ;-) files/digest-mplayer-1.0_pre5-r5
>>> md5 files   ;-) files/mplayer.desktop
>>> md5 files   ;-) files/mplayer-1.0_pre5-r5-configure.patch
>>> md5 files   ;-) files/vuln02-fix.diff
>>> md5 files   ;-) files/mmst_fix_20050415.diff
>>> md5 files   ;-) files/mplayer-1.0_pre6-configure.patch
>>> md5 files   ;-) files/mplayer-1.0_pre6-ppc64.patch
>>> md5 files   ;-) files/mplayer-gcc_detection.patch
>>> md5 files   ;-) files/mplayer-gif.patch
>>> md5 files   ;-) files/mplayer-x11.patch
>>> md5 files   ;-) files/cachefill.patch
>>> md5 files   ;-) files/mplayer-jack.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-gcc_detection.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-alsa-gcc34.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-help_mp-ro.h.patch
>>> md5 files   ;-) files/rtsp_fix_20050415.diff
>>> md5 files   ;-) files/mplayer-1.0_pre5-mga-kernel-2.6.patch
>>> md5 files   ;-) files/mplayer-1.0_pre6-codecs.patch
>>> md5 files   ;-) files/mplayer-1.0_pre6-pic.patch
>>> md5 files   ;-) files/gui_vuln_code.patch
>>> md5 files   ;-) files/str_undefined.patch
>>> md5 files   ;-) files/real_demux.patch
>>> md5 files   ;-) files/mplayer-1.0_pre5-r1-conf_locale.patch
>>> md5 files   ;-) files/mplayer-mythtv.patch
>>> md5 files   ;-) files/mplayer-odml.patch
>>> md5 files   ;-) files/strl.c
>>> md5 files   ;-) files/digest-mplayer-1.0_pre6-r4
>>> md5 files   ;-) files/mplayer-1.0_pre5-live.patch
>>> md5 files   ;-) files/digest-mplayer-1.0_pre6-r5
>>> md5 files   ;-) files/digest-mplayer-1.0_pre6-r6
>>> md5 src_uri ;-) MPlayer-1.0pre6a.tar.bz2
>>> md5 src_uri ;-) font-arial-iso-8859-1.tar.bz2
>>> md5 src_uri ;-) font-arial-iso-8859-2.tar.bz2
>>> md5 src_uri ;-) font-arial-cp1250.tar.bz2
>>> md5 src_uri ;-) Blue-1.4.tar.bz2
>>> Unpacking source...
>>> Unpacking MPlayer-1.0pre6a.tar.bz2 to /var/tmp/portage/mplayer-1.0_pre6-r4/work
>>> Unpacking font-arial-iso-8859-1.tar.bz2 to /var/tmp/portage/mplayer-1.0_pre6-r4/work
>>> Unpacking font-arial-iso-8859-2.tar.bz2 to /var/tmp/portage/mplayer-1.0_pre6-r4/work
>>> Unpacking font-arial-cp1250.tar.bz2 to /var/tmp/portage/mplayer-1.0_pre6-r4/work
>>> Unpacking Blue-1.4.tar.bz2 to /var/tmp/portage/mplayer-1.0_pre6-r4/work
 * Applying mplayer-1.0_pre6-configure.patch ...                                                                                                                                               [ ok ] * Applying mplayer-1.0_pre6-ppc64.patch ...                                                                                                                                                   [ ok ] * Applying mplayer-nl.patch ...                                                                                                                                                               [ ok ] * Applying mplayer-avi_crash.patch ...                                                                                                                                                        [ ok ] * Applying mplayer-gcc_detection.patch ...                                                                                                                                                    [ ok ] * Applying mplayer-jack.patch ...                                                                                                                                                             [ ok ] * Applying mplayer-1.0_pre6-codecs.patch ...                                                                                                                                                  [ ok ] * Applying rtsp_fix_20050415.diff ...                                                                                                                                                         [ ok ] * Applying mmst_fix_20050415.diff ...                                                                                                                                                         [ ok ]>>> Source unpacked.
 * No LINGUAS given, defaulting to English
Detected operating system: Linux
Detected host architecture: i386
Checking for cc version ... v. ?.??, bad
Checking for gcc version ... v. ?.??, bad
Checking for gcc-3.4 version ... ./configure: line 1: gcc-3.4: command not found, bad
Checking for gcc-3.3 version ... ./configure: line 1: gcc-3.3: command not found, bad
Checking for gcc-3.2 version ... ./configure: line 1: gcc-3.2: command not found, bad
Checking for gcc-3.1 version ... ./configure: line 1: gcc-3.1: command not found, bad
Checking for gcc3 version ... ./configure: line 1: gcc3: command not found, bad
Checking for gcc-3.0 version ... ./configure: line 1: gcc-3.0: command not found, bad
Checking for cc version ... v. ?.??, bad

*** Please downgrade/upgrade C compiler to version gcc-2.95.x or gcc-3.x! ***

You are not using a supported compiler. We do not have the time to make sure
everything works with compilers other than the ones we use.  Use either the
same compiler as we do, or use --disable-gcc-checking but DO *NOT* REPORT BUGS
unless you can reproduce them after recompiling with a 2.95.x or 3.x version!

Note for gcc 2.96 users: Some versions of this compiler are known to miscompile
mplayer and lame (which is used for mencoder).  If you get compile errors,
first upgrade to the latest 2.96 release (minimum 2.96-85) and try again.
If the problem still exists, try with gcc 3.x (or 2.95.x) *BEFORE* reporting
bugs!

        GCC 2.96 IS NOT AND WILL NOT BE SUPPORTED BY US !

    *** For details please read DOCS/HTML/en/users-vs-dev.html ***


Error: Bad gcc version

Check "configure.log" if you do not understand why it failed.

!!! ERROR: media-video/mplayer-1.0_pre6-r4 failed.
!!! Function src_compile, Line 502, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

#


# gcc --version
gcc (GCC) 3.3.5-20050130 (Gentoo Linux 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1)
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

#


# emerge --info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r6 i686)
=================================================================
System uname: 2.6.11-gentoo-r6 i686 Mobile Intel(R) Pentium(R) 4     CPU 3.06GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  7 2005, 08:00:13)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.9.4, 1.7.9-r1, 1.6.3, 1.4_p6, 1.8.5-r3
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r2, 2.6.8.1-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-Os -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://128.213.5.34/gentoo/ http://mirror.datapipe.net/gentoo http://mirror.datapipe.net/gentoo http://gentoo.mirrored.ca/"
LANG="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 S3TC X a52 aac acpi alsa apache2 avi bash-completion berkdb bitmap-fonts bonobo bzip2 caps cdinstall cdparanoia cdr cjk crypt cscope cups curl divx4linux dts dvd dvdr ecc eds emboss encode esd evo extras f77 faad fam fame ffmpeg fftw flac foomaticdb fortran freetype gcj gdbm geoip gif gimpprint glut gnome gnutls gphoto2 gstreamer gtk gtk2 gtkhtml guile hal howl imagemagick imlib ipv6 ithreads java jce jikes jpeg junit lcms ldap libg++ libwww live lzo mad mailwrapper matroska mikmod mjpeg mmx mmx2 mng motif mozdevelop mozilla moznomail mozsvg mp3 mpeg mysql ncurses netcdf network nls nntp noplugin nptl nvidia oav objc offensive ogg oggvorbis opengl pam pcmcia pda pdflib perl png pnp ppds python quicktime quotes readline real rogue rtc ruby samba sdl slang sndfile softmmu speex spell sse sse2 ssl svg symlink tcltk tcpd tetex theora threads tiff truetype truetype-fonts trusted type1-fonts unicode userlocales utf8 videos vim-with-x vorbis wmf wxwindows xanim xml xml2 xmms xprint xscreensaver xv xvid xvmc zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS, LINGUAS

#
Comment 1 Jan Brinkmann (RETIRED) gentoo-dev 2005-05-05 18:23:12 UTC
*** Bug 91626 has been marked as a duplicate of this bug. ***
Comment 2 Luca Barbato gentoo-dev 2005-05-09 08:44:26 UTC
Should be fixed
Comment 3 Joel Parker 2005-05-10 19:29:02 UTC
I just tried 1.0_pre6-r4 again, and this time it worked. Weird.
Comment 4 Luca Barbato gentoo-dev 2005-05-11 04:44:28 UTC
Closing then