Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 894034

Summary: dev-python/resolvelib-0.9.0 fails tests: FAILED test_resolvers_cocoapods.py::test_resolver with new dev-python/packaging
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Matthew Thode ( prometheanfire ) <prometheanfire>
Status: IN_PROGRESS ---    
Severity: normal CC: mgorny, python
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://github.com/sarugaku/resolvelib/issues/121
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2023-02-12 12:19:36 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-python/resolvelib-0.9.0 fails tests (HARDENED-SYSTEM).
Discovered on: amd64 (internal ref: hardened_tinderbox)

NOTE:
(HARDENED-SYSTEM) in the summary means that the bug was found on a machine that runs an hardened profile with -D_FORTIFY_SOURCE=3 and -D_GLIBCXX_ASSERTIONS (https://www.gentoo.org/support/news-items/2023-01-01-hardening-fortify-assertions.html) but this bug MAY or MAY NOT BE related to the changes related to hardened.
Comment 1 Agostino Sarubbo gentoo-dev 2023-02-12 12:19:39 UTC
Created attachment 850436 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2023-02-12 12:19:40 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:


FAILED tests/functional/cocoapods/test_resolvers_cocoapods.py::test_resolver[conflict_common_parent]
FAILED tests/functional/cocoapods/test_resolvers_cocoapods.py::test_resolver[deep_complex_conflict]
FAILED tests/functional/cocoapods/test_resolvers_cocoapods.py::test_resolver[pruned_unresolved_orphan]
FAILED tests/functional/cocoapods/test_resolvers_cocoapods.py::test_resolver[shared_parent_dependency]
FAILED tests/functional/cocoapods/test_resolvers_cocoapods.py::test_resolver[shared_parent_dependency_with_swapping]
FAILED tests/functional/cocoapods/test_resolvers_cocoapods.py::test_resolver[spapping_and_rewinding]
Comment 3 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-02-19 21:24:16 UTC
self = <[AttributeError("'Version' object has no attribute '_version'") raised in repr()] Version object at 0x55b12e8e2838>
version = '5.0.0-beta1.1'

    def __init__(self, version: str) -> None:
        """Initialize a Version object.
    
        :param version:
            The string representation of a version which will be parsed and normalized
            before use.
        :raises InvalidVersion:
            If the ``version`` does not conform to PEP 440 in any way then this
            exception will be raised.
        """
    
        # Validate the version and parse it into pieces
        match = self._regex.search(version)
        if not match:
>           raise InvalidVersion(f"Invalid version: '{version}'")
E           packaging.version.InvalidVersion: Invalid version: '5.0.0-beta1.1'

match      = None
self       = <[AttributeError("'Version' object has no attribute '_version'") raised in repr()] Version object at 0x55b12e8e2838>
version    = '5.0.0-beta1.1'
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2023-02-24 17:34:24 UTC
The main branch's fixed but the fix is large-ish, so I've asked upstream for a new release.
Comment 5 Larry the Git Cow gentoo-dev 2023-02-24 17:42:06 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a791bb3f7bb685495fdc2cae9d1cbba6124c32c1

commit a791bb3f7bb685495fdc2cae9d1cbba6124c32c1
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2023-02-24 17:41:33 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2023-02-24 17:42:03 +0000

    dev-python/resolvelib: Require packaging < 22
    
    Bug: https://bugs.gentoo.org/894034
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 dev-python/resolvelib/resolvelib-0.8.1.ebuild | 2 +-
 dev-python/resolvelib/resolvelib-0.9.0.ebuild | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2023-02-24 17:42:37 UTC
This is actually a dev-python/packaging problem, and we no longer force the new packaging version in setuptools.