Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 84668

Summary: Enigmail not completely available in mozilla-thunderbird-1.0
Product: Gentoo Linux Reporter: Martin von Gagern <Martin.vGagern>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Severity: normal CC: alin, azoff, ekutay, gentoo, meh6666, sven.koehler
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: .tar.bz2 of my .thunderbird dir (1.8MB)

Description Martin von Gagern 2005-03-09 14:28:27 UTC
I switched from mozilla (seamonkey) to mozilla-thunderbird. I have USE=crypt and want to use enigmail.
In Thunderbird, I have the enigmail setting in the account manager, can configure the gpg binary and successfully run a test in the adcanced dialog.
But I have no Enigmail menu, no decrypt button, no information about signatures, and no OpenPGP button when composing.

This looks like bug 56814, I also get some warning about old extensions being disabled when I start thunderbird for the first time.

It also looks somewhat like bug 75779, but I tried to rename my local or the global compreg.dat, neither helped.

Reproducible: Always
Steps to Reproduce:
1. USE=crypt emerge thunderbird
2. thunderbird
3. import seamonkey settings or don't, doesn't matter

Actual Results:  
1. Warning about old extensions being disabled
2. no Enigmail UI components except in account manager

Expected Results:  
All Enigmail UI components available

Manually installing the binary enigmail distribution from the homepage works,
but seems somewhat unclean to me.

Portage (default-linux/x86/2004.3, gcc-3.3.5, glibc-,
2.6.10-gentoo-r5 i686)
System uname: 2.6.10-gentoo-r5 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.00GHz
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  7 2005, 12:05:53)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.5, 1.8.5-r3, 1.7.9-r1, 1.6.3, 1.4_p6, 1.9.4
sys-devel/libtool:   1.5.10-r4
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe -msse2 -mfpmath=sse"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe -msse2 -mfpmath=sse"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="x86 X acpi alsa apm arts avi berkdb bitmap-fonts cdr crypt cups curl
divx4linux dvd dvdr emboss encode esd f77 fam flac font-server foomaticdb
fortran gd gdbm gif gphoto2 gpm gtk gtk2 imagemagick imap imlib innodb ipv6 java
jpeg junit kde libg++ libwww lirc mad maildir mailwrapper mikmod mmx motif
mozilla mpeg mule mysql ncurses nls nptl oggvorbis opengl oss pam pcmcia pdflib
perl pic png pnp python qt quicktime readline samba sasl sdl slang speex spell
sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts trusted type1-fonts
unicode usb wavelan xml xml2 xmms xv zlib"
Comment 1 Torbjörn Svensson 2005-03-26 06:51:32 UTC
I got this bug too.

I don't know if this helps, but I hope so..

$ rm .thunderbird/u742bx9m.default/compreg.dat
$ thunderbird 
No running windows found
Registering Enigmail account manager extension.
Enigmail account manager extension registered.

As you can see it do recognize the enigmail extension, but it's not displayed propperly (as the default bugreport claim).
Comment 2 Erol Kutay 2005-04-19 08:58:13 UTC
I can also confirm this misbehaviour.
Funny that I have enigmail still up and running on my workstation using the same version of thunderbird and enigmail.
On my laptop I've done a clean install and enigmail does not show up. In the menu and does not recognize any encrypted messages. Additionally if I install the xpi thunderbird is not able to open _any_ attachements no more. This is solved when uninstalling the extension.
Please advice.
Comment 3 Erol Kutay 2005-04-22 07:31:11 UTC
I know, that there are too many people not using pgp, but still there are some. For now I emerged mozilla, but that's only a workaround and I'm not happy about this.

As far as I can see this is not a singular phenomena. A colleague of mine had it too, Torbj
Comment 4 Erol Kutay 2005-04-22 07:31:11 UTC
I know, that there are too many people not using pgp, but still there are some. For now I emerged mozilla, but that's only a workaround and I'm not happy about this.

As far as I can see this is not a singular phenomena. A colleague of mine had it too, Torbjörn has confirmed, me, initially Martin .... Thus is there any activity regarding this issue?

If you need any additional information, you will get it immediately.

Comment 5 Erol Kutay 2005-04-23 02:38:37 UTC
After a while digging, I was able to run enigmail again. 
The magic was to install enigmail manually, which breaks some other functionality as I have mentioned. Then uninstall enigmail extension, restart thunderbird. Stop thunderbird and start it again. 
After this thunderbird has the enigmail menu and functionality again.

I assume, that the installation is not correct in this build, if you do not upgrade.
Comment 6 Sven 2005-05-09 17:20:38 UTC
same problems here with mozilla-thunderbird-1.0.2
Comment 7 Kevin 2005-05-11 11:27:30 UTC
Me too with mozilla-thunderbird-1.0.2
Comment 8 Erol Kutay 2005-05-11 22:20:10 UTC
Though no developer seems to react to this problem since weeks - narf -, I'd advise you all to follow my procedures to enable enigmail as this:

Install the enigmail extension manually, start up thunderbird again, shutdown thunderbird, start it up again, uninstall the manually installed enigmail extension, shut down thunderbird again, then start it up again.

If you are lucky, you will have the compiled in extension again initiated by the manual installed extension.
Comment 9 Peter Fein 2005-05-19 21:38:32 UTC
So I tried Erol's instructions, no dice.  But manually installing the extension
seems to work ok - no problems with attachments or otherwise, though I haven't
tested extensively.

You can download the xpi from:

which will work even if you're using an old version of firefox. (rant suppressed) 

It'd be nice to see some activity from the maintainers on this one...
Comment 10 Alin Dobre (RETIRED) gentoo-dev 2005-06-23 04:15:53 UTC
i got this issue with both 1.0.2 and 1.0.2-r1 versions. each time i tried to
install it i have deleted the /usr/lib/MozillaThunderbird/ directory, before.
Even though the two ebuilds use different versions of enigmail, none of them
cannot use the build-in extension.
Funny thing: on another comuter, i have installed both versions (now it's
1.0.2-r1) and build-in enigmail works just fine. also, on both computers i have
mozilla seamonkey (KEYWORDS="x86") installaled with enigmail build-in, which
works just fine, as well. i also tried to disable ccache for building it, i have
the crypt flag set.... i'm out of ideas
Comment 11 Martin von Gagern 2005-06-23 05:22:28 UTC
Created attachment 61776 [details]
.tar.bz2 of my .thunderbird dir (1.8MB)

I just created copies of a .thunderbird directory after all the steps mentioned
in comment 7.

1. start TB for the first time, quit => 1-just-created
2. start, install xpi,		quit => 2-installed-localy
3. start, uninstall extension,	quit => 3-uninstalled
4. start, see no enigmail menu, quit => 4-started-once-more
5. start, enigmail works now,	quit => 5-finally-works

There are a lot of changes between all those files, but perhaps someone has a
good idea where to look.
Comment 12 Jory A. Pratt 2005-07-19 09:41:57 UTC
enigmail has been removed from thunderbird 1.0.5 it is being moved to its own
ebuild. sorry for the inconvience this caused you.
Comment 13 Jory A. Pratt 2005-07-19 09:45:47 UTC
thought I closed sorry
Comment 14 Martin von Gagern 2005-07-19 20:29:02 UTC
I can't see this enigmail ebuild available yet. As the new release 1.0.6 of
Thunderbird should make enigmail work again, it would be nice to keep this in
the thunderbird ebuilds until a new ebuild for enigmail is available.
See also bug #99182
Comment 15 Erol Kutay 2005-07-21 08:26:38 UTC
And again, I have no enigmail functionalities in thunderbird no more after the
last update. Brilliant that the update came _before_ the notification of
dropping enigmail, more precisely I have updated on the 15th. The comment was commited on the 19th. I
will downgrade.
Comment 16 Sven 2005-07-21 08:53:59 UTC
Sorry, but it isn't a shame that the thunderbird-ebuild doesn't install enigmail
anymore, since those are marked ~x86! If you use bleading-edge stuff, you'll
have to live with the side-effects and don't complain about it!
Comment 17 Sven 2005-07-21 08:55:16 UTC
Ohh sorry, i'm wrong! enigmail has been removed from the x86-version of the
ebuild! Shame on the maintainer!
Comment 18 Erol Kutay 2005-07-21 09:52:24 UTC
(In reply to comment #16)
> Ohh sorry, i'm wrong! enigmail has been removed from the x86-version of the
> ebuild! Shame on the maintainer!

Never ever shame on a maintainer, but complaints and critical words must be
allowed. ;)

Anyway, as using ~x86 I'm not to be ignored as a user, because I'm using this
not (only) to be bleeding edge, but to support the ongoing development with bug
reports, help in the forum and so on and so forth.

And btm. ~x86 is not bleeding edge, it is just not tested sufficiently to be put
in the stable branch. From a developers view I would take that as feature complete.