Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 846392 (CVE-2021-42700, CVE-2021-42702, CVE-2021-42704)

Summary: media-gfx/inkscape: multiple vulnerabilities
Product: Gentoo Security Reporter: John Helmert III <ajak>
Component: VulnerabilitiesAssignee: Gentoo Security <security>
Status: CONFIRMED ---    
Severity: minor CC: dilfridge, zlogene
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://www.cisa.gov/uscert/ics/advisories/icsa-22-132-03
Whiteboard: B3 [??]
Package list:
Runtime testing required: ---

Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-05-19 05:51:48 UTC
CVE-2021-42700:

Inkscape 0.19 is vulnerable to an out-of-bounds read, which may allow an attacker to have access to unauthorized information.

CVE-2021-42702:

Inkscape version 0.19 can access an uninitialized pointer, which may allow an attacker to have access to unauthorized information.

CVE-2021-42704:

Inkscape version 0.19 is vulnerable to an out-of-bounds write, which may allow an attacker to arbitrary execute code.

URL is the only reference for these CVEs, no references to upstream to
verify where these issues were fixed. Unsure whether we're fixed.