Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 843242

Summary: sci-mathematics/octave-6.4.0-r3 installs libtool files (.la) without corresponding static libraries
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Gentoo Science Mathematics related packages <sci-mathematics>
Status: RESOLVED FIXED    
Severity: normal CC: mjo
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log.xz

Description Agostino Sarubbo gentoo-dev 2022-05-08 06:03:16 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sci-mathematics/octave-6.4.0-r2 installs libtool files (.la) without corresponding static libraries.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2022-05-08 06:03:18 UTC
Created attachment 777356 [details]
build.log.xz

build log and emerge --info (compressed because it exceeds attachment limit, use 'xzless' to read it)
Comment 2 Agostino Sarubbo gentoo-dev 2022-05-26 06:50:46 UTC
ci has reproduced this issue with version 6.4.0-r3 - Updating summary.
Comment 3 Michael Orlitzky gentoo-dev 2022-05-26 19:21:52 UTC
I already fixed it in octave-7.x if there's some way to ignore it for older packages.
Comment 4 Michael Orlitzky gentoo-dev 2022-08-06 23:16:41 UTC
Maybe this will stay fixed now that octave-7.x has KEYWORDS?