Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 843212

Summary: =dev-libs/boost-1.79.0 on ia64, s390: error at libs/log/build/Jamfile.v2:59 Unable to find file or target named '/boost/architecture//mips'
Product: Gentoo Linux Reporter: matoro <matoro_bugzilla_gentoo>
Component: Current packagesAssignee: David Seifert <soap>
Status: RESOLVED FIXED    
Severity: normal CC: chewi, loong, matoro_bugzilla_gentoo, s390, sam, Xeha
Priority: Normal Keywords: PullRequest
Version: unspecified   
Hardware: IA64   
OS: Linux   
See Also: https://github.com/boostorg/boost/pull/540
https://github.com/boostorg/log/pull/155
https://github.com/gentoo/gentoo/pull/26206
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 853676    
Attachments: build.log

Description matoro archtester 2022-05-07 22:52:01 UTC
New boost-log seems to be misidentifying ia64 as mips for some reason.  =dev-libs/boost-1.78.0-r2 is unaffected.

Reproducible: Always




Portage 3.0.30 (python 3.10.4-final-0, default/linux/ia64/17.0, gcc-11.3.0, glibc-2.35-r4, 5.17.5-gentoo-ia64 ia64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.17.5-gentoo-ia64-ia64-Intel-R-_Itanium-R-_Processor_9340-with-glibc2.35
KiB Mem:    16505648 total,   9581776 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 07 May 2022 21:18:08 +0000
Head commit of repository gentoo: 7675030d6b531d61be0d10d3747fa3ce5196126e

sh bash 5.1_p16
ld GNU ld (Gentoo 2.38 p4) 2.38
app-misc/pax-utils:        1.3.4::gentoo
app-shells/bash:           5.1_p16::gentoo
dev-lang/perl:             5.34.1-r3::gentoo
dev-lang/python:           3.10.4::gentoo
dev-util/cmake:            3.23.1::gentoo
dev-util/meson:            0.61.4-r2::gentoo
sys-apps/baselayout:       2.8::gentoo
sys-apps/openrc:           0.44.10::gentoo
sys-apps/sandbox:          2.29::gentoo
sys-devel/autoconf:        2.71-r1::gentoo
sys-devel/automake:        1.16.5::gentoo
sys-devel/binutils:        2.38-r2::gentoo
sys-devel/binutils-config: 5.4.1::gentoo
sys-devel/gcc:             11.3.0::gentoo
sys-devel/gcc-config:      2.5-r1::gentoo
sys-devel/libtool:         2.4.7::gentoo
sys-devel/make:            4.3::gentoo
sys-kernel/linux-headers:  5.17-r1::gentoo (virtual/os-headers)
sys-libs/glibc:            2.35-r4::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    sync-user: portage:portage
    priority: -1000
    sync-git-verify-commit-signature: yes

ACCEPT_KEYWORDS="ia64 ~ia64"
ACCEPT_LICENSE="@FREE"
CBUILD="ia64-unknown-linux-gnu"
CFLAGS="-O3 -pipe -mtune=itanium2"
CHOST="ia64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -pipe -mtune=itanium2"
DISTDIR="/var/cache/distfiles"
EMERGE_DEFAULT_OPTS="--usepkg --autounmask=n --complete-graph --keep-going --with-bdeps=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg buildpkg-live compress-build-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://gentoo.osuosl.org/ https://mirror.leaseweb.com/gentoo/ https://mirror.rackspace.com/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j16"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/bin/bash"
USE="acl bash-completion bzip2 caps cli crypt dri elogind fortran gdbm gentoo-vm graphite headless-awt ia64 iconv ipv6 libbsd libglvnd libtirpc lto ncurses nls nptl openmp pam pcre pgo readline split-usr ssl symlink threads udev unicode verify-sig vhosts vim-syntax xattr zlib" ADA_TARGET="gnat_2020" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="void libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-4 php8-0" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_10" PYTHON_TARGETS="python3_10" RUBY_TARGETS="ruby26 ruby27" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, INSTALL_MASK, LC_ALL, LD, LEX, LFLAGS, LIBTOOL, LINGUAS, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS

=================================================================
                        Package Settings
=================================================================

dev-libs/boost-1.78.0-r2::gentoo was built with the following:
USE="bzip2 nls zlib (-context) -debug -doc -icu -lzma (-mpi) -numpy -python -tools -zstd" PYTHON_TARGETS="python3_10 -python3_8 -python3_9"
CXXFLAGS="-O3 -pipe -mtune=itanium2 -std=c++14"
Comment 1 matoro archtester 2022-05-07 22:52:52 UTC
Created attachment 777332 [details]
build.log
Comment 2 WANG Xuerui gentoo-dev 2022-05-13 14:23:48 UTC
Same for loong, may have to dig deeper. boost-1.78.0 works, the keyword was simply forwarded to 1.79.0.
Comment 3 WANG Xuerui gentoo-dev 2022-05-13 14:30:25 UTC
Found the culprit:

https://github.com/boostorg/log/pull/155 was merged before https://github.com/boostorg/boost/pull/540, creating the inconsistency that eventually failed the build.
Comment 4 WANG Xuerui gentoo-dev 2022-05-13 15:15:10 UTC
Simply applying the changes in https://github.com/boostorg/boost/pull/540 isn't enough to fix the build, but breaks amd64 as well (!). For now I've pmasked >=dev-libs/boost-1.79.0 on loong, waiting for upstream to solve this.
Comment 5 matoro archtester 2022-05-16 18:39:54 UTC
(In reply to WANG Xuerui from comment #4)
> Simply applying the changes in https://github.com/boostorg/boost/pull/540
> isn't enough to fix the build, but breaks amd64 as well (!). For now I've
> pmasked >=dev-libs/boost-1.79.0 on loong, waiting for upstream to solve this.

I just looked at this commit to replicate it for ia64, should we be masking the specific version instead?
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2022-05-20 20:15:50 UTC
The same error also occurs on s390 (ie. lgentoo3)
Comment 7 Larry the Git Cow gentoo-dev 2022-05-20 20:18:55 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3faf8eec06c271b005762884c0cba44f7a027563

commit 3faf8eec06c271b005762884c0cba44f7a027563
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2022-05-20 20:18:27 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2022-05-20 20:18:43 +0000

    dev-libs/boost: drop ia64 and s390 keywords temporarily, bug 843212
    
    Bug: https://bugs.gentoo.org/843212
    Package-Manager: Portage-3.0.30, Repoman-3.0.3
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 dev-libs/boost/boost-1.79.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 Xeha 2022-06-13 14:26:33 UTC
same on m68k
Comment 9 Larry the Git Cow gentoo-dev 2022-07-03 08:33:58 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a4c4d058df485555cddea1da537bb04847a088a7

commit a4c4d058df485555cddea1da537bb04847a088a7
Author:     WANG Xuerui <xen0n@gentoo.org>
AuthorDate: 2022-07-03 08:29:11 +0000
Commit:     WANG Xuerui <xen0n@gentoo.org>
CommitDate: 2022-07-03 08:31:31 +0000

    Revert "dev-libs/boost: drop ia64 and s390 keywords temporarily, bug 843212"
    
    This reverts commit 3faf8eec06c271b005762884c0cba44f7a027563.
    
    ~loong and ~m68k builds are fixed, so should the others. Given the
    original drop was due to this bug, just restore keywords for one less
    rekeywording bug.
    
    Closes: https://bugs.gentoo.org/843212
    Signed-off-by: WANG Xuerui <xen0n@gentoo.org>

 dev-libs/boost/boost-1.79.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dec7403c5d0a504a45f1d299c33893b064b1782b

commit dec7403c5d0a504a45f1d299c33893b064b1782b
Author:     WANG Xuerui <xen0n@gentoo.org>
AuthorDate: 2022-07-03 03:36:34 +0000
Commit:     WANG Xuerui <xen0n@gentoo.org>
CommitDate: 2022-07-03 08:31:31 +0000

    profiles/arch/loong: remove the boost-1.79.0 mask
    
    Bug: https://bugs.gentoo.org/843212
    Signed-off-by: WANG Xuerui <xen0n@gentoo.org>

 profiles/arch/loong/package.mask | 4 ----
 1 file changed, 4 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1a9b0d1fe535f498e607f7f8f860656237af347e

commit 1a9b0d1fe535f498e607f7f8f860656237af347e
Author:     WANG Xuerui <xen0n@gentoo.org>
AuthorDate: 2022-07-03 03:25:27 +0000
Commit:     WANG Xuerui <xen0n@gentoo.org>
CommitDate: 2022-07-03 08:31:31 +0000

    dev-libs/boost: fix build for 1.79.0
    
    Fix upstream issue causing configure errors on multiple arches. Changes
    are hand-picked into the dist sources tree. One file rename is reverted
    to make scrubbed patch work with patch(1).
    
    Bug: https://bugs.gentoo.org/843212
    Signed-off-by: WANG Xuerui <xen0n@gentoo.org>

 dev-libs/boost/boost-1.79.0.ebuild                 |  1 +
 .../files/boost-1.79.0-fix-mips1-transition.patch  | 39 ++++++++++++++++++++++
 2 files changed, 40 insertions(+)