Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 835367

Summary: app-containers/containerd-1.5.9: inconsistent vendoring when building with go-1.18
Product: Gentoo Linux Reporter: Holger Hoffstätte <holger>
Component: Current packagesAssignee: William Hubbs <williamh>
Status: RESOLVED FIXED    
Severity: normal CC: christian, flaviocamilo, gyakovlev, leonchik1976, mirek, nexion.hellborn, pefoley2, realnc, sam, toralf, voyageur
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://github.com/containerd/containerd/issues/6586
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 835378    

Description Holger Hoffstätte 2022-03-15 19:12:07 UTC
After updating to go-1.18.0 and rebuilding all go-based packages I was greeted by:

$cat /tmp/portage/app-containers/containerd-1.5.9/temp/build.log
 * Package:    app-containers/containerd-1.5.9
 * Repository: gentoo
 * Maintainer: williamh@gentoo.org gyakovlev@gentoo.org
 * USE:        abi_x86_64 amd64 btrfs cri elibc_glibc kernel_linux seccomp userland_GNU
 * FEATURES:   network-sandbox preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking containerd-1.5.9.tar.gz to /tmp/portage/app-containers/containerd-1.5.9/work
>>> Source unpacked in /tmp/portage/app-containers/containerd-1.5.9/work
>>> Preparing source in /tmp/portage/app-containers/containerd-1.5.9/work/containerd-1.5.9 ...
>>> Source prepared.
>>> Configuring source in /tmp/portage/app-containers/containerd-1.5.9/work/containerd-1.5.9 ...
>>> Source configured.
>>> Compiling source in /tmp/portage/app-containers/containerd-1.5.9/work/containerd-1.5.9 ...
make -j8 -l8 'BUILDTAGS=no_devmapper seccomp' LDFLAGS= REVISION=1407cab509ff0d96baa4f0eb6ff9980270e6e620 VERSION=v1.5.9 man -j1 
+ man/ctr.8
go run cmd/gen-manpages/main.go ctr.8 man
WORK=/tmp/portage/app-containers/containerd-1.5.9/temp/go-build4201699265
go: inconsistent vendoring in /tmp/portage/app-containers/containerd-1.5.9/work/containerd-1.5.9:
	github.com/containerd/containerd: is marked as replaced in vendor/modules.txt, but not replaced in go.mod

	To ignore the vendor directory, use -mod=readonly or -mod=mod.
	To sync the vendor directory, run:
		go mod vendor
make: *** [Makefile:245: man/ctr.8] Error 1
 * ERROR: app-containers/containerd-1.5.9::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-containers/containerd-1.5.9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-containers/containerd-1.5.9::gentoo'`.
 * The complete build log is located at '/tmp/portage/app-containers/containerd-1.5.9/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/app-containers/containerd-1.5.9/temp/environment'.
 * Working directory: '/tmp/portage/app-containers/containerd-1.5.9/work/containerd-1.5.9'
 * S: '/tmp/portage/app-containers/containerd-1.5.9/work/containerd-1.5.9'

Apparently go-1.18 is more strict, the rebuild succeeds with 1.17.8.


Reproducible: Always

Steps to Reproduce:
1. update to go-1.18
2. try to emerge containerd-1.5.9
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-03-17 17:39:42 UTC
*** Bug 835512 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2022-03-25 19:24:32 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c9020e90c4c56acada3022341bb372805759562f

commit c9020e90c4c56acada3022341bb372805759562f
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-03-25 19:24:14 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-03-25 19:24:14 +0000

    app-containers/containerd: BDEPEND on <go-1.18
    
    Bug: https://bugs.gentoo.org/835367
    Signed-off-by: Sam James <sam@gentoo.org>

 app-containers/containerd/containerd-1.4.11.ebuild | 4 +++-
 app-containers/containerd/containerd-1.4.12.ebuild | 2 ++
 app-containers/containerd/containerd-1.5.9.ebuild  | 2 ++
 3 files changed, 7 insertions(+), 1 deletion(-)
Comment 3 Larry the Git Cow gentoo-dev 2022-03-28 05:35:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b0c789e55fe279952eff475ff60cc1574ea5f917

commit b0c789e55fe279952eff475ff60cc1574ea5f917
Author:     William Hubbs <williamh@gentoo.org>
AuthorDate: 2022-03-28 05:34:56 +0000
Commit:     William Hubbs <williamh@gentoo.org>
CommitDate: 2022-03-28 05:34:56 +0000

    app-containers/containerd: add 1.5.11
    
    Closes: https://bugs.gentoo.org/835367
    Bug: https://bugs.gentoo.org/835917
    Signed-off-by: William Hubbs <williamh@gentoo.org>

 app-containers/containerd/Manifest                 |  1 +
 app-containers/containerd/containerd-1.5.11.ebuild | 84 ++++++++++++++++++++++
 2 files changed, 85 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=08561219d3263a52bc263a73334003cd8f06eabe

commit 08561219d3263a52bc263a73334003cd8f06eabe
Author:     William Hubbs <williamh@gentoo.org>
AuthorDate: 2022-03-28 05:34:56 +0000
Commit:     William Hubbs <williamh@gentoo.org>
CommitDate: 2022-03-28 05:34:56 +0000

    app-containers/containerd: revert BDEPEND on <go-1.18
    
    This reverts commit c9020e90c4c56acada3022341bb372805759562f.
    This forced downgrades on users.
    The fix should have been to bump containerd.
    
    Bug: https://bugs.gentoo.org/835367
    Signed-off-by: William Hubbs <williamh@gentoo.org>

 app-containers/containerd/containerd-1.4.11.ebuild | 4 +---
 app-containers/containerd/containerd-1.4.12.ebuild | 2 --
 app-containers/containerd/containerd-1.5.9.ebuild  | 2 --
 3 files changed, 1 insertion(+), 7 deletions(-)