Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 83216

Summary: emerge kadu fails
Product: Gentoo Linux Reporter: Michal <michalp>
Component: [OLD] UnspecifiedAssignee: Gentoo net-im Herd <net-im>
Status: RESOLVED NEEDINFO    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Michal 2005-02-24 11:22:56 UTC
One od kadu modules depends on media-libs/libsndfile,whiich is not included in the ebuild

Reproducible: Always
Steps to Reproduce:
emerge kadu
Actual Results:  
>>> Configuring arts_sound module...
MODULE_LIBS:           soundserver_idl
MODULE_LIBS_PATH:      /lib /usr/kde/3.1/lib /usr/kde/3.2/lib /opt/kde/lib /opt/
kde3/lib
MODULE_INCLUDES:       soundserver.h
MODULE_INCLUDES_PATH:  /include/arts /usr/include/arts /usr/kde/3.1/include/arts
 /usr/kde/3.2/include/arts /usr/include/kde/arts /opt/kde/include/arts /opt/kde3
/include/arts
MODULE_TOOLS:
MODULE_CONFIGURE_CMD:
checking if libsoundserver_idl.so/dylib library is in system directories... no
checking for libsoundserver_idl.so in specified directiories... not found
checking for libsoundserver_idl.dylib in specified directiories... not found
configure: error: libsoundserver_idl.dylib not found!

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/kadu-0.3.9/work/kadu/config.log



I'm using ACCEPT_KEYWORDS="~x86" ,but I guess it doesn't matters ...
It depends on media-libs/libsndfile
emerge  libsndfile helps. 
Please include it in the ebuild.

Thanks - Michael
Comment 1 Michal 2005-02-24 15:45:41 UTC
My mistake - emerge  libsndfile does not fix the problem.
I've assumed so because in my previous build a cvs snapshot wasn't building until I emerged libsndfile.
I must add that I use Gnome , I've a fresh sync ant my hentoo is a fresh build. If You want to I can support You with the  /var/tmp/portage/kadu-0.3.9/work/kadu/config.log 
and my make.conf file.
But here's the result of "find / -name libsoundserver_idl.so"
/usr/kde/3.3/lib/libsoundserver_idl.so

After emerge kadu I get the same error 

>>> Configuring x11_docking module...
MODULE_LIBS:           X11
MODULE_LIBS_PATH:      /usr/X11R6/lib /usr/lib /usr/local/X11R6/lib
MODULE_INCLUDES:       X11/Xlib.h
MODULE_INCLUDES_PATH:  /usr/X11R6/include /usr/include /usr/local/include
MODULE_TOOLS:
MODULE_CONFIGURE_CMD:
checking if libX11.so/dylib library is in system directories... yes
checking if X11/Xlib.h header is in system directories... yes

>>> Configuring arts_sound module...
MODULE_LIBS:           soundserver_idl
MODULE_LIBS_PATH:      /lib /usr/kde/3.1/lib /usr/kde/3.2/lib /opt/kde/lib /opt/kde3/lib
MODULE_INCLUDES:       soundserver.h
MODULE_INCLUDES_PATH:  /include/arts /usr/include/arts /usr/kde/3.1/include/arts /usr/kde/3.2/include/arts /usr/include/kde/arts /opt/kde/include/arts /opt/kde3/include/arts
MODULE_TOOLS:
MODULE_CONFIGURE_CMD:
checking if libsoundserver_idl.so/dylib library is in system directories... no
checking for libsoundserver_idl.so in specified directiories... not found
checking for libsoundserver_idl.dylib in specified directiories... not found
configure: error: libsoundserver_idl.dylib not found!

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/kadu-0.3.9/work/kadu/config.log
Comment 2 Karol Wojtaszek (RETIRED) gentoo-dev 2005-03-18 09:18:15 UTC
Should be fixed in new release. Please, in 1 hour sync portage tree and emerge kadu-0.4.0