Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 831959

Summary: gui-wm/wayfire-0.7.3-r1 fails to compile: debug-func.hpp:5:10: fatal error: execinfo.h: No such file or directory
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: No maintainer - Look at if you want to take care of it <maintainer-needed>
Severity: normal Keywords: PullRequest
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 856418    
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2022-01-24 07:59:19 UTC

Issue: gui-wm/wayfire-0.7.2 fails to compile.
Discovered on: amd64 (internal ref: tinderbox_musl)

This machine uses MUSL libc
Comment 1 Agostino Sarubbo gentoo-dev 2022-01-24 07:59:22 UTC
Created attachment 763453 [details]

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2022-01-24 07:59:23 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:

../wayfire-0.7.2/src/debug-func.hpp:5:10: fatal error: execinfo.h: No such file or directory
/var/tmp/portage/gui-wm/wayfire-0.7.2/temp/environment: line 2087: type: locale: not found
Library execinfo found: NO
Run-time dependency libinotify found: NO (tried pkgconfig and cmake)
wf-touch| Run-time dependency doctest found: NO (tried pkgconfig and cmake)
wf-utils| Program doxygen found: NO
../wayfire-0.7.2/src/debug-func.hpp:5:10: fatal error: execinfo.h: No such file or directory
Comment 3 Agostino Sarubbo gentoo-dev 2022-09-07 13:15:29 UTC
tinderbox_musl has reproduced this issue with version 0.7.3-r1 - Updating summary.
Comment 4 Larry the Git Cow gentoo-dev 2023-12-17 19:55:27 UTC
The bug has been closed via the following commit(s):

commit a6da6e062fd05e637af7a70fe8644be36b3c579a
Author:     Alfred Wingate <>
AuthorDate: 2023-11-25 22:54:45 +0000
Commit:     Arthur Zamarin <>
CommitDate: 2023-12-17 19:55:17 +0000

    gui-wm/wayfire: add 0.8.0
    Signed-off-by: Alfred Wingate <>
    Signed-off-by: Arthur Zamarin <>

 gui-wm/wayfire/Manifest             |   1 +
 gui-wm/wayfire/wayfire-0.8.0.ebuild | 158 ++++++++++++++++++++++++++++++++++++
 gui-wm/wayfire/wayfire-9999.ebuild  | 118 ++++++++++++++++++---------
 3 files changed, 239 insertions(+), 38 deletions(-)