Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 831092

Summary: sci-libs/h5part-1.6.6: write3 test fails with MPI_ERR_INFO: invalid info object
Product: Gentoo Linux Reporter: Alex Fan <>
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: CONFIRMED ---    
Severity: normal Keywords: TESTFAILURE
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Alex Fan archtester 2022-01-13 00:20:15 UTC
on amd64 and riscv, the test phase fails with

[0] Testing  -- Write 64-bit strided data (write3)                                                    [0] ===============================================                                                   [0] Opening file once, write-truncate, lustre filesyste, MPI-POSIX VFD, 1KB alignment                 
[localhost:00055] *** An error occurred in MPI_Info_dup                                               
[localhost:00055] *** reported by process [3502899201,0]                                              [localhost:00055] *** on communicator MPI_COMM_WORLD                                                  [localhost:00055] *** MPI_ERR_INFO: invalid info object                                               [localhost:00055] *** MPI_ERRORS_ARE_FATAL (processes in this communicator will now abort,            
[localhost:00055] ***    and potentially your MPI job)                                                FAIL: test

Reproducible: Always
Comment 1 Alex Fan archtester 2022-01-13 00:22:24 UTC
I also tried disable network-sandbox and allow oversubscribing, but neither worked.
Comment 2 Alex Fan archtester 2022-01-13 00:27:16 UTC
Created attachment 762002 [details]
Comment 3 Alex Fan archtester 2022-01-13 00:27:52 UTC
Created attachment 762003 [details]