Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 830896

Summary: media-libs/lib3mf-2.2.0 fails to compile: zip.h:284:11: error: expected ; at end of member declaration
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Bernd <waebbl-gentoo>
Severity: normal CC: ionen, proxy-maint
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2022-01-10 08:34:10 UTC

Issue: media-libs/lib3mf-2.2.0 fails to compile.
Discovered on: amd64 (internal ref: tinderbox)

This machine uses CLANG as a compiler and LLD as a linker
Comment 1 Agostino Sarubbo gentoo-dev 2022-01-10 08:34:12 UTC
Created attachment 761740 [details]

build log and emerge --info
Comment 2 Bernd 2022-01-11 17:40:52 UTC
I can not reproduce this currently. On a recent test the package builds successfully for me.

Also the package shows strange behaviour on your install. Despite having -DUSE_INCLUDED_LIBZIP=OFF set and having libzip-1.8.0 installed, it tries to use the internal libzip header files.
Comment 3 Bernd 2022-04-23 08:53:58 UTC
I checked this again today in a clang / lld chroot environment and can still not reproduce it. What bothers me, you are saying the build is from an environment using clang and lld, yet the build log says it's using g++ for compiling.

Could it be, there was some configuration error with your setup when this issue popped up?
Can you please try to reproduce the bug?
Comment 4 Ionen Wolkens gentoo-dev 2022-04-23 09:26:34 UTC
This one is obscure, you need to build libzip with clang, then build lib3mf with gcc (not sure how this happened from the tinderbox though).

*** This bug has been marked as a duplicate of bug 830231 ***
Comment 5 Bernd 2022-04-23 10:50:09 UTC
Thanks for the hint Ionen. Haven't tried to reproduce it with this combination, but found a closed issue at upstreams github repository, which seems not to be fixed and added it to the See also link in bug #830231.