Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 82633

Summary: kuroo-0.53.(0|1) crashes: Xlib: unexpected async reply (sequence 0x6993)
Product: Gentoo Linux Reporter: Anthony Gorecki <anthony>
Component: [OLD] UnspecifiedAssignee: Gentoo KDE team <kde>
Severity: normal CC: x11
Priority: High    
Version: 2004.3   
Hardware: All   
OS: All   
Package list:
Runtime testing required: ---

Description Anthony Gorecki 2005-02-19 17:39:29 UTC
When navigating through the various tabs in the program, kuroo will crash randomly with the message:

Xlib: unexpected async reply (sequence 0x6993)!
In file kernel/qpixmap_x11.cpp, line 630: Out of memory
KCrash: Application 'kuroo' crashing...

This problem was originally encountered with 0.53.0, and subsequently in 0.53.1 when I upgraded the package. This appears to be an Xorg issue.

System information:

Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.4.3, glibc-, 2.6.10 i686)
System uname: 2.6.10 i686 Intel(R) Pentium(R) 4 CPU 2.66GHz
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  7 2005, 00:23:52)]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.5, 1.9.4, 1.7.9-r1, 1.6.3, 1.4_p6, 1.8.5-r3
sys-devel/libtool:   1.5.10-r4
CFLAGS="-O3 -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks noinfo prelink sandbox sfperms strict"
USE="x86 arts crypt cups gif ipv6 jpeg kdeenablefinal mmx mmx2 nptl nptlonly opengl pam pcre perl png readline sse sse2 ssl tiff unicode xv zlib"
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-19 17:53:01 UTC
What is kuroo? Is it in portage? I can't find it.
Comment 2 Anthony Gorecki 2005-02-19 18:00:14 UTC
kuroo is a GUI interface to Portage: app-portage/kuroo

I took a look at the source of this program and noticed that the author has already discovered this error and commented out several lines of code in an attempt to (temporarily) correct it. Apparently some of the troublesome setIcon() calls were missed in that effort. After commenting them out and rebuilding the source, I now receive the same error with sequence 0x1d8f. Investigating further.
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-19 18:08:21 UTC
Ah sorry, my CVS checkout was old. Since it seems like it may be programming problems on the part of the author, reassigning for now.
Comment 4 Anthony Gorecki 2005-02-19 18:22:45 UTC
This program is unstable to the point of being completely unusable and dangerous. Considering that this is a system maintenance package that can potentially invoke Portage commands in an unpredictable fashion, it may be better to hard mask it for now.
Comment 5 Gregorio Guidi (RETIRED) gentoo-dev 2005-02-20 03:55:20 UTC
see here:

I think we will mask it if this error persist when kde-3.4 is unmasked...
Comment 6 Anthony Gorecki 2005-02-20 17:46:09 UTC
Since when do we leave highly unstable packages masked only as ~devel? I don't mean to attack the package, but it simply doesn't work. The referenced KDE bug report points fingers at this program, this program points fingers at KDE, and either way, it's still not usable. I don't see why this package should receive any special treatment.
Comment 7 Gregorio Guidi (RETIRED) gentoo-dev 2005-02-21 03:21:03 UTC
The referenced KDE bug report points out that it's related to kde 3.4_beta,
which is hardmasked.
But I agree it should be masked if it affected everybody.
Comment 8 Gregorio Guidi (RETIRED) gentoo-dev 2005-02-21 05:05:17 UTC
Update: after seeing bug 82510, I think it's better to mask it for now.
Comment 9 Anthony Gorecki 2005-02-21 05:19:18 UTC
Thanks for the clarification, I must have skipped over the version string in the bug report. If this was strictly localized to KDE 3.4, leaving it unmasked would be fair enough, however I have yet to find a single KDE application that exhibits the same symptoms and I've been utilizing and testing the segregated KDE ebuilds since before they were committed to Portage. It seems to me that it's far more likely to be application specific, in which case I agree with the KDE bug report's last comment.