Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 811789

Summary: app-accessibility/at-spi2-core-2.40.3 misses dependencies on systemd
Product: Gentoo Linux Reporter: Alexey <alexey+gentoo>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: CONFIRMED ---    
Severity: normal CC: alexey+gentoo, prefix, sam
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=811795
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
emerge --info

Description Alexey 2021-09-05 20:22:45 UTC
Created attachment 737833 [details]
build.log

Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency libsystemd found: NO (tried pkgconfig)

../at-spi2-core-2.40.3/bus/meson.build:75:2: ERROR: Dependency "libsystemd" not found, tried pkgconfig
Comment 1 Alexey 2021-09-05 20:23:40 UTC
Created attachment 737836 [details]
emerge --info
Comment 2 Alexey 2021-09-05 20:53:29 UTC
I suspect the problem is this:

Program dbus-daemon found: YES (/home/user/gentoo/usr/bin/dbus-daemon)
Program dbus-broker-launch found: YES (/usr/bin/dbus-broker-launch)

which triggers this dependency on systemd in bus/meson.build:

  dbus_broker = find_program('dbus-broker-launch',
                             required: false)
  if dbus_broker.found()
    launcher_args += '-DDBUS_BROKER="@0@"'.format(dbus_broker.path())
    needs_systemd = true
  endif

maybe find_program() should ignore programs outside of EPREFIX?
Comment 3 Matt Turner gentoo-dev 2021-09-06 19:50:25 UTC
If Meson fails to find a dependency with pkgconfig, it tries with cmake. cmake is not a dependency of the package.
Comment 4 Matt Turner gentoo-dev 2021-09-06 20:15:59 UTC
I think you're right.

Looks like we need to fix meson.build to not check for dbus-broker if default_bus == dbus-daemon.