Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 785769

Summary: dev-util/catalyst should be able to create a bootable .iso image for ARM64
Product: Gentoo Linux Reporter: Einstok Fair <einfair>
Component: Current packagesAssignee: Gentoo Catalyst Developers <catalyst>
Status: RESOLVED FIXED    
Severity: enhancement CC: jstein, sam
Priority: Normal    
Version: unspecified   
Hardware: ARM64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Einstok Fair 2021-04-26 05:22:56 UTC
- The documentation should explain how to use catalyst scripts for the task.
- Downloads page for ARM64 architecture should contain .iso image in addition to stage3

Reproducible: Always
Comment 1 Matt Turner gentoo-dev 2021-06-12 18:28:01 UTC
So there's a trivial amount of plumbing that needs to be done in catalyst, but 95% of the work is making a kernel config and actually testing the resulting ISO which I can't do because I don't have hardware.

We can keep bugs like this open, but I really don't see the point. The way it gets fixed is by contributing.
Comment 2 Einstok Fair 2021-06-13 19:54:00 UTC
I have the hardware, but don't have an ISO.
I am unable to contribute because of lack of understanding what and how to do.
Comment 3 Georgy Yakovlev archtester gentoo-dev 2021-07-26 01:00:51 UTC
sent patches that enable ISO creation in catayst:
https://archives.gentoo.org/gentoo-catalyst/messages/2021-07/
Comment 4 Georgy Yakovlev archtester gentoo-dev 2021-07-26 01:02:09 UTC
releng.git now contains arm64 stages

https://gitweb.gentoo.org/proj/releng.git/tree/releases/specs/arm64

build is still disabled, some packages need stable keywords
Comment 5 Georgy Yakovlev archtester gentoo-dev 2021-07-26 01:02:31 UTC
^ i meant arm64 livecd specs, not stages.
Comment 6 Larry the Git Cow gentoo-dev 2021-07-29 01:22:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/proj/catalyst.git/commit/?id=e0b9b007b563188cca5f5317f780bb5d4bbb17d1

commit e0b9b007b563188cca5f5317f780bb5d4bbb17d1
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2021-07-25 23:51:12 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2021-07-29 00:36:42 +0000

    targets: Add arm64 livecd support
    
    Closes: https://bugs.gentoo.org/785769
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 targets/support/bootloader-setup.sh | 2 +-
 targets/support/create-iso.sh       | 7 +++++--
 2 files changed, 6 insertions(+), 3 deletions(-)