Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 778

Summary: gnome-python doesn't build correctly on my box
Product: Gentoo Linux Reporter: Daniel Lyons <fusion>
Component: [OLD] GNOMEAssignee: Tod M. Neidt (RETIRED) <tod>
Severity: normal    
Priority: High    
Version: 1.0 RC6 r14   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Daniel Lyons 2002-02-20 02:32:44 UTC
gnome-python's compile bombs out looking for capplet-widget.h.

I fixed it in the ebuild by changing the line in the GNOME section of src_compile() 
PYTHON="/usr/bin/python" CFLAGS="$CFLAGS --host=${CHOST}
PYTHON="/usr/bin/python" CFLAGS="$CFLAGS -I/usr/include/libcapplet1" ./configure 

I believe that could be called a "dirty hack" but it made the compile happen on my 
Comment 1 Tod M. Neidt (RETIRED) gentoo-dev 2002-02-21 16:13:49 UTC

Tried to reproduce this, but mine bombed on 

/usr/lib/ no such file or directory :)

I have xfree-4.2.0-r5 installed.

gnome-python needs work :)
Comment 2 Daniel Lyons 2002-02-21 16:39:51 UTC
If I can talk to someone one-on-one about ebuilds and get some generic advice, 
I'll take this ebuild AND start contributing the five or so I have on my own box.  
But first all I want is for someone to email me and tell me what the common 
mistakes are, what the accepted formatting is, etc.  What things I should do to 
ensure that my build is platform-agnostic.

I'm also willing to pitch in on documentation.  Hell, I love this distro, I just want to 
help!  Anyone who gives me a bit of a tutorial I will take some of the burden off of.
Comment 3 Tod M. Neidt (RETIRED) gentoo-dev 2002-02-23 22:40:12 UTC

I just tried to reproduce this bug on my other machine and gnome-python merged
just fine.

This leads me to believe that there is a dependency problem with the ebuild,
i.e. one that is need isn't there or doesn't specify a recent enough version.
Comment 4 Tod M. Neidt (RETIRED) gentoo-dev 2002-02-23 23:32:52 UTC

could you check what version of control-center you have merged?

I had and gnome-python merged fine.

I merged control-center- and remerged gnome-python and it was ok also?

There's a new version of gnome-python. I think I'll bump the version of cvs.
Comment 5 chouser (RETIRED) gentoo-dev 2002-02-24 16:58:49 UTC
I just saw this problem as well.  I fixed it by adding to the ebuild:

   CFLAGS="$CFLAGS `/usr/bin/gnome-config capplet --cflags`"

I had this problem with gnome-python-1.4.1-r3 and gnome-python-1.4.2 (just a
renamed copy of 1.4.1-r3, not anything that's been put in CVS recently).  The
problem first showed up after I upgraded to python-2.2-r3 (from python-2.1.1-r4)
and to control-center- (from, I think, control-center-

Hope this helps in the bug hunt. ;-)

Comment 6 Bruce A. Locke (RETIRED) gentoo-dev 2002-02-28 21:10:13 UTC
gnome-python-1.4.1-r4 builds on my system...  Please reopen bug if it doesn't
work for you...