Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 768537

Summary: games-strategy/megaglest-3.13.0 fails to compile: Failed to find configuration base-unicode-3.0
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Gentoo Games <games>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 893356    
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2021-02-03 16:15:54 UTC

Issue: games-strategy/megaglest-3.13.0 fails to compile.
Discovered on: amd64 (internal ref: tinderbox)
Comment 1 Agostino Sarubbo gentoo-dev 2021-02-03 16:15:56 UTC
Created attachment 685659 [details]

build log and emerge --info
Comment 2 kavol 2021-03-02 18:11:50 UTC
I observe the problem too - it compiles on one machine and fails on another

on the one that works, the interesting difference is this:

>>> Preparing source in /var/tmp/portage/games-strategy/megaglest-3.13.0/work/megaglest-3.13.0 ...
 * Applying megaglest-3.11.1-cmake-lua.patch ...                                                                                                                                                                                     [ ok ]
 * Working in BUILD_DIR: "/var/tmp/portage/games-strategy/megaglest-3.13.0/work/megaglest-3.13.0_build"
 * Hardcoded definition(s) removed in CMakeLists.txt:
 *      SET(CMAKE_BUILD_TYPE "RelWithDebInfo" CACHE STRING "Choose build type: None(

 * Requested wxWidgets:        3.0
 * Using wxWidgets:            gtk2-unicode-3.0

>>> Source prepared.

searching for "gtk2-unicode-3.0" it has this file installed:

while it is missing on the failing machine

on both, there is

but somehow the wxwidgets eclass is not satisfied with it, because it forces gtk2 if gtk3 not specified explicitly

so the origin seems to be in megaglest ebuild - while in DEPEND, it requires version 3.0-gtk3

        editor? ( x11-libs/wxGTK:3.0-gtk3[X,opengl] )
        fribidi? ( dev-libs/fribidi )
        model-viewer? ( x11-libs/wxGTK:3.0-gtk3[X] )

later in prepare it sets WX_GTK_VER="3.0" instead of "3.0-gtk3"

        if use editor || use model-viewer ; then

so it is a simple patch:

--- /var/db/repos/gentoo/games-strategy/megaglest/megaglest-3.13.0.ebuild~      2021-03-02 18:49:26.662946353 +0100
+++ /var/db/repos/gentoo/games-strategy/megaglest/megaglest-3.13.0.ebuild       2021-03-02 18:49:40.515185096 +0100
@@ -69,7 +69,7 @@
        if use editor || use model-viewer ; then
-               WX_GTK_VER="3.0"
+               WX_GTK_VER="3.0-gtk3"

(note that I cannot insert tabs here therefore the above won't apply :-( )

but now there is a question whether this hard version dependency could be avoided, because it obviously works (not just compiles, but both the editor and g3dviewer work) also with GTK2 version ...?
Comment 3 Pacho Ramos gentoo-dev 2023-11-20 09:36:51 UTC
WX_GTK_VER is properly set now to avoid this