Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 762232

Summary: media-sound/dvda-author-10.06-r1 calls ar directly
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Gentoo Sound Team <sound>
Status: RESOLVED FIXED    
Severity: normal CC: jakov.smolic
Priority: Normal Keywords: PullRequest
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://github.com/gentoo/gentoo/pull/18868
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2020-12-28 13:17:49 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: media-sound/dvda-author-10.06-r1 calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-12-28 13:17:51 UTC
Created attachment 680053 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-12-28 13:17:53 UTC
Possible context of error(s):

make[4]: ar: No such file or directory
Comment 3 Larry the Git Cow gentoo-dev 2020-12-29 16:40:13 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c7de0f8340f24f7d55edb67242f3969ee3eeca2b

commit c7de0f8340f24f7d55edb67242f3969ee3eeca2b
Author:     Jakov Smolic <jakov.smolic@sartura.hr>
AuthorDate: 2020-12-29 16:40:03 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2020-12-29 16:40:03 +0000

    media-sound/dvda-author: Respect AR
    
    Closes: https://bugs.gentoo.org/762232
    Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
    Signed-off-by: David Seifert <soap@gentoo.org>

 media-sound/dvda-author/dvda-author-10.06-r1.ebuild | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)