Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 76142

Summary: ARTS/GSTREAMER endianess
Product: Gentoo Linux Reporter: iago <iagofrombrad>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Severity: major CC: lu_zero, ppc
Priority: High    
Version: unspecified   
Hardware: PPC   
OS: Linux   
Whiteboard: sound
Package list:
Runtime testing required: ---
Attachments: arts-bigendian.patch

Description iago 2004-12-30 07:01:27 UTC
When I try to play some mp3 with kde_players/juk/amarok I get only an awful noise. I believe it's related to mp3 endianess. I haven't the same problem with wave files. I haven't tried other formats like ogg.
I haven't problems using mplayer or xmms, which use alsa directly.

Reproducible: Always
Steps to Reproduce:

Actual Results:  
I can't hear any music.

Expected Results:  
Play sounds, not noise!
Comment 1 iago 2004-12-30 07:02:47 UTC
My kdemultimedia version is 3.3.1.
Comment 2 iago 2004-12-30 10:25:55 UTC
Aditional note: mplayer using arts as audio output plays good mp3s.
Comment 3 Gregorio Guidi (RETIRED) gentoo-dev 2004-12-30 11:36:05 UTC
A few candidates:

maybe you can add some information there (as the output of 'artsd -l0'), 
there are probably more people able to debug this issue there.
Comment 4 Gregorio Guidi (RETIRED) gentoo-dev 2005-01-09 12:36:52 UTC
Created attachment 48039 [details, diff]

Can someone test this?
There was a similar fix for alsa5 around, do not expect too much though...
Comment 5 iago 2005-01-15 04:59:24 UTC
I'm trying it. Soon I will able to tell you if it's all right.
I must say that the old alsa-bigendian patch didn't work on my PC.
Comment 6 iago 2005-01-20 08:33:05 UTC
Well, I used this patch, but I can't listen correctly to mp3 files. I haven't tried with ogg because I haven't one.
I can listen to wav files and uncompressed one, but I hear a bad noise with mp3s. Thanks a lot.
Comment 7 Lars Weiler (RETIRED) gentoo-dev 2005-05-07 16:20:00 UTC
Is this bug still an issue?
Comment 8 Lars Weiler (RETIRED) gentoo-dev 2005-05-07 16:20:37 UTC
Forgot to change to NEEDINFO
Comment 9 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-25 05:53:22 UTC
No feedback.