Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 75681

Summary: media-gfx/UFRaw - a plugin for GIMP (new ebuild)
Product: Gentoo Linux Reporter: Lukas Miczka <cpu>
Component: New packagesAssignee: Gentoo Graphics Project <graphics+disabled>
Severity: enhancement CC: allanonjl, graphics+disabled, msl, nattfodd, sebastian
Priority: High Keywords: EBUILD
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: ebuild for ufraw-0.4
patch for ufraw Makefile
ebuild for ufraw cvs
Quick and dirty ebuild update

Description Lukas Miczka 2004-12-26 02:52:36 UTC
This is plugin for gimp wich allows to manipulate RAW img based on dcraw there it is in apt-get :))) so it should be in portage too cause it's worth here is www

Reproducible: Always
Steps to Reproduce:
Comment 1 Lukas Miczka 2005-01-24 12:07:59 UTC 
new home site adress 
I hope this will interest someone at least
Comment 2 Reuben Martin 2005-02-10 12:16:15 UTC
I would like to second the nomination of ufraw to portage. We have people trying to get Bibble rpms to work on Gentoo who are not aware that this program can preform the same functions as good if not better at no cost.

Dependencies will be dcraw, lcms, zlib, jpeg, tiff, and optional gimp>=2.0 for the gimp plugin.
Comment 3 Dominik Behr 2005-02-11 22:09:40 UTC
Created attachment 51043 [details]
ebuild for ufraw-0.4

This is an ebuild for ufraw 0.4
Comment 4 Dominik Behr 2005-02-11 22:11:10 UTC
Created attachment 51044 [details, diff]
patch for ufraw Makefile

this is the patch that needs to be placed in files subdir. it patches Makefile
so it can find lcms.h header needed for building ufraw.
Comment 5 Dominik Behr 2005-02-11 22:13:41 UTC
the current url for ufraw is
Comment 6 Ian Goldby 2005-02-25 13:28:47 UTC
Thanks for the ebuild. I tried it and it works.

(Just in case anyone else is wondering what to do with the files:
1. Copy the ebuild to media-gfx/ufraw/ufraw-0.4.ebuild, preferably in your
   PORTDIR_OVERLAY directory.
2. Execute "ebuild ufraw-0.4.ebuild digest".
3. Copy the patch to media-gfx/ufraw/files/ufraw-0.4-lcms.patch
4. ACCEPT_KEYWORDS="~x86" emerge -av ufraw
5. Launch the GIMP and open a raw file. The ufraw import dialog should appear.
Comment 7 Anthony Staines 2005-04-19 14:56:18 UTC
Thanks to all of you, especially Lukas and Ian. I tried it too, and it works beautifully.
Linux  2.6.10-gentoo-r4 Pentium III (Coppermine) GenuineIntel GNU/Linux

Please consider adding it to Portage..
Comment 8 Paul de Vries 2005-04-25 12:51:15 UTC
Works like a charm. However to prevent a security warning, copy the patch file first to the files directory ("mkdir files" if it does not exists yet) before the step: 
Execute "ebuild ufraw-0.4.ebuild digest"
Comment 9 Hal Engel 2005-06-25 18:59:55 UTC
Tried this on amd64 system and it has problems with integer to pointer casts and
some fuctions using 32 bit parameters for pointers.  So this is not 64 bit
compatable.  I opened a bug upstream.
Comment 10 Hal Engel 2005-07-25 17:06:55 UTC
The amd64 problems have now been fixed in CVS which will eventualy be version
0.5.  I will second that this should be in portage.  Perhaps 0.5 would be a good
point to get this into portage.
Comment 11 Dominik Behr 2005-08-22 23:43:45 UTC
Created attachment 66618 [details]
ebuild for ufraw cvs

For people who want to try upcoming 0.5 and amd64 folks, here is a cvs ebuild.
Comment 12 Nir Dremer 2005-09-25 01:54:56 UTC
0.4 works good for me, thanks!
Comment 13 Lukas Miczka 2005-09-25 15:01:29 UTC
There is new UFRaw version (0.5) relased today (25.09.2005)
Comment 14 Luca Barbato gentoo-dev 2005-09-25 19:19:16 UTC
I'd make the gimp dep optional since it could be used as a stand alone program.

If I have time I'll have a deeper look.
Comment 15 Luca Barbato gentoo-dev 2005-09-26 13:33:02 UTC
Created attachment 69287 [details]
Quick and dirty ebuild update

Here a quite raw ebuild that loos a bit saner.

I'm thinking about making it an alternative to dcraw or just provide the extra
tools w/out dcraw provided by ufraw.

I'm too tired to commit now, please test and report problems
Comment 16 Dominik Behr 2005-09-27 00:27:16 UTC
It works very well for me and it is much better and cleaner than my attempts.
Also, you can probably enable ~amd64. 0.5 is supposed to be safe for amd64 and a
friend of mine tested 0.5-cvs ebuild on amd64 and it worked for him. It would be
great if you checked it in. I think there are many people who would use it.
Comment 17 Matthew Bevan 2005-10-25 17:29:43 UTC
I've tested on x86 and amd64, and ran it through a large number (>100) of raw 
files from my Olympus C-8080wz.  Results are great!  At least adding ~amd64 
would be a Good Thing(TM). 
Comment 18 Jan Dohl 2005-10-31 14:59:42 UTC
Compiled and tested on amd64 with Nikon D50 NEF files from within Gimp. Works as 
expected so far. So I agree with this ebuild to be ready for ~amd64.
Comment 19 Hal Engel 2005-11-12 12:59:16 UTC
This should have the ~amd64 flag.  I have been using this for months on my amd64
machine and there are abolutely no problems.
Comment 20 Philippe Schleusner 2005-11-17 10:47:05 UTC
ufraw-0.5 compiles and run on amd64. Please add ~amd64 flag.
Comment 21 Uberto Barbini 2005-11-22 13:59:20 UTC
Changing the name to 0.6 (and making the digest) work perfectly here on a amd64
Comment 22 Marcelo Goes (RETIRED) gentoo-dev 2005-11-26 09:34:03 UTC
Isn't this in the tree already?
Can we close this bug?
Comment 23 Sönke N. Greimann 2005-12-03 09:45:52 UTC
ufraw-0.6 is borked for me. It loads images just fine but fails to spit them
out. This affects all uses, from ufraw-batch to the gimp-plugin. Rollback to 0.5
fixes it.

Since ufraw is in ~arch people using it will probably run into this, so maybe
hard-masking 0.6 is in order until this is resolved?
Comment 24 Marcelo Goes (RETIRED) gentoo-dev 2005-12-03 09:55:06 UTC
Added =media-gfx/ufraw-0.6 to package.mask.
Comment 25 Marcelo Goes (RETIRED) gentoo-dev 2005-12-10 10:04:27 UTC
Marking as fixed. Please open a new bug for problems with ufraw in the tree.
Comment 26 Alexandre Buisse (RETIRED) gentoo-dev 2006-04-01 06:05:38 UTC
I have removed ufraw-0.6 from package.mask as 0.7 is now in ~arch. Besides, no details on the bug were given and 0.6 worked fine here...