Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 750368

Summary: dev-ml/uutf-1.0.1 : is not a compiled interface for this version of OCaml.
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Team for the ML programming language family <ml>
Status: RESOLVED DUPLICATE    
Severity: normal CC: dev-portage, sam
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge-info.txt
dev-ml:uutf-1.0.1:20201019-225722.log
emerge-history.txt
environment
etc.portage.tbz2
temp.tbz2
emerge.log.bz2

Description Toralf Förster gentoo-dev 2020-10-20 07:23:10 UTC
File "./pkg/pkg.ml", line 1:
Error: /usr/lib64/ocaml/topkg/topkg.cmi
       is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.
 * ERROR: dev-ml/uutf-1.0.1::gentoo failed (compile phase):
 *   (no error message)

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-libressl_abi32+64-20201012-091521

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-10.2.0 *
clang version 11.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/11/bin
/usr/lib/llvm/11
11.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.9 (fallback)
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby25 (with Rubygems)
  [2]   ruby26 (with Rubygems)
  [3]   ruby27 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.47.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.265_p01 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.8.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon Oct 19 10:05:28 PM UTC 2020
/var/db/repos/libressl	Sun Oct 18 04:35:14 PM UTC 2020

emerge -qpvO dev-ml/uutf
[ebuild  N    ] dev-ml/uutf-1.0.1  USE="ocamlopt -doc -test -utftrip"
Comment 1 Toralf Förster gentoo-dev 2020-10-20 07:23:12 UTC
Created attachment 667433 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-10-20 07:23:13 UTC
Created attachment 667436 [details]
dev-ml:uutf-1.0.1:20201019-225722.log
Comment 3 Toralf Förster gentoo-dev 2020-10-20 07:23:15 UTC
Created attachment 667439 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-10-20 07:23:16 UTC
Created attachment 667442 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-10-20 07:23:17 UTC
Created attachment 667445 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-10-20 07:23:18 UTC
Created attachment 667448 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-10-20 08:17:34 UTC
Created attachment 667493 [details]
emerge.log.bz2

the whole emerge.log
Comment 8 Sam James archtester gentoo-dev Security 2020-10-20 08:27:50 UTC
topkg doesn't seem to have been rebuilt here. Not sure why yet.

topkg gets installed originally (2020-10-13T18:41:33), then later on OCaml is updated (2020-10-13T20:06:09), but topkg doesn't get rebuilt.
Comment 9 Sam James archtester gentoo-dev Security 2020-10-20 09:03:01 UTC
*** Bug 750365 has been marked as a duplicate of this bug. ***
Comment 10 Zac Medico gentoo-dev 2020-10-20 21:21:56 UTC
The log shows that --deep was not used, which is an possible indication that this is a duplicate of bug 731150:

> 1603148173: Started emerge on: Oct 20, 2020 00:56:13
> 1603148173:  *** emerge --verbose-conflicts --nospinner --tree --update --autounmask=n --autounmask-keep-masks --color=n --complete-graph --with-bdeps=y --quiet-build=y --regex-search-auto=y --verbose dev-ml/markup
> 1603148227:  >>> emerge (1 of 5) dev-ml/uchar-0.0.2 to /
> 1603148227:  === (1 of 5) Cleaning (dev-ml/uchar-0.0.2::/var/db/repos/gentoo/dev-ml/uchar/uchar-0.0.2.ebuild)
> 1603148227:  === (1 of 5) Compiling/Merging (dev-ml/uchar-0.0.2::/var/db/repos/gentoo/dev-ml/uchar/uchar-0.0.2.ebuild)
> 1603148233:  === (1 of 5) Merging (dev-ml/uchar-0.0.2::/var/db/repos/gentoo/dev-ml/uchar/uchar-0.0.2.ebuild)
> 1603148238:  >>> AUTOCLEAN: dev-ml/uchar:0
> 1603148242:  === (1 of 5) Post-Build Cleaning (dev-ml/uchar-0.0.2::/var/db/repos/gentoo/dev-ml/uchar/uchar-0.0.2.ebuild)
> 1603148242:  ::: completed emerge (1 of 5) dev-ml/uchar-0.0.2 to /
> 1603148243:  >>> emerge (2 of 5) dev-ml/uutf-1.0.1 to /
> 1603148243:  === (2 of 5) Cleaning (dev-ml/uutf-1.0.1::/var/db/repos/gentoo/dev-ml/uutf/uutf-1.0.1.ebuild)
> 1603148243:  === (2 of 5) Compiling/Merging (dev-ml/uutf-1.0.1::/var/db/repos/gentoo/dev-ml/uutf/uutf-1.0.1.ebuild)
> 1603148246:  *** Finished. Cleaning up...
> 1603148246:  *** exiting unsuccessfully with status '1'.
> 1603148246:  *** terminating.
Comment 11 Tupone Alfredo gentoo-dev 2021-07-05 19:10:14 UTC

*** This bug has been marked as a duplicate of bug 731150 ***