Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 738116

Summary: games-emulation/dosbox-staging-0.75.0 calls ar directly
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Bernard Cafarelli <voyageur>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: build.log
1-autoconf.out

Description Agostino Sarubbo gentoo-dev 2020-08-20 05:06:08 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: games-emulation/dosbox-staging-0.75.0 calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-08-20 05:06:11 UTC
Created attachment 655578 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-08-20 05:06:12 UTC
Created attachment 655580 [details]
1-autoconf.out

1-autoconf.out
Comment 3 Larry the Git Cow gentoo-dev 2020-09-04 21:26:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0d7dc6ce882f0189e8340630c9bd1fdf75f02d10

commit 0d7dc6ce882f0189e8340630c9bd1fdf75f02d10
Author:     Bernard Cafarelli <voyageur@gentoo.org>
AuthorDate: 2020-09-04 21:25:48 +0000
Commit:     Bernard Cafarelli <voyageur@gentoo.org>
CommitDate: 2020-09-04 21:26:21 +0000

    games-emulation/dosbox-staging: small fixes
    
    Do not call ar directly
    Fix icon installation
    Use provided desktop file
    
    Closes: https://bugs.gentoo.org/738116
    Closes: https://bugs.gentoo.org/738470
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>

 .../dosbox-staging/dosbox-staging-0.75.1-r2.ebuild | 51 ++++++++++++++++++++++
 .../files/dosbox-staging-0.75.1-ar.patch           | 11 +++++
 2 files changed, 62 insertions(+)