Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 737276

Summary: sys-fs/udev - systemd-udevd[...]: sfX: Worker [...] processing SEQNUM=[...] is taking a long time
Product: Gentoo Linux Reporter: guser90
Component: Current packagesAssignee: Gentoo systemd Team <systemd>
Status: UNCONFIRMED ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info

Description guser90 2020-08-15 22:25:45 UTC
Created attachment 654832 [details]
emerge --info

Hi, 

I'm not sure if I should report it here or directly to linux kernel community. But maybe it has to do with the gentoo configuration.

Harware: z97 chipset.

Gentoo 1:
Udev 245.5-r1
Kernel 5.4.48-gentoo

Gentoo 2:
Udev 238
Kernel 4.9.95

Please notice both Gentoo installations run on the same hardware machine.

Gentoo 1:
1. Insert the usb pendrive into the slot.
2. Wait until it is detected (observation with the help of dmesg -w).
3. Take out the usb pendrive from the slot.
4. Repeat steps 1-3 x times. I have tried with multiple pendrives.
5. Usb pendrive cannot be detected any more. Amperage is 0 (measured with a logilink measuring device). Dmesg shows the following issue:
systemd-udevd[2311]: sfX: Worker [3783] processing SEQNUM=3192 is taking a long time
systemd-udevd[2311]: sfX: Worker [3783] processing SEQNUM=3192 killed
Putting it in and taking it out again doesn't help. At least a couple of slots stop working at once. Probably all from a particular controller.

I can reproduce it pretty quickly. It takes about 1-5 minutes to reproduce. I can't link the problem to a specific pendrive. I think any might cause it.


Gentoo 2:
The problem described in Gentoo 1 cannot be reproduced. I have tried over half an hour and I wasn't able to hang usb. Dmesg kept showing me the connection and disconnection and the pendrive was powered all the time.

I also described the problem here https://forums.gentoo.org/viewtopic-t-1117598.html Besides, I was only testing with usb 3.0.

Thanks for help.