Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 737212

Summary: dev-perl/Authen-Libwrap-0.230.0-r1 fails to link with LLD because of /usr/lib in the link command line
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Gentoo Perl team <perl>
Status: RESOLVED FIXED    
Severity: normal CC: kentnl
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 723238, 731004    
Attachments: build.log

Description Agostino Sarubbo gentoo-dev 2020-08-15 05:21:48 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-perl/Authen-Libwrap-0.230.0-r1 fails to link with LLD because of /usr/lib in the link command line.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
This PR gives an idea about a fix: https://github.com/PhotoFlare/photoflare/pull/248/files.
Comment 1 Agostino Sarubbo gentoo-dev 2020-08-15 05:21:50 UTC
Created attachment 654722 [details]
build.log

build log and emerge --info
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2020-08-16 01:29:05 UTC
Its worth mentioning that LD in environment *cant* be to blame for this, because `LD` gets shot in src_configure due to other perl problems.

Its only indicative of `CC`'s default LD.

How to reliably reproduce this issue is not clear to me at this point, and tips to replicate would be welcome. Patch incomming that *should* work.
Comment 3 Larry the Git Cow gentoo-dev 2020-08-16 01:32:07 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8cd94a41de24204614aa921c19262c8e53333a26

commit 8cd94a41de24204614aa921c19262c8e53333a26
Author:     Kent Fredric <kentnl@gentoo.org>
AuthorDate: 2020-08-16 01:26:19 +0000
Commit:     Kent Fredric <kentnl@gentoo.org>
CommitDate: 2020-08-16 01:29:35 +0000

    dev-perl/Authen-Libwrap: -r bump fix for bug #737212
    
    This overrides the magic detection in Build.PL, which was previously
    creating problems for LD=lld due to the inclusion of "/usr/lib/" instead
    of "/usr/lib64/".
    
    This employs get_libdir to resolve the right version, and passes
    expected config into Build.PL, and patches Build.PL to simply die when
    the passed values don't look usable, instead of doing some weird config
    discovery which could possibly do wrong things.
    
    Bug: https://bugs.gentoo.org/737212
    Package-Manager: Portage-2.3.103, Repoman-2.3.22
    Signed-off-by: Kent Fredric <kentnl@gentoo.org>

 .../Authen-Libwrap-0.230.0-r2.ebuild               | 46 ++++++++++
 .../files/Authen-Libwrap-0.23-inc-paths.patch      | 98 ++++++++++++++++++++++
 2 files changed, 144 insertions(+)
Comment 4 Kent Fredric (IRC: kent\n) gentoo-dev 2020-08-16 01:40:34 UTC
(In reply to Larry the Git Cow from comment #3)
> The bug has been referenced in the following commit(s):
> 
> https://gitweb.gentoo.org/repo/gentoo.git/commit/
> ?id=8cd94a41de24204614aa921c19262c8e53333a26
> 
> commit 8cd94a41de24204614aa921c19262c8e53333a26
> Author:     Kent Fredric <kentnl@gentoo.org>
> AuthorDate: 2020-08-16 01:26:19 +0000
> Commit:     Kent Fredric <kentnl@gentoo.org>
> CommitDate: 2020-08-16 01:29:35 +0000
> 
>     dev-perl/Authen-Libwrap: -r bump fix for bug #737212
>     
>     This overrides the magic detection in Build.PL, which was previously
>     creating problems for LD=lld due to the inclusion of "/usr/lib/" instead
>     of "/usr/lib64/".
>     
>     This employs get_libdir to resolve the right version, and passes
>     expected config into Build.PL, and patches Build.PL to simply die when
>     the passed values don't look usable, instead of doing some weird config
>     discovery which could possibly do wrong things.
>     
>     Bug: https://bugs.gentoo.org/737212
>     Package-Manager: Portage-2.3.103, Repoman-2.3.22
>     Signed-off-by: Kent Fredric <kentnl@gentoo.org>
> 
>  .../Authen-Libwrap-0.230.0-r2.ebuild               | 46 ++++++++++
>  .../files/Authen-Libwrap-0.23-inc-paths.patch      | 98
> ++++++++++++++++++++++
>  2 files changed, 144 insertions(+)

^ please test
Comment 5 Larry the Git Cow gentoo-dev 2020-09-17 12:18:11 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0b052d74e022960b785ee76a7d64361e667ab1cb

commit 0b052d74e022960b785ee76a7d64361e667ab1cb
Author:     Kent Fredric <kentnl@gentoo.org>
AuthorDate: 2020-09-17 12:17:06 +0000
Commit:     Kent Fredric <kentnl@gentoo.org>
CommitDate: 2020-09-17 12:17:06 +0000

    dev-perl/Authen-Libwrap: Cleanup old 0.230.0-r1
    
    Closes: https://bugs.gentoo.org/737212
    Package-Manager: Portage-3.0.4, Repoman-3.0.1
    Signed-off-by: Kent Fredric <kentnl@gentoo.org>

 .../Authen-Libwrap-0.230.0-r1.ebuild               | 41 ----------------------
 1 file changed, 41 deletions(-)