Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 735026

Summary: media-plugins/mythplugins-31.0 : ripping select tracks in mythmusic fails
Product: Gentoo Linux Reporter: Stephen Kirkby <bugs>
Component: Current packagesAssignee: Wilson M. Michaels <thebitpit>
Status: UNCONFIRMED ---    
Severity: normal CC: proxy-maint
Priority: Normal Keywords: PATCH, UPSTREAM
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://code.mythtv.org/trac/ticket/13650
https://code.mythtv.org/trac/ticket/13635
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: mythplugins-Support_ripping_subsets_of_tracks.patch

Description Stephen Kirkby 2020-08-01 10:51:22 UTC
When selecting "Rip CD" in mythmusic, on the track selection screen:

- if all tracks are selected, it works and rips fine
- if the first track isn't selected but the rest are, it fails with error "Failed to create encoder" 


Reported upstream: 

https://code.mythtv.org/trac/ticket/13635

but posting here also as I have a proposed patch for this now (attached).
Also have a working ebuild here:

https://github.com/moodytux/portage-overlay/blob/master/media-plugins/mythplugins/mythplugins-31.0-r1.ebuild

When testing this, bear in mind there is another outstanding issue which makes the UI hang before Ripping the CD, which I've also reported:

https://code.mythtv.org/trac/ticket/13650

along with a simple work around, which is to add an entry to /etc/hosts before entering the Rip CD screen.


Reproducible: Always

Steps to Reproduce:
1. Select "Rip CD" in mythmusic
2. On the track selection screen, deselect the first track
3. Select Rip
Actual Results:  
Error shown: "Failed to create encoder"

Expected Results:  
Should perform the rip.
Comment 1 Stephen Kirkby 2020-08-01 10:52:15 UTC
Created attachment 651958 [details, diff]
mythplugins-Support_ripping_subsets_of_tracks.patch