Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 734176

Summary: media-sound/lilypond calls ar directly
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Scheme Project <scheme>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    
Attachments: build.log
other.tar.bz2

Description Agostino Sarubbo gentoo-dev 2020-07-28 09:22:09 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: media-sound/lilypond calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-07-28 09:22:14 UTC
Created attachment 651090 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-07-28 09:22:17 UTC
Created attachment 651092 [details]
other.tar.bz2

other logs
Comment 3 Larry the Git Cow gentoo-dev 2020-09-05 08:31:46 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=567c5bc07e771ba1d236510cd9ada578700b61c3

commit 567c5bc07e771ba1d236510cd9ada578700b61c3
Author:     Miroslav Šulc <fordfrog@gentoo.org>
AuthorDate: 2020-09-05 08:31:24 +0000
Commit:     Miroslav Šulc <fordfrog@gentoo.org>
CommitDate: 2020-09-05 08:31:40 +0000

    media-sound/lilypond: fixed hardcoded ar command
    
    Closes: https://bugs.gentoo.org/734176
    Package-Manager: Portage-3.0.5, Repoman-3.0.1
    Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>

 media-sound/lilypond/lilypond-2.21.1-r1.ebuild | 7 +++++--
 media-sound/lilypond/lilypond-2.21.4-r1.ebuild | 7 +++++--
 media-sound/lilypond/lilypond-9999.ebuild      | 7 +++++--
 3 files changed, 15 insertions(+), 6 deletions(-)