Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 732758

Summary: dev-lang/lazarus-2.0.12: version bump
Product: Gentoo Linux Reporter: Christian Becker <xpistianbecker2>
Component: Current packagesAssignee: Amy Liffey <amynka>
Status: RESOLVED FIXED    
Severity: normal CC: gentoobug, jstein, sam
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://forum.lazarus.freepascal.org/index.php/topic,53455.0.html
See Also: https://bugs.gentoo.org/show_bug.cgi?id=707388
https://bugs.gentoo.org/show_bug.cgi?id=818142
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 817998    

Description Christian Becker 2020-07-15 17:32:55 UTC
Lazarus IDE 2.0.10 was released July 11th.
Comment 1 Christian Becker 2020-09-20 17:28:31 UTC
(In reply to Christian Becker from comment #0)
> Lazarus IDE 2.0.10 was released July 11th.

Updated an older ebuild for 2.0.10

https://github.com/Mikrotherion/gentoo-overlay/tree/Mikrotherion-update-2.0.10/dev-lang/lazarus
Comment 2 Konstantin M√ľnning 2020-11-03 00:10:44 UTC
Should go ahead with this as in-tree lazarus-2.0.6 does not compile with dev-lang/fpc-3.2.0.
Comment 3 Andreas Sturmlechner gentoo-dev 2021-03-15 16:28:02 UTC
*** Bug 728388 has been marked as a duplicate of this bug. ***
Comment 4 Christian Becker 2021-06-01 11:18:36 UTC
Ebuild for lazarus 2.0.12

Compiles fine, but upon starting Lazarus it complains about not being able to write a config file to /etc/lazarus/ - as a workaround you can make that directory and give writing permissions to everyone/ your normal user.

https://github.com/Mikrotherion/gentoo-overlay/blob/Mikrotherion-update-2.0.12/dev-lang/lazarus/lazarus-2.0.12.ebuild
Comment 5 tonich 2021-07-12 15:07:11 UTC
Got the same problem as described here: #690060
Comment 6 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-10-14 10:53:13 UTC
Please do attach a patch / make a PR as preferred for ::gentoo if there's additional fixes to be added. Thanks!

Can't switch to Qt5 without packaging qtpas and I have no idea about Pascal at all.
Comment 7 Larry the Git Cow gentoo-dev 2021-10-14 10:54:13 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ac45bc70f2a217d80f84fa2968fd36a762762c6b

commit ac45bc70f2a217d80f84fa2968fd36a762762c6b
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-14 10:48:07 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-14 10:54:00 +0000

    dev-lang/lazarus: add 2.0.12
    
    Bug: https://bugs.gentoo.org/732758
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-lang/lazarus/Manifest              |  1 +
 dev-lang/lazarus/lazarus-2.0.12.ebuild | 83 ++++++++++++++++++++++++++++++++++
 2 files changed, 84 insertions(+)