Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 729476

Summary: dev-util/android-studio should depend on dev-libs/libdbusmenu
Product: Gentoo Linux Reporter: Paul Preney <paul>
Component: Current packagesAssignee: Jason Zaman <perfinion>
Status: CONFIRMED ---    
Severity: normal CC: dan, paul
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Paul Preney 2020-06-24 22:07:23 UTC
This emerge output: 

    !!! existing preserved libs:
    >>> package: dev-libs/libdbusmenu-16.04.0-r1
     *  - /usr/lib64/libdbusmenu-glib.so.4
     *  - /usr/lib64/libdbusmenu-glib.so.4.0.12
     *      used by /opt/android-studio/bin/libdbm64.so (dev-util/android-studio-3.6.3.0.192.6392135)
    Use emerge @preserved-rebuild to rebuild packages using these libraries

is fixed by installing dev-libs/libdbusmenu which appears to be a missing dependency.
Comment 1 jorgicio 2020-07-10 02:38:42 UTC
I confirm this.

I had installed another package, which depends on libdbusmenu. After removed it, did a cleanup and libdbusmenu was removed, but android-studio complains about it. Reinstalled android-studio and still complaining, so indeed, it depends on libdbusmenu.
Comment 2 Winston Weinert 2020-08-10 22:02:13 UTC
This issue exists with dev-util/android-studio-4.0.1.0.193.6626763 as
well:

!!! existing preserved libs:
>>> package: dev-libs/libdbusmenu-16.04.0-r1
 *  - /usr/lib64/libdbusmenu-glib.so.4
 *  - /usr/lib64/libdbusmenu-glib.so.4.0.12
 *      used by /opt/android-studio/bin/libdbm64.so (dev-util/android-studio-4.0.1.0.193.6626763)
Comment 3 Marek Szuba archtester gentoo-dev 2021-04-29 12:17:57 UTC
I have just reproduced this with 4.1.3.0.201.7199119.